Jump to content
partTimePilot

[Temporary]IXEG 737 in X-Plane 11 How to get it work

Recommended Posts

Hey guys, 

I have the fabulous 737 from IXEG working in XP11. Because this plane is not officially supported in XP 11 yet, I had to do a few tweeks to get the bird flying.
I see a lot of people, asking the same questions in this regard here. What I'd like to do with this post, is to help people who would like to use the 737 in XP 11, by providing a single post with all the required steps so that people don't have to search that much. 

So, here we go:

Installation

  • Install XP 11 as you like by using the X-Plane 11 Installer.exe
  • Install the IXEG by using the windows-installer.exe that comes with the download
  • Specify your XPlane 11 (not 10!) root folder when asked by the IXEG installer

When this is done you may, or may not be able to already fly the plane without further tweaking. However, I wasn't and here are the two tweaks I did. 

Fixing APU not starting and plane not correctly responding to thrust problems 

  • Make a backup of the file B733.acf under X-Plane11\Aircraft\X-Aviation\IXEG 737 Classic
     
  • In your XP11 root folder, open PlaneMaker.exe
  • Select File -> Open and find the file B733.acf under X-Plane11\Aircraft\X-Aviation\IXEG 737 Classic
  • Select Standard -> Systems
  • Navigate to the Electrical tab
  • Check the following APU Checkboxs:
    • auxiliary power unit (APU)
    • APU provides bleed air for engine start
    • APU provides generator for electrical supply
      APU Fix.PNG
  • Close the View with X (Note: Close the view, not the program)
  • Select Standard -> Engine Specs
  • Select the Description tab
    • Set hi idle fuel adjustment to 1.16 (fuel ratio)
    • Set lo idle fuel adjustment to 0.88 (fuel ratio)
      EngineFix.PNG
  • Close the View with X (Note: Close the view, not the program)
  • Select File -> Save
  • Quit PlaneMaker.exe

And that's it. Go have a good time flying this beauty :-) 

For the sake of completeness:
I use

  • Windows 7 Home Premium (Version 6.1; Build 7601: Service Pack 1)
  • X-Plane 11.01r2 
  • IXEG 737 1.0.7
  • No other add ons

Cheers, 
Chris


 

Edited by Morten
added make a backup step
  • Upvote 9

Share this post


Link to post
Share on other sites

I'm able to start the fab IXEG from cold and dark without the tweek.(but thanks, nevertheless!) The only problem I have is after start and pushing the throttles up to get her moving, she slips and slides all over the place. My workaround has been to put her in reverse thrust to get back to my original position while using my rudder pedals... at this point there is still slipping, so I again put her into reverse thrust and then normal thrust...several times.  (while taxiing out, I sometimes have to repeat this routine),,,Suddenly, like magic, the plane does what I want.  I can then line up, set my power and take off.

Problem don't end there. Some gizmo crashes if I change the FMS, drag is not normal for flaps/speed brakes and I'm sure a few other things I haven't noticed..but the plane will fly and mostly follow the route! OH! I Take that back.  I mostly have to use the heading knob/function to follow the route most of the time, but not all the time.

So, I'm still getting a little dose of IXEG when needed :) Absolutely love this plane and hope the update to the update is near.

Anyone else trying this method? It's crazy, but it works lol

Share this post


Link to post
Share on other sites

I have the sliding only just after pushback and after starting one engine. I pay attention to not pushing and turning but only pushing straight else the plane is likely to crash. Once both engines are on I can safely taxi to the holding point. And once in the air the plane is working fine with the only annoying exception of the (almost non existing) drag, but we understand it's a known problem with xp11. So here the trick is to start an early descent enough to slow down properly and intercept the g/s leveled. Continuous descent approaches are a bit tough actually atm.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 5/25/2017 at 0:26 PM, TimeTraveler said:

The only problem I have is after start and pushing the throttles up to get her moving, she slips and slides all over the place. 

Yup, had the same problem without the tweaking. The above Engine Specs fix with Plane Maker solved that for me. 

  • Upvote 1

Share this post


Link to post
Share on other sites

nice one, great advice will I need to do this when install the new 1.1? removed XP10 now so need this one in 11, I miss her....

Share this post


Link to post
Share on other sites
8 hours ago, wain said:

nice one, great advice will I need to do this when install the new 1.1? removed XP10 now so need this one in 11, I miss her....

Thank you, wain.

I don't know if these tweaks are needed. I did not have time to test the update yet. 

I will update this thread once I had. If you do so first, you are more than welcome to share your experiences.

Cheers

Share this post


Link to post
Share on other sites

As it looks of now, you STILL have to fiddle with the settings. Just tried it. APU won't start. Engine Spoolup slow.

Kinda bad that theres no X11 aircraft file included ....

Oliver

@Litjan @Cameron

Share this post


Link to post
Share on other sites
11 minutes ago, Cebulon said:

As it looks of now, you STILL have to fiddle with the settings. Just tried it. APU won't start. Engine Spoolup slow.

Kinda bad that theres no X11 aircraft file included ....

Oliver

@Litjan @Cameron

That's correct. X-Plane 11 is at your own risk. From a code perspective we alleviated what was causing issues taxiing around. For those adventurous enough to dabble in 11 and not care about flight characteristics, you can have some fun then.

  • Upvote 1

Share this post


Link to post
Share on other sites

@Cameron i am fully aware of the XP11 issues and that 1.1 is just a ninja fix. Thats okay and the aircraft is well flyable in XP11.

I AM happy enough, when the ground handling is fixed for now.

BUT, theres enough people arround which would be happy to have the acf file available with the APU fix and the HIGH/LOW idle fix included.

i am able to fix that in a minute, others aren't. I am sure there will be a huge number of questions coming up again and again.

Little wor for a dev, happy people all around ;-) LOL

 

Happy flying

 

 

Edited by Cebulon

Share this post


Link to post
Share on other sites
7 minutes ago, Cebulon said:

I attached my mod, if its okay. If not delete please.

Happy flying

I dont think you should share that acf file without a permission.

 

Edited by Tom Stian
  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, Cebulon said:

@Cameron i am fully aware of the XP11 issues and that 1.1 is just a ninja fix. Thats okay and the aircraft is well flyable in XP11.

I AM happy enough, when the ground handling is fixed for now.

BUT, theres enough people arround which would be happy to have the acf file available with the APU fix and the HIGH/LOW idle fix included.

i am able to fix that in a minute, others aren't. I am sure there will be a huge number of questions coming up again and again.

Little wor for a dev, happy people all around ;-) LOL

 

Happy flying

 

 

You are totally right, of course - and that is why we will have a full compatibility patch for XP11 "soon". And your intention with attaching the .acf file here was ment well, I know - but we would rather not have this sort of thing in the "official" support forum, for two reasons:

1.) People downloading it will assume that it is an official "patch" or whatever. No matter what kind of disclaimer you put up, some people have a hard time reading what they don´t really want to acknowledge.

2.) All the files that you have in your X-Aviation/IXEG737 folder are copyrighted and can´t be shared without written consent.

Cheers, Jan

 

Edited by Litjan
  • Upvote 3

Share this post


Link to post
Share on other sites
11 minutes ago, Litjan said:

You are totally right, of course - and that is why we will have a full compatibility patch for XP11 "soon". And your intention with attaching the .acf file here was ment well, I know - but we would rather not have this sort of thing in the "official" support forum, for two reasons:

1.) People downloading it will assume that it is an official "patch" or whatever. No matter what kind of disclaimer you put up, some people have a hard time reading what they don´t really want to acknowledge.

2.) All the files that you have in your X-Aviation/IXEG737 folder are copyrighted and can´t be shared without written consent.

Cheers, Jan

 

He's not sharing any files, he's just telling how to mod them so that the aircraft works better. 

Share this post


Link to post
Share on other sites
1 minute ago, jaguado said:

He's not sharing any files, he's just telling how to mod them so that the aircraft works better. 

He is not...anymore.

Share this post


Link to post
Share on other sites
17 minutes ago, Litjan said:

He is not...anymore.

Ja, deleted the attachment a minute later, sorry for the hazzle, i didn't realy think about it.

  • Upvote 2

Share this post


Link to post
Share on other sites

The new 1.1 Installer does not create the directory "coroutes" inside the Aircraft-Folder. So if you are wondering why you can't export from whatever program to the IXEG, just create the folder <X-Plane>\Aircraft\X-Aviation\IXEG 737 Classic\coroutes

  • Upvote 5

Share this post


Link to post
Share on other sites

having issues still with APU after changes, however setting to Turnaround state and all is good, I am happy to do this as I just want to fly so I can live with it.....

Share this post


Link to post
Share on other sites
46 minutes ago, wain said:

having issues still with APU after changes, however setting to Turnaround state and all is good, I am happy to do this as I just want to fly so I can live with it.....

I trust that you applied the manual fixes to the .acf file that is required for the APU to work in XP11?

Share this post


Link to post
Share on other sites

Hello I updated the 737 ixeg v1.1 in xp 11 but it continues with the same problems appears that update was made only for xp10 and it's a very good aircraft but it lacks the updates for xp11

Share this post


Link to post
Share on other sites
3 hours ago, Litjan said:

I trust that you applied the manual fixes to the .acf file that is required for the APU to work in XP11?

yeah yeah, hey I am not complaining, happy to have it in XP11 and all else seems great to me.....

Share this post


Link to post
Share on other sites

@bluair the only bug specific to XP11 that has been addressed is the sliding on the ground. Atm the plane is officially for XP10 only. But with the ground fix it's also enjoyable for those who want to use it with XP11. I'm using it right now with XP11 and I have no major issues.

Share this post


Link to post
Share on other sites
1 hour ago, crisk73 said:

@bluair the only bug specific to XP11 that has been addressed is the sliding on the ground. Atm the plane is officially for XP10 only. But with the ground fix it's also enjoyable for those who want to use it with XP11. I'm using it right now with XP11 and I have no major issues.

I already used ixeg in XP 10 and I liked it a lot, but now in xp11 it's not the same thing in the floor, it's wheelchair-friendly so I can cumulate the taxi, I have to accelerate the engines at maximum and others .......... ...There's still a lot missing.

Edited by bluair

Share this post


Link to post
Share on other sites

It has been said countless times that update 1.1 is for xplane 10 only! 

This aircraft was designed and coded for xplane 10 and in my opinion is reason enough to keep a copy of xplane 10 installed. If you want to enjoy the IXEG 737 at its best then stick to 10. 

This aircraft is a fabulous achievement for IXEG and the systems simulation goes to depths most of us will never understand. 

Development of this product began in the early days of XP 10 and continued until the year before XP 11 was released. The fact that people on these forums seem to think that 5 years of work can be gone over in-depth and pushed out as a complete product for XP 11 is just plain silly. 

XP 11 brought huge changes which all developers were given very little time to tackle; not just IXEG.

 

The team are to be applauded.

 

Michael.

 

Share this post


Link to post
Share on other sites
1 hour ago, bluair said:

I already used ixeg in XP 10 and I liked it a lot, but now in xp11 it's not the same thing in the floor, it's wheelchair-friendly so I can cumulate the taxi, I have to accelerate the engines at maximum and others .......... ...There's still a lot missing.

use the manual fixes described in the first post.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×