Jump to content

[SOLVED] Can't disengage brakes


Recommended Posts

After the 1.02 update fixed the issue of CTD when pressing the "chocks" button, the aircraft brakes refuse to release.  The parking brake is *off* and the chocks are disconnected, but still the dataref shows 1.000 for lbrak rbrak and wbrak.  On other aircraft it will show 0.0000.  I have never used rudder pedals, and always mapped two keys on the joystick to "hold regular effort" and "toggle maximum effort."  How can I get the TBM to release its brakes?

Edited by borrrden
Link to post
Share on other sites
  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Thanks for the effort guys, 1.0.3 changed things.  The parking brake still doesn't work but is set with the brakes off instead of always on and no option to stop the plane.  After start, the plane run

I've confirmed that X-Plane Joystick Settings.prf is the offending preferences file.  I restored everything besides that one from backup and the issue remains fixed.  I will keep analyzing to find out

If it were easy do you really think we'd be here?

Oddly, the taxi tutorial seems capable of releasing the brakes, but I don't know what it is doing....it shows the lbrak and rbrak going to 0 when demonstrating the "brakes off" taxi portions.  This brakes locked thing happens from a "fresh" state (i.e. deleting the state folder from TBM900 output triggering the tutorial again)

Edited by borrrden
Add more info
Link to post
Share on other sites

I am having the same exact issue as well as my pitch axis just refuses to work on this aircraft

*Update* When the plane has a fresh state the brakes wont disengage but when its not a fresh state, i have no brakes at all. Also i have pitch movement for the first 2 seconds the plane loads. After that, nothing.

Edited by Tstakeman89
Link to post
Share on other sites

using Logitech G940:

left pedal is set as "left toebrake" right pedal is set as "right toebrake", the last ruder axis is set as "ruder".

even in the tutorial about taxing the aicraft the pedals are not moving when forced to do the exercise with "setting the parking brake" - ruder is moving but pedals (brakes) arent.

Link to post
Share on other sites

same here. Checked all settings for double axis or keystrokes. Should be ok. No movement of brakes/pedals seen in the 3D, only yaw works. When selecting full rudder left and right suddenly the plane starts to roll, but no chance for braking, they don't work.

Have 1.02 and XP11.26 on Win10

Thanks, Peter

Link to post
Share on other sites

Just tried it with v1.02, and I can't get my brakes to actually engage. I apply brakes via my HOTAS, and nothing happens. Can't get the parking brake to engage, either. This was especially hilarious since the moment I threw the aircraft into flight idle, it taxied forwards uncontrollably.

Link to post
Share on other sites

I had the same problem with the pitch axis not working. Go into maintenance and check airframe etc (forgot what is what called exactly). Apparently the delivery guys had a rough landing and already broke some stuff. After fixing I had the pitch axis working again. Might be the same case with the brakes. 

Link to post
Share on other sites
5 minutes ago, deimos256 said:

Yeah the lack of any sort of acknowledgement thus far is concerning.  I hate to sound hyperbolic but I can't fly this if my brakes aren't working.

Yes ; at less something like "we heard of that and are trying something". I mean, this topic if top one on the forum and no one from the dev team is sending a buoy. I know releases are something difficult - but one word from them to these people unable to taxiing and takeoff this exceptionnal bird will be a good point.

Edited by MagicSystem
Link to post
Share on other sites

Let's not get overly dramatic here, guys.

If you'll pay any attention to the forum you'll see topics get updated with the [sOLVED] on the subject. If it does not contain this that means we're aware.

Bigger fires first. Too many people couldn't even load the airplane without the whole sim crashing.

Everything has a priority.

Link to post
Share on other sites

For what it's worth I just had an idea that works.  It's more or less the "nuclear option" but I deleted my X-Plane preferences (backed them up rather) and let X-Plane create new ones.  Now I can see the brake pressure starting with 0.  I lost my control mapping and such but the issue also vanished.

The preferences are in X-Plane/Output/Preferences

Link to post
Share on other sites

I've confirmed that X-Plane Joystick Settings.prf is the offending preferences file.  I restored everything besides that one from backup and the issue remains fixed.  I will keep analyzing to find out more because as a developer myself I also know the frustration of being on the other side of these kinds of things.

  • Like 1
Link to post
Share on other sites
  • borrrden changed the title to [SOLVED] Can't disengage brakes

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...