Jump to content

SkyMaxx Pro 2.0 issues.


Recommended Posts

Hi alpilotx,

 

Sorry some of those were in wrong order. Do try to keep the packs in order but they sometimes end up in a mess.

 

My thought is that surely it's not actually loading every single scenery before I've even selected a starting location? That would seem like a wasteful thing to do.

 

Andy

 
Link to post
Share on other sites
  • Replies 98
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

What a Discussion Anything was fine with 1.3 Since 2.0 X-Plane only runs good with default Clouds. Maybe it can be that it Conflicts with other plugs or Programs or even with my Ballpen on my table

Update.  Don't exactly know what I did except move all my custom scenery and aircraft back into the XPlane folder and now getting good frame rate with SMP V2.  Currently flying Carenado BE58 to Nice a

Never stop moving forward 

Posted Images

I had one little thing that's just a query really. Does skymaxx have it's own VRAM usage that wouldn't show up in the rendering screen in x-plane? Only asking because yesterday I had some crazy black spikes shooting up everywhere when there were a lot of clouds, which from experience with other games usually means my card's memory is being taxed a bit too much, but the reading in x-plane still had nearly a gigabyte free. I'll try reducing the resolution to very high or high and see if that sorts it out, though it might just be a case if turning down the memory clock settings on my card.

Link to post
Share on other sites

Does skymaxx have it's own VRAM usage that wouldn't show up in the rendering screen in x-plane?

 

I don't know how Laminar comes up with that number. If they are tracking their own resource usage internally, then I would think SkyMaxx's VRAM usage would not be part of it. If they are querying the graphics driver for it then it would - but knowing how hard it is to reliably query the driver across all kinds of cards, I suspect the former case.

 

If you've increased the cloud draw distance setting in the SkyMaxx Pro configuration, that will consume additional VRAM - so if you've messed with that, try turning it back down.

Link to post
Share on other sites

Thanks to you guys for the free upgrade to SMP V2. Just recently purchased SMP V1 and was enjoying the improvements over X-P 10 3.0's default. Before I continue, please note that I'm not a newbie, but no guru either. I've downloaded SMP 2, extracted the files, and placed the upgrade V2 folder in X-P's main folder. It's now positioned right above my SMP V1 folder in the X-P dropdown expand. When I fired up X-P and opened the plug-in and configuration window, I noted that  it's still displaying the SMP 1 version and not the upgraded V2. Maybe I've placed the upgrade in the wrong directory, or am I suppose to uninstall V1 and replace it with V2. Also, I was running REX for X-P with many rendering problems before I acquired SMP V1. Should I now uninstall REX to avoid possible performance conflicts. Any suggestions or thoughts would be appreciated.

 

Thanks again, Mike

Link to post
Share on other sites

Hi Friends

To have problems since SMP Pro 2.0 is installed on my iMac, having lowest 30 fps before, it's now 1 frame per 10sec.

Now with my finger on the right mouse click for 5 minutes to change plugins in the menu waiting that the menubar opens up,waiting another 5 minutes for activating or deactivating something, i was thinking about maybe overnight someone has put my old Quadra machine with 40 Mhz from 1990 in my iMac

and You want me to buy a new Computer. I was deinstalling 10.30.8, installing 10.25 and doing this since 20hrs switching plugins on and out,i have done anything to bring it to some framerate. The only thing i am now near to do, is (

)

There is a problem and i wait till its solved.

Can't get back SMP 1.3

OM Shanti

Link to post
Share on other sites

OK so I've been working away moving scenery around etc.

 

I've no idea what's changed but I've just managed three successful loads in a row.

 

The last steps I did were remove three large OSM files from the custom scenery + the scenery_packs.ini file.

 

This resulted in it starting.

 

I then replaced, one by one, each osm file, restarting each time.

 

Finally I replaced the original scenery_packs.ini

 

It seems to work for now...

 

Andy

Link to post
Share on other sites

Hi Friends

To have problems since SMP Pro 2.0 is installed on my iMac, having lowest 30 fps before, it's now 1 frame per 10sec.

Now with my finger on the right mouse click for 5 minutes to change plugins in the menu waiting that the menubar opens up,waiting another 5 minutes for activating or deactivating something, i was thinking about maybe overnight someone has put my old Quadra machine with 40 Mhz from 1990 in my iMac

and You want me to buy a new Computer. I was deinstalling 10.30.8, installing 10.25 and doing this since 20hrs switching plugins on and out,i have done anything to bring it to some framerate. The only thing i am now near to do, is (

)

There is a problem and i wait till its solved.

Can't get back SMP 1.3

OM Shanti

 

 

Having the exact same issue.  10.30b8 on i7 iMac with OSX 10.8.5.   SMP V1 worked fine but V2 just shuts everything down to fps of 0.5.  I removed the Custom Scenery folder to no effect, and also removed all plug-ins with the exception of SilverLining.  Stumped on this one.

 

Nano

Link to post
Share on other sites

Did you change any settings in SkyMaxx Pro's configuration? If so, start by deleting the resources/plugins/silverlining/settings.dat file prior to starting X-Plane in order to get back to the default settings.

 

If you crank up the cloud draw distance all the way up for example and you don't have enough free VRAM to support it, this could happen.

 

If you didn't change any settings, you can configure SkyMaxx Pro 2.0 to behave exactly as SkyMaxx Pro 1.3 by disabling the hi-res cloud puffs, cloud shadows, and lens flare options.

Link to post
Share on other sites

Did you change any settings in SkyMaxx Pro's configuration? If so, start by deleting the resources/plugins/silverlining/settings.dat file prior to starting X-Plane in order to get back to the default settings.

 

If you crank up the cloud draw distance all the way up for example and you don't have enough free VRAM to support it, this could happen.

 

If you didn't change any settings, you can configure SkyMaxx Pro 2.0 to behave exactly as SkyMaxx Pro 1.3 by disabling the hi-res cloud puffs, cloud shadows, and lens flare options.

 

I did not change any settings from the default configuration.  But I will try your suggestion.  

Link to post
Share on other sites

If the settings don't help, it probably means you were almost out of memory before installing SkyMaxx Pro 2.0, and it pushed it over the edge. You should probably temporarily remove custom scenery and plugins other than SilverLining and Gizmo, and see if that clears it up. If so, start adding the other stuff back in until you run out of resources again.

Link to post
Share on other sites

Yes, thats an important factor in X-plane 10! It has no stable RAM footprint in the classical sense. It depends and fluctuates massively with the choosen rendering settings, the installed content (not only scenery, but also different aircraft), the active plug-ins, and the location you are flying at a given moment. All of these can - at any given time - make quite some difference in your memory footprint. So, just as sundog correctly diagnosed, when you are already at the edge of 8 GB (which is definitely quite easily possible with what i see from your installed content - in the Log.txt) ... its not very hard to be pushed over the edge from one moment to th other. So, either go back a few steps by removing content (HD Mesh Scenery v2,  Simheave photoscenery or World2Xplane can be big memory hogs ... depending on the complexity of a region ... but also complex aircrafts etc. can ask for a big share from your resources!!), lowering rendering settings or consider upgrading your RAM (if that is a viable option for you) to be on the safe side in the future.

Link to post
Share on other sites

What a Discussion

Anything was fine with 1.3

Since 2.0 X-Plane only runs good with default Clouds.

Maybe it can be that it Conflicts with other plugs or Programs or even with my Ballpen on my table,

but it is not my resort to find the Conflict unless You Pay me per Hour.

So cannot downgrade to 1.3 so i have nothing!

I am so sad to Configure up and down the line wasting my time.

Best is to give an Option to download 1.3 again till You know what the Problem is with this Plugin

Patience End, thought i can enjoy XP this Weekend, tell You i have a lot of words for this You will not listen!!

Happy Crashing!

  • Downvote 2
Link to post
Share on other sites

And Alpilot, "really" i like all of Your works, but You must admit that it is useless to disable anything that was running fine until Skymaxx 2.0. They advertises with SkyMAXX PRO takes an new and dynamic approach with a completely new, framerate friendly cloud engine.

which should be better than default. I do not blame someone, shit happens but 1 FRAME in 10 Seconds even with all options are down as possible, Sorry than Something is wrong, i am not a Programmer, i'm a user

Otherwise, disable anything just fly with sea and cloud it's nice too,

also we can buy a new 8 Core Mac with 32GB Ram Dual AMD Fire Pro and some SSD, but than with a bit more money i can buy a used Cessna.


Link to post
Share on other sites

Saynday,

 

 

And our clouds do perform well we will always stand by that,  you inability to listen to some established people in the community is causing your frustrations right now.  I suggest you take a breath and try and understand how to configure your X-Plane for better performance.   It will help you enjoy overall and with SMP......

 

Both Frank and alpilotX have given great advice, there are no free rides and X-Plane along with any other program......it isn't plug and play.......

 

SMP is an excellent system and you will not be getting anywhere stating otherwise,  so I suggest to you to start being a bit more rational and looking at the awesome advice presented to you......

Link to post
Share on other sites

Now I am going to have to install another virgin copy of 10.25 to run unless I decide to go with 10.30.

 

So long as you de-select the beta checkbox in the installer you could have simply gone back to a fresh 10.25 install with minimal hassle.

Link to post
Share on other sites

 

And Alpilot, "really" i like all of Your works, but You must admit that it is useless to disable anything that was running fine until Skymaxx 2.0. They advertises with SkyMAXX PRO takes an new and dynamic approach with a completely new, framerate friendly cloud engine.

which should be better than default. I do not blame someone, shit happens but 1 FRAME in 10 Seconds even with all options are down as possible, Sorry than Something is wrong, i am not a Programmer, i'm a user

 

Still ... I repeat what I wrote above: the RAM footprint of the sim is extremely variable depending on a lot of factors, which can even (easily!) change with the exact same installation environment when you change starting location (which  defines what gets loaded into memory, and can thus massively change your RAM footprint). And then, if you run out of physical memory (and the sim hasn't crashed) and your OS starts to swap (its the classic way to manage virtual memory on all modern OS-es ... they can use disk to swap out less used RAM, and thus allowing you to use a larger memory space than your physical RAM would allow) then all is over! Swapping is usually a very slow process (especially when it goes to a HDD) compared to using RAM, and thus can slow down everything by a few magnitudes ...

Link to post
Share on other sites

Still ... I repeat what I wrote above: the RAM footprint of the sim is extremely variable depending on a lot of factors, which can even (easily!) change with the exact same installation environment when you change starting location (which  defines what gets loaded into memory, and can thus massively change your RAM footprint). And then, if you run out of physical memory (and the sim hasn't crashed) and your OS starts to swap (its the classic way to manage virtual memory on all modern OS-es ... they can use disk to swap out less used RAM, and thus allowing you to use a larger memory space than your physical RAM would allow) then all is over! Swapping is usually a very slow process (especially when it goes to a HDD) compared to using RAM, and thus can slow down everything by a few magnitudes ...

 

Swapping is the reason I am anxious to have the hard disk in my Mac Book Pro swapped with an SSD; I am hoping it will improve frame rate when swapping starts to occur.

Edited by Jose Almeida
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...