Jump to content

IMPORTANT! FPS Issues? Read me now!


Recommended Posts

ADMIN NOTE:

SkyMaxx Pro v5.0.1 has been released and supersedes this post for the time being:

-------------------------------------------------------

We have received numerous reports of insanely high RAM usage up to the point X-Plane eventually crashes and/or FPS are simply unsustainable.

In every one of these instances, XPRealistic has been in use and the culprit of the issue.

Our best guess at the moment would be that they are somehow changing the format of the depth buffer, which would mess up our attempts to copy it for our shadow and soft particle effects, and ultimately causing terrible memory leaks.

The fix on this is potentially going to need to come from their side. As of this writing I have reached out to the main developer to offer him a copy of SMP v5 so we can work together.

In the meantime, you have a couple of options:

1. Remove XPRealistic entirely.

or try...

2. Unticking "Natural movements" and "Ground Shakings" in XP realistic v2.

We have received a report that #2 does work, but in all cases option #1 does for sure resolve the insane memory leak.

I will do my best to keep everyone updated here on how the XPRealistic developer works with us.

  • Like 3
Link to post
Share on other sites

An update on the situation...

We have made contact with the developer of XPRealistic, and we feel we have a handle on why this is occurring. XPRealistic is writing to some required view monitoring datarefs every frame which SkyMaxx Pro also monitors. This is causing numerous allocations of depth buffers until things eventually explode.

We are discussing how to deal with this. There are talks of us creating a workaround, and XPRealistic coming out with an update. As we get more information we will let you know.

  • Like 4
Link to post
Share on other sites

Hi,
It's nor XPRealistic in my case case (i don't have it). I have same issue with Dreamfoil Bell 407 helicopter. What is strange, only inside of aircraft = 10 fps and RAM load of 64 of 64 GB. Outside framerate back to 80 fps.

Link to post
Share on other sites
1 minute ago, g.pajak said:

Hi,
It's nor XPRealistic in my case case (i don't have it). I have same issue with Dreamfoil Bell 407 helicopter. What is strange, only inside of aircraft = 10 fps and RAM load of 64 of 64 GB. Outside framerate back to 80 fps.

It's possible that if you have another plugin which does some kind of head shaking or ground shaking, it's causing this.

If you don't have XPRealistic, please follow these guidelines to find the issue:

1. Rename your plugins folder to plugins_bak, then create a new folder called 'plugins'.

2. Move SilverLining and Gizmo64.plugin from plugins_bak to plugins.

3. Now start X-Plane. Has the problem resolved itself?

If yes...

Now you need to add back each plugin located in plugins_bak to plugins one at a time until you find the problem.

Link to post
Share on other sites
18 minutes ago, g.pajak said:

Hi,
It's nor XPRealistic in my case case (i don't have it). I have same issue with Dreamfoil Bell 407 helicopter. What is strange, only inside of aircraft = 10 fps and RAM load of 64 of 64 GB. Outside framerate back to 80 fps.

The headshake plugin may cause the same issue, if you have that installed. Or if your aircraft has its own headshake features it might cause the same thing.

Link to post
Share on other sites

This is so very sad. Ive been paying a lot of money for my hobby. Not to be an technician.
When I buy stuff I fully expect the items to work properly.
Its upp to you to test and make shure everything works as intended. 
And yes of course. Blending 3rd party freeware is cause a lot of issues. 

But you should have known there might be some issues.
Neither SkyMaxxPro or XPRealistic is freeware.

I fully expect this to be solved very soon. Or ill reclaim my money.

Its a pity when the product in all is quite good.

Link to post
Share on other sites
9 minutes ago, SkyChek said:

This is so very sad. Ive been paying a lot of money for my hobby. Not to be an technician.
When I buy stuff I fully expect the items to work properly.
Its upp to you to test and make shure everything works as intended. 
And yes of course. Blending 3rd party freeware is cause a lot of issues. 

But you should have known there might be some issues.
Neither SkyMaxxPro or XPRealistic is freeware.

I fully expect this to be solved very soon. Or ill reclaim my money.

Its a pity when the product in all is quite good.

Sorry, but this post as a whole is pretty ridiculous.

We are not responsible for things out of our control. We absolutely will own and find ways about things we CAN control (and this thread is evidence of that).

You having unrealistic expectations, however, is not fair on any developer. I don't care if they're associated to me, or a can of worms. It's just about being real.

  • Like 1
Link to post
Share on other sites
1 hour ago, g.pajak said:

I have same issue with Dreamfoil Bell 407 helicopter.

Are you using the included Geforce plugin? This also creates some camera movement effects and maybe removing this from the aircraft's plugins folder solves the issue (just move the plugin to your desktop for testing so you can restore it later on).

Link to post
Share on other sites
7 minutes ago, Crunchie Dirt-Nap said:

I hope this gets resolved soon so I can try out the new features in v5. In the meantime I just downloaded and installed version 4 again so will just use that until the new one gets sorted out. 

Assuming you can disable/remove XPRealistic you can enjoy v5 now.

Link to post
Share on other sites
7 minutes ago, Cameron said:

Assuming you can disable/remove XPRealistic you can enjoy v5 now.

Yes I may do that as well but I really like XPRealistic which is one of my must have add-ons and to me SkyMaxx version 4 is still awesome so I am okay with just using the old combination until I am able to use the new SkyMaxx and XPRealistic together without any restrictions on which features can be enabled etc. 

Link to post
Share on other sites
3 hours ago, g.pajak said:

Hi,
It's nor XPRealistic in my case case (i don't have it). I have same issue with Dreamfoil Bell 407 helicopter. What is strange, only inside of aircraft = 10 fps and RAM load of 64 of 64 GB. Outside framerate back to 80 fps.

I flew the Toliss A321 Neo today with Both Sky Maxx Pro 5 and XPRealistic 2 and had no fps issue at all. I flew the Bell Helicopter and had fps at LOWI. Its odd that this only seems to happen somfar with the Bell. I will see if this is a problem with other aircraft.

Link to post
Share on other sites
  • Cameron locked and unpinned this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...