Jump to content

ITT and RPM pulsating to red line


Recommended Posts

After I increase the condition levers to maximum, the ITT and RPMs wildly go to redline then back down to idle and back to red line and so on. Any clues as to why this is happening? 
 

*Edit. Just saw a post later down the list where somebody else was having this same problem back in June. I hesitate to ask when this will be fixed since I may get a flippant response from someone. The plane is unflyable as is. Why are these issues not disclosed to the customer before they purchase a $50 plane?? 
 

Edited by smaze17
  • Upvote 1
Link to post
Share on other sites
  • 1 month later...
5 hours ago, moespeeds said:

Same problem here, though ITT doesn't seem to actually damage the engines so I've begun to just ignore it. Just another expensive aircraft for x-plane with undisclosed issues/incomplete features. Seems to be par for the course with just about all payware anymore.

Darn it. I was hoping you were going to be more pessimistic.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...