Jump to content

AP doesn't hold altitude

Recommended Posts

Hi All,

as the title, it seems the AP can't hold the altitude.

As you can see in the following pic, i set the Altitude at 1500ft but after reaching 1500ft, a small drift continues to increase Altitude depending by speed.

If i decrease the speed the altitude decreases... so i need to keep a certain speed to avoid drifting in altitude in both sides.

Anybody can help?




Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

Nobody on our development team can replicate this issue. It is most likely either due to hardware conflicting with X-Plane's autopilot logic (as our autopilot is using the base X-Plane adjustment system) or a plugin/script install that is interfering. 

If you can come up with the exact steps that you took to get it to this situation, that would be massively helpful in debugging. 

Link to comment
Share on other sites

Some of this might seem like "is the refrigerator plugged in" type of troubleshooting but bear with me. I found this thread because I was having the same problem.

Turns out, in my case, I had a notch of flaps in that I didn't notice. Note that on autopilots that don't have auto throttle, the aircraft can only adjust its altitude using pitch trim. If your power setting is too high, you will drift up. If your power setting is too low, you will drift down. If you have a notch in like I did, or a speed break inadvertently deployed, your trim cannot be enough to compensate for the lift and/or drag generated by these conditions.

I noticed in your screenshot that you are considerably slower than your VMO, so I think my analysis bears some merit.

Also, don't forget, when you're cruising in a high-performance aircraft, you must set your manifold pressure and your throttle to an appropriate cruise range.

I hope this obvious answer can be found by others that share the same issue without going through copious amounts of manuals and YouTube tutorials that don't address these sort of common errors.

Good luck!

Link to comment
Share on other sites

  • 3 months later...

I'm also having this issue (not as bad as in the OP though). When I disconnect the autopilot to correct, it winds up pitching up rapidly due to apparently being out of trim. With regard to the throttle setting, this does seem more likely to occur in the 2 minute phase of cruise where power is set at full

Link to comment
Share on other sites

  • 10 months later...
  • 10 months later...

I had the same problem and today I found the answer below. I hope it solves your problem too.




"Ok I have done some further testing with the above method, it seems the issue comes from what exact disco servos button you have setup on your controller. I had "Disco servos, yaw damp and trim, any side" which seemed to make the trim not work at all whenever the autopilot was reapplied. I switched the disco servos command to "Disco servos and yaw damp, any side." and have not noticed any weirdness with the trim and autopiltot. Seems like disconnecting the trim is causing some sort of conflict with the plane's autopilot."

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...