Jump to content
Cameron

TBM 900 v1.1.2 Update Released!

Recommended Posts

Hello All,

This will serve as a formal forum announcement that we have released the version 1.1.2 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an e-mail by X-Aviation with complete instructions on how to obtain your update. We have made this a very simple process! For those that purchase the TBM 900 from today forward, your purchased download will already be updated to version 1.1.2 for you.

What if I didn't get the update e-mail?

If you did not receive your update e-mail don't fret! X-Aviation has updated our system to allow all customers to update with ease, regardless of whether you received an e-mail for the update! Here's what to do:

1. Login to your X-Aviation account here: https://www.x-aviation.com/catalog/account_history.php

2. Find your original TBM 900 download and re-download the file. It will download as the latest version!

The following is a list of additions/fixes included:
 
What's New / Changed:

  • Implemented AoA display with HUD
  • Sidebar drawer was broken in X-Plane 11.30 when sim was fullscreen
  • Icing effects were drawn as fully white in XP11.30
  • Throttle on-screen mini overlay was drawn with black background in XP11.30
  • Integrated support for particle system in XP11.30
  • Added new particle effects for engine heatblur, contrails, engine fire, wingtip vapor trails and fuel leak.
  • Fixed broken FAA charts due to mishandling of AIRAC cycle 1813
  • Readjusted ECS to not make the cabin so cold at night with low occupancy
  • Implemented X-Plane tailnum dataref sync to generate correctly-named logbook entries.
  • Manipulators all overhauled for VR
  • Brightened the overhead lights
  • Lightened up panel textures
  • Hide pilot models when the door is open
  • Intro tutorial contained a typo
  • Sound init failure can result in crash
  • Updated WMM.COF file to latest release by NOAA

As always, thanks for being a customer with X-Aviation. We appreciate your feedback and support!


Enjoy these latest updates, and stay tuned to the forum as we continually announce the latest happenings.

  • Like 3

Share this post


Link to post
Share on other sites
33 minutes ago, Wael Soliman said:

The Access light key back to off position immediately when pressing on it , XP 11.26

Isn't this how it should be? It's a momentary switch. 

  • Like 1

Share this post


Link to post
Share on other sites

I can't click any switches except for nav and strobe lights. Can move flaps lever, nothing else. The crash bar is in its upper position on load, and can't be moved. Can't turn battery on, cant move throttle lever using mouse pointer (it's in full reverse on load, not even cutoff).

X-Plane 11.26

Share this post


Link to post
Share on other sites

Short 20 min flight, no problems for me. Everything working as expected. 

Just the AOA HUD does nothing, no indication visible. Am I right that because I'm using Track IR it wouldn't work? 

Share this post


Link to post
Share on other sites

Hello!

HUD doesn’t work correctly on VR either. It shouldn,t be visible anywhere else than in opened HUD glass. Now it’s hoovering everywhere.

Br. Vesa 

Share this post


Link to post
Share on other sites

Correct! Played around a bit and now I can see the indicator coming down from the ceiling when i look up with track-ir in a very unnatural and uncomfortable way.

Share this post


Link to post
Share on other sites

Tested v1.1.2 on 11.30r1. Have serious dificulties to move the throttle from IDLE-CUT to the next postition. In v1.1.1 when hovering over the throttle there was double sided arrow and movement was easy even sometimes too easy, now I can see a hand but no matter what I tried after a long time I was only able to move the throttle to IDLE-LOW. So no flight test here.

P.D: second test, same result but the handle is stuck at IDLE-LOW from the begining. Phisicaly its not moving from that position but the scheme on the left shows the stick at IDLE-LOW and the stick silouete on the left side moving up and down, mouse only. That was in windowed mode. In full mode both stick and stick scheme became freezed. The rest of the buttons working though.

Edited by Mateyhv

Share this post


Link to post
Share on other sites
9 minutes ago, Mateyhv said:

Tested v1.1.2 on 11.30r1. Have serious dificulties to move the throttle from IDLE-CUT to the next postition. In v1.1.1 when hovering over the throttle there was double sided arrow and movement was easy even sometimes too easy, now I can see a hand but no matter what I tried after a long time I was only able to move the throttle to IDLE-LOW. So no flight test here.

That's a mistake on my end.  I'll change the cursor type in the next update, but it should work as it did in the VR mod that was made before.  Left side of the power lever should be forward-backward and right side should be left-right.

Edited by Goran_M

Share this post


Link to post
Share on other sites

Goran, while you're at it, do you think it's possible to add dedicated commands for cutoff, low idle, high idle and flight idle positions? 

I know there's the mixture rich/lean a bit commands which work, but I want to use an axis on my saitek quadrant for controlling the left side of the throttle and therefore dedicated commands would be very nice! 

Share this post


Link to post
Share on other sites
1 hour ago, Mateyhv said:

Tested v1.1.2 on 11.30r1. Have serious dificulties to move the throttle from IDLE-CUT to the next postition. In v1.1.1 when hovering over the throttle there was double sided arrow and movement was easy even sometimes too easy, now I can see a hand but no matter what I tried after a long time I was only able to move the throttle to IDLE-LOW. So no flight test here.

Same problem here!

Just now, RobW05 said:

Goran, while you're at it, do you think it's possible to add dedicated commands for cutoff, low idle, high idle and flight idle positions? 

I know there's the mixture rich/lean a bit commands which work, but I want to use an axis on my saitek quadrant for controlling the left side of the throttle and therefore dedicated commands would be very nice! 

I would love the ability to press (and hold) a dedicated button on my throttle which should bring it in fuel control mode. That way we could control the fuel control mode with the actual throttle.

Share this post


Link to post
Share on other sites
57 minutes ago, awillimd said:

Upgrade not working for me. No plugins installed. No switches working.

Is the tool bar visible on the left? (Maintenance Manager, etc)

Share this post


Link to post
Share on other sites

Hi,

 

I have the same power lever problems as others have mentioned. Clicking and dragging the power lever in order to start the engine only works maybe one in ten tries. Also clickspots on some of the switches feel as though they've been shifted slightly away from the actual location of the switches.

Once I've managed to get the engine started, the plane behaves normally and I can control power with my joystick slider.

I do have the side-menu/tool-bar btw.

Is there a way to download 1.1.1 as I delete my files after they've been installed?

Edited by vvazz0

Share this post


Link to post
Share on other sites
2 minutes ago, vvazz0 said:

Hi,

 

I have the same power lever problems as others have mentioned. Clicking and dragging only works maybe one in ten tries. Also clickspots on some of the switches feel as though they've been shifted slightly away from the actual location of the switches.

Is there a way to download 1.1.1 as I delete my files after they've been installed?

The power lever issue has been fixed and will be available soon.  For now, left side moves the power lever forward and backward.  Right side moves it left-right.  The clickspots for some of the switches have been moved from the base of the switch to the tip of the switch.  

Share this post


Link to post
Share on other sites
22 minutes ago, vvazz0 said:

Hi,

 

I have the same power lever problems as others have mentioned. Clicking and dragging the power lever in order to start the engine only works maybe one in ten tries. Also clickspots on some of the switches feel as though they've been shifted slightly away from the actual location of the switches.

Once I've managed to get the engine started, the plane behaves normally and I can control power with my joystick slider.

I do have the side-menu/tool-bar btw.

Is there a way to download 1.1.1 as I delete my files after they've been installed?

Worked it out now: you have to click & drag the power lever from its right-hand side. B)

Share this post


Link to post
Share on other sites

Not sure I will update this to version noting some of the issues...…………..

But for the next one how exactly do you update your current version (many XP11 planes you just delete the old aircraft folder) - but this one comes with an installer - any help appreciated?

Share this post


Link to post
Share on other sites
Not sure I will update this to version noting some of the issues...…………..
But for the next one how exactly do you update your current version (many XP11 planes you just delete the old aircraft folder) - but this one comes with an installer - any help appreciated?

Redownload the installer. Run it. It will prompt to uninstall the old version. After that it will install the new one


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I just made a LFQQ/EBBR back and forth with the new update.

Everything works fine and even better on my side, so smooth which I wish for everybody! Strangely I don't have any bugs mentioned on the previous posts I just read... ? I mean I didn't notice (in my home cockpit) any issue with the throttle/power by the way... I could maintain all the speed required in any phase of flight as recommended by applying hands action so... ?

The particle effect is just amazing, heatblur woaaa I love it , never seen that at this level, same for the ice effect...

What surprise me very positively is that I have no hit at all on my fps, 30/35 in overcast over Bruxelles (big and dense city) no micro stutters with all the new technologies and the myriad of deep details and stuff provided from this outstanding addon so that THANK YOU so much for bringing us so much fun and tks for the good philosophy of such a realism never reached so far!

God job Captains, big respect for that!

Lkn

Edited by LKN

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×