Jump to content

TBM ILS Workaround


Recommended Posts

As of version 1.1.13 this has been resolved and the below posts are no longer applicable!

Numerous threads and posts have been made here with regards to the ILS no longer working in the TBM. This was due to a change in the X-Plane AIRAC data format. While a patch is being created to address this and other items, I went through some backup drives to obtain the previous AIRAC you can install to bring back ILS functionality.

Download the attached file, and install it to:

X-Plane/Resources

The zip contains a folder called "default data". That folder should override the current one you have in place at the location listed above.

This is only a temporary "fix" while we work to get the next release out.

1085835884_defaultdata.zip

Link to post
Share on other sites

Any further update on this?  Cameron?  Goran?  Is this workaround really working, or not?  I'd rather know it for sure before doing any change...

Navigraph just released their 2014 AIRAC Cycle, which they reaffirmed is going to be the last one with the double version for X Plane, 11.50 AND 11.41.

From the next cycle (2101, I suppose) only the 10.50 version will be available.

At this moment, this means that the ILS LOCs will be out of service for those of us using the (in any other sense fabulous) X-Aviation TBM 900 on X Plane 11.50.

I guess Navigraph shouldn't be blamed for deciding to discontinue publishing data in a format which is now some months old.

It is becoming increasingly urgent to have a patch which reliably solves this issue.

Do you at least have an expected date for the release of the new patch?

Thank you very much, and Happy New Year from Milan....

 

Stefano

  • Like 1
  • Upvote 1
Link to post
Share on other sites

As far as the workaround, I haven't tried it, so I can't comment on it.

My X-Plane installs (I have 3 of them) are specifically configured for add on work.  You could try adding another X-Plane install on your PC for minor testing purposes.  There won't be any problems with DRM from either Laminar or X-Aviation if you do.

The update is still being worked on, albeit with some hurdles.

The official word from Saso regarding the update (which includes the ice and rain effects):

"There is a rain effect issue where the higher levels sometimes don't work for some people on Vulkan and sometimes they do. There doesn't appear to be much of a sensible pattern in when it does and when it doesn't work."

There is no point releasing an update now, with broken ice and rain, because of its potential, unpredictable nature to cause crashes.

We want to get this out as urgently as everyone wants it out.  

Link to post
Share on other sites

Where does one install that last 2014 Navigraph data? I am assuming that this is somehow done in a way that we don't lose compatibility of our other add-ons that correctly make use of the 11.50+ Navigraph data.

Many thanks.

Link to post
Share on other sites

I have successfully managed to implement Cameron's workaround !

 

My setup:

  • I have previously updated to X-Plane 11.50 and I have Navigraph installed

What I did:

Folder X-Plane 11/Resources/default data: 

  • deleted CIFP folder
  • copied all earth_XXX.dat files  and the CIFP folder of Camerons's default data to X-Plane 11/Resources/default data

Folder X-Plane 11/Custom Data: 

  • deleted all earth_XXX.dat files
  • deleted CIFP folder
  • copied all earth_XXX.dat files and CIFP folder from Cameron's default data to X-Plane 11/Custom Data

 

And voilà: both ILS and VOR are working perfectly again!

 

In addition please keep in mind:

  • Don't forget to backup all folders before changing/overwriting/deleting them, you might need them to revert if this fix does not work in your environment.
  • I have just tested the TBM 900 so far, so I can't give you any advice if any other addon will be working  or not.

 

Many thanks to all contributors!

Link to post
Share on other sites

I just bought the TBM and have almost the same configuraiton, XPlane 11.51 Linux (with Saitek/Logitech Pro Flight Multi Panel) , Navigraph latest cycle (11.50+)

If i activate the ILS APP in the G1000, it follows the GPS approach (in APR AP mode), the CDI switch auto from GPS to LOC/GS and I can see the LOC + GS but the AP does not switch to the ILS after capturing it. Even manually i can't make it follow the ILS. Other problem the ILS is not aligned with the runway (LFGJ)

No problem with plain 172 G1000 or EPIC 1000 G1000

Should i enter a separate issue unless i am doing something wrong ? i am disapointed because bought the TBM at that price to do realistic IFR training (not just LPV APP)

Best and happy new year to all

 

Edited by cpot
Link to post
Share on other sites
2 hours ago, cpot said:

I just bought the TBM and have almost the same configuraiton, XPlane 11.51 Linux (with Saitek/Logitech Pro Flight Multi Panel) , Navigraph latest cycle (11.50+)

If i activate the ILS APP in the G1000, it follows the GPS approach (in APR AP mode), the CDI switch auto from GPS to LOC/GS and I can see the LOC + GS but the AP does not switch to the ILS after capturing it. Even manually i can't make it follow the ILS. Other problem the ILS is not aligned with the runway (LFGJ)

No problem with plain 172 G1000 or EPIC 1000 G1000

Should i enter a separate issue unless i am doing something wrong ? i am disapointed because bought the TBM at that price to do realistic IFR training (not just LPV APP)

Best and happy new year to all

 

You have two options:

  1. Follow the instructions in the post just above yours
  2. Download the latest Navigraph cycle in 11.4 format.
Link to post
Share on other sites
27 minutes ago, jrw4 said:

Do the recommended changes to the navdata files have any impact on other XP aircraft, e.g., Aerobask, Toliss, and ZiboMod?

Many thanks and best wishes.

No.

Link to post
Share on other sites
5 hours ago, Cameron said:

You have two options:

  1. Follow the instructions in the post just above yours
  2. Download the latest Navigraph cycle in 11.4 format.

To be frank i don't intend to be a geek (deleting folders) with the most expensive aircraft i bought for Xplane.

The second option is OK waiting for a patch because it seems that other stock x-plane aircrafts will continue to work   

Edited by cpot
  • Like 1
Link to post
Share on other sites
23 hours ago, MichaelH said:

I have successfully managed to implement Cameron's workaround !

 

My setup:

  • I have previously updated to X-Plane 11.50 and I have Navigraph installed

What I did:

Folder X-Plane 11/Resources/default data: 

  • deleted CIFP folder
  • copied all earth_XXX.dat files  and the CIFP folder of Camerons's default data to X-Plane 11/Resources/default data

Folder X-Plane 11/Custom Data: 

  • deleted all earth_XXX.dat files
  • deleted CIFP folder
  • copied all earth_XXX.dat files and CIFP folder from Cameron's default data to X-Plane 11/Custom Data

 

And voilà: both ILS and VOR are working perfectly again!

 

In addition please keep in mind:

  • Don't forget to backup all folders before changing/overwriting/deleting them, you might need them to revert if this fix does not work in your environment.
  • I have just tested the TBM 900 so far, so I can't give you any advice if any other addon will be working  or not.

 

Many thanks to all contributors!

Michael....  ok for the Resources/Default data....but...  if you copy in the Custom Data folder  the files and CIPF folder from Cameron's default data, which are from cycle 1708, maybe you can see ILS LOC again, but how can nav data be updated???  You'll have in your FMS  the 1708 data, not the 2014...

Did I misread?  Am I missing anything?

Stefano

Link to post
Share on other sites
2 hours ago, cpot said:

To be frank i don't intend to be a geek (deleting folders) with the most expensive aircraft i bought for Xplane.

The second option is OK waiting for a patch because it seems that other stock x-plane aircrafts will continue to work   

....Problem is, the current AIRAC cycle (2014) expiring January 20, 2021, is the last one for which Navigraph published the 11.41 version.  

From now on, only 11.50!!!

Stefano  

Link to post
Share on other sites
1 hour ago, ssalis said:

Did I misread?  Am I missing anything?

Stefano

Yes. You're missing the fact it's intended for people who do not subscribe to data services and therefore don't care.

1 hour ago, ssalis said:

....Problem is, the current AIRAC cycle (2014) expiring January 20, 2021, is the last one for which Navigraph published the 11.41 version.  

It's not a problem right now. And, once it becomes an "outdated" problem, hopefully not long.

Just need to be matter of fact about it. No need to over sensationalize or be dramatic.

Link to post
Share on other sites

Cameron,

Now I understand that your workaround is for people not interested in having navdata regularly updated.  I certainly missed that point, I'm sorry, I'm not writing in my mother tongue and some subtlety can certainly escape me.

I also understand very well that it's just a game, and there's nothing sensational or dramatic in it.

I'm just writing to understand more and better, I'm a doctor and a real life IR private pilot, definitely not  a computer expert.  

But, I have to say, the impression is that all the posts here really bother and irritate you, even the most correct, gentle, constructive and "innocent" of them.  And, sometimes, your answers sound pretty "aggressive", I hope you understand what I mean.

Goran's answers are there to show that it hasn't to be necessarily so.   But, again, could only be my erroneous perception of it.  In that case, please excuse me.

Thank you very much, anyway, yours is by far the best virtual aircraft around.

Bye from Milan

Stefano

 

  • Upvote 1
Link to post
Share on other sites
11 hours ago, Cameron said:

Yes. You're missing the fact it's intended for people who do not subscribe to data services and therefore don't care.

It's not a problem right now. And, once it becomes an "outdated" problem, hopefully not long.

Just need to be matter of fact about it. No need to over sensationalize or be dramatic.

Please try to understand this from the perspective of users who paid $65 for what well may be the most expensive add-on GA aircraft in X-Plane, doubly so for those who paid for it during the last seven months without having been told that the most basic ILS technology (which works in every default XP aircraft) is nonfunctional in the Hot Start TBM900. 

This is a customer relations issue, not a technical one. It's X-Aviation's reputation that's on the line, not that of the customers. If you wish to censor and scold us, then have at it. I'm not so sure that works well in the social media-rich world of 2021, but give it a try. The developers had over half a year to fix this problem and, indeed, claim to have done so, but do not want to bear the expense of releasing that fix. That's a business decision over which the customers have no control, but it may come at a significant reputational cost.

Happy New Year everyone. Be safe.

  • Like 2
  • Upvote 1
Link to post
Share on other sites

@jrw4 What you have to understand is that we get this (messages like yours) on an almost daily basis.  I've been told I don't know how to work as a developer if I can't provide updates in a timely manner...and to be honest with you, it can get very frustrating when we have to keep repeating the same response, over and over and over again...on top of being on the receiving end of countless insults.

Cameron isn't scolding or censoring anyone.  He's just repeating the same answer again, and moving on to other customers who need seeing to.  

I'm only responsible for the artwork on the TBM, but I am, obviously, in contact with Saso Kiselkov, who coded all the systems, and I have asked him, many times, for anything on the update.  It's not something that can just be packed together and shipped in a matter of weeks.  I'm sure you've seen what the hold up is now.  And it's the ONLY hold up.  Vulkan is new technology, and all but the rain and ice effects are working.  Trying to nail it down is proving to be an exercise in patience for Saso.  

No one said it was the customers reputation on the line, but I will correct you on something.  This is in no way a reflection on X-Aviation's reputation.  Cameron has nothing to do with the update except to package and upload it to the store.  It's on US, (Saso and myself) to provide the update, and we would rather take our time and provide an as close to faultless update as possible, than rush it and have people complain about more (potential) problems.

Like I've said in other posts, the ILS issue is fixed.  We have over 200 testers who have confirmed this.  During the last 7 months, X-plane has been in beta for most of that time.  And shipping an update during a beta period would be, in actuality, pretty silly.

 

Edited by Goran_M
Link to post
Share on other sites

Hello,
I am one of those users, Tbm purchased 10 days ago, didn’t know was broken, let’s say it’s my bad.
Total guessed usage (gps only ofc)..8 to 10 hours until new airacs.

I totally rely on ssalis and jrw4’s tought, as I am also fully understanding X-Avi point of view and efforts, even if the lack of info still gives me thoughts.
Btw..everyone I speak with, I only get the best reviews for you.

I absolutely don’t wanna be polemic but since the long time needed to develop this tricky fix, may i suggest to at least write the issue on the selling page?
Wait wait..I know, this is totally counterproductive, but trust me, I would still have bought from you, and for knowledge probably’d have turned to 737 classic, not my main priority but surely a must have in the future. I hope this will resolve soon, I’m a bit disappointed but really still hyped to fly that boy.

Just a question: by downgrading airacs, will I be able to fly networks like Vatsim/Ivao or everything will be compromised?

Happy new year everyone, also from Italy!!!

Peace

  • Like 2
Link to post
Share on other sites
15 minutes ago, C1cc1a4lCu1o said:

I am one of those users, Tbm purchased 10 days ago, didn’t know was broken, let’s say it’s my bad.

I wouldn't call it broken.  1 thing is not working.  Look on the bright side.  You can use the lack of ILS to practise manual landings. ;)

17 minutes ago, C1cc1a4lCu1o said:

I hope this will resolve soon

Yes.  Saso is burning the brain cells trying to figure out why the rain works on some systems, but not others.

18 minutes ago, C1cc1a4lCu1o said:

by downgrading airacs, will I be able to fly networks like Vatsim/Ivao or everything will be compromised?

Everything should be fine.  Just remember to make back ups of any folders you delete, so you can replace them should anything go wrong.

Link to post
Share on other sites
9 minutes ago, Goran_M said:

I wouldn't call it broken.  1 thing is not working.  Look on the bright side.  You can use the lack of ILS to practise manual landings. ;)

Hint: The emoticon doesn't make things better, Goran, for someone who just dropped the better part of a hundred bucks on a product which has been selling for seven months with a known defect. 

37 minutes ago, Goran_M said:

No one said it was the customers reputation on the line, but I will correct you on something.  This is in no way a reflection on X-Aviation's reputation.  Cameron has nothing to do with the update except to package and upload it to the store.  It's on US, (Saso and myself) to provide the update, and we would rather take our time and provide an as close to faultless update as possible, than rush it and have people complain about more (potential) problems.  

With regard to this, am I correct in thinking that X-Aviation was listing this product for sale for over half a year with the knowledge that it had that known defect, or did the developers hide that fact from Cameron? 

Let me make a concrete suggestion to retrieve the goodwill of the users: issue a hot fix for the ILS problem and work on the rain effects on whatever timescale you find convenient. Suggesting a navadata workaround that you know has hit a dead end with the latest release is an embarrassment to all concerned. The Zibo Mod had a fix for the navdata problem one day after it was reported. Come on.

  • Upvote 1
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...