Jump to content

Recommended Posts

Hi , 
I have tried to program this aircraft using Datarefs, the reason for this and not using commands is because the supplied commands are toggles and not On / OFF.  
I use spad.next  to control the writing to the datarefs however lets take the battery as an example from what I see in Dataref editor it increases from 0 - 1  from when you click the switch. However this is done in increments and cant just be changed from a  0 directly to a 1.

Will Torquesim provide in a future update the commands On and off ?  as for Hardware cockpits toggles can get out of sync with the hardware switch.


Link to post
Share on other sites

I have been using the available commands to activate switches and knobs for xSaitekPanels. These are available with the prefix afm/sr/cmd/switches. The commands all offer _On, _Off and _Toggle options. The only dataref I have used in that for the panel and instrument lights (plits and ilits). 

Edited by scotfleiger
Link to post
Share on other sites

Cheers for the info @scotfleiger What exactly did you use to discover those Im using Dataref Tool when you close Xplane it produces a list of all Known Datarefs and commands in two seperate txt files.  
commands.txt  contained these 


could you be a gent and attach your config file I can then add them manually

Link to post
Share on other sites

Although not explicit via the DataRefTool plugin, through experimenting I found that in addition to the _Toggle suffix the _On and _Off suffixes were also available. These are all case sensitive and most use a capital for the suffix. However, this did not work in a couple of cases and I tried lower case which did work. Check out the xSaitekPanels.ini I have published to see those commands I have used. 

Link to post
Share on other sites


What version of Spad.neXt are you running?  Ever since upgrading to the latest version, I am no longer able to locate most of the various custom commands. And, I am not sure if all the custom datarefs are available either. In the earlier version of Spad.neXt, I was able to drill down and locate the custom datarefs and commands for a particular aircraft so long as I had a commands.txt and a datarefs.txt file that contained them located in the aircraft folder. In this new version, it doesn't work anything like the old one.  To search datarefs, a list of aircraft developers is displayed with a dropdown menu showing some (not all) of their aircraft.  The "dataref" list contains a large list of developers, but probably not all.  When searching for custom commands, the "commands" dropdown list does show many developers at all.  (Including Torquesim)  See attached photos. I have sent a ticket to Ulrich at Spad.neXt.  He acknowledged the problem but he has yet corrected it.  I was hoping I might be missing something. I have an extensive home cockpit setup and am unable to program my panels on the Cirrus. Thanks for any help you can provide.

Rick S.



Link to post
Share on other sites

@ricktana I'm using the latest Beta of Spad.neXt currently ( and have been working directly with Ulrich over the last couple of days getting dataRefs added/corrected etc. One of the issues I found was with a different plane - previously I did just what you stated, hence the reason I already had the files made up and ready to post here. ;-)

Same as @scotfleiger I use the DataRefTools to find which ones I'm needing/missing and use the output in the xplane\output\preferences\drt_*.txt files to define them for Spad. However with that being said - now that you mention it I'm seeing them missing since upgrading my Spad.neXt. I believe I'll bring this up to him as well!


Edited by qazme
Link to post
Share on other sites

Just checked again and Spad.neXt version is available.  It seems at first glance to have solved most (hopefully all) of my problems.  A large number of previously missing "Commands" and "Datarefs" are now visible in the program. I'll give it a go tomorrow and see if I am able to comfigure my panels to this SR22.


Rick S.

Link to post
Share on other sites

A question for "quazme" or anyone else that can help.  I have the latest version of Spad.next version  I am still unable to find some custom datarefs for the SR22.  Noteably, the following: "afm/sr/apLight/alt" and "afm/sr/apLight/ap". I see them in "DataRefTool" but not in Spad.neXt.  There also seems to be some datarefs misssing from the x-plane default "sim" datarefs. I checked my "datarefs.txt" and "commands.txt" files in the aircraft folder and the custom datarefs are there.  You mentioned that you have been working with Ulrich getting dataRefs added/corrected. I was wondering if these were somehow left out of Spad or that there might be another reason I am not seeing them.  Thanks for the help.


Missing datarefs2.jpg

Link to post
Share on other sites

I'm not a programmer, so I'm not really following this discussion. But I'm having what I think is a data refs and commands problem with the Autopilot button on my RealSimGear G1000. The AP button is not "mapped," so although the SR22 can see that the button is there and is being pressed, it doesn't turn on the AP.

The CommandMapping.ini file line of code for the autopilot reads: BTN_AP=afm/sr/cmd/ap/ap .  

That's very different than the code for the flight director on the RSG G1000. It reads: BTN_FD=sim/GPS/g1000n1_fd

Should the BTN_AP line of code be changed to something like this: BTN_AP=sim/GPS/g1000n1_ap ?

Link to post
Share on other sites


I use two touchscreen monitors and Air Manager to run my G1000 on the SR22 along with Saitek and Goflight hardware. I am using that same command, "afm/sr/cmd/ap/ap"  in Spad.neXt to turn on the autopilot using my GoFlight MCP.  It works well and engages the autopilot like it should. I have the RealSimGear GCU and have found sometimes that if you go to "Plugins/RealSimGear Device Interface/Connected Hardware" and disconnect and then connect the plugin, it sometimes fixes problems with commands not working. 

Rick S.


Link to post
Share on other sites

ricktana, Thanks for your response. The code that I thought was incorrect was in fact correct. The problem was that RSG created new firmware for the SR22, and because I bought the SR22 just as soon as it was released, I installed the older firmware.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...