Jump to content

TBM 900 v1.1.10 Update Released!


Recommended Posts

Hello All,

This will serve as a formal forum announcement that we have released the version 1.1.10 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an e-mail by X-Aviation with complete instructions on how to obtain your update. We have made this a very simple process! For those that purchase the TBM 900 from today forward, your purchased download will already be updated to version 1.1.10 for you.

What if I didn't get the update e-mail?

If you did not receive your update e-mail don't fret! X-Aviation has updated our system to allow all customers to update with ease, regardless of whether you received an e-mail for the update! Here's what to do:

1. Login to your X-Aviation account here: https://www.x-aviation.com/catalog/account_history.php

2. Find your original TBM 900 download and re-download the file. It will download as the latest version!

The following is a list of additions/fixes included:
 
What's New / Changed:

Improvements / New Features:

  • Lightened all panel textures.
  • Adjusted panel textures to make the panels more readable
  • New glass texture work for much nicer reflection effects
  • Added new glass reflections to PFDs & MFD screens
  • Implemented screen brightness automatic & manual control.
  • Use MENU key on PFD to control screen brightness.
  • Landing gear should cast shadows in interior views
  • Cabin lights default to on to allow controlling them via the CABIN switch.
  • Cabin light button state is persisted
  • Implemented nulling of VR yoke inputs after AP engagement
  • Reworked airfoils for more realistic flight-handling feel
  • Adjusted stalling performance to be much closer to book numbers
  • Adjusted high speed performance to be closer to the book numbers
  • Added default RealSimGear command mapping file to ship with the plane
  • Corrected CG offsets to be closer to the real plane
  • Re-worked portions of the Payload Manager to allow displaying CG and manipulating exterior elements even when an FSE flight is active
  • AP code was restoring CRS2 to CRS1 value on aircraft reload
  • Disable X-Plane's built-in random failures on load and restore the setting on exit. We have our own failure logic.
  • Panel rendering performance improvement
  • Added printable normal checklists in PDF format, courtesy of Grau Adler

Bugfixes:

  • Sidebar drawer towing function should work from inside the cockpit.
  • G1000 NG redline should be 104% not 102%.
  • VOR intercepts were broken in the previous beta.
  • Removed icing effect from engine inlet lip, as that part of the inlet is heated by an exhaust bleed.
  • Switching CDI from NAV ro GPS while LOC mode was armed would crash on an assertion failure
  • Fixed missing "vertical track" annunciation broken by X-Plane 11.35
  • De-pressurization with RAM AIR wasn't fast/responsive enough
  • SVS was missing ILS & RNAV approach pathways
  • under new XP11.40 FM the elevator & rudder trim didn't have enough authority
  • Modified engine simulation to allow for greater power range at high alt
  • Downloading US obstacle database was horribly slow, resulting in soft sim lockup
  • Avoid printing weights in the load manager as negative zero
  • Hovering pilot door glass fixed
  • Removed spurious debug message being emitted to Log.txt
  • Generator wear rate was excessive
  • Cabin thermal conductivity wasn't responding properly to fast flight.
  • Fuel automatic selector wasn't correctly switching when the fuel level sensors were broken
  • Pressing a service button in maintenance manager didn't update the window
  • IAS selector window should use a completely black background, not dark-grey-black
  • Tow clickspot on nosewheel can be clicked through the instrument panel
  • ADC-generated alerts weren't taking sensor inaccuracies into account
  • Generator switch dataref was misnamed in docs
  • Main door was snapping closed when battery was drained and added notification if battery is drained and user attempts to operate the main door
  • Outflow valve & safety valve bleed-through rates were too low, resulting in lack of depress when bleed was closed
  • Fixed race condition causing a crash in panel rendering
  • Fire extinguisher was protruding out of the fuselage a touch
  • Hot air rheostat dataref doc was incorrectly labeled as temp_sel
  • Default the rain effects to OFF on Mac
  • Radio altimeter window could flash occasionally due to race condition
  • Synthetic vision system could cause a crash due to erroneously trying to load pixel data from a buffer, instead of allocating a blank buffer
  • Low-signal VOR & NDB behavior was reworked to use normal distributions
  • Low-signal DME error is now physically based
  • Removed unnecessary error messages about X-Plane navdata format errors
  • Implemented duplicate navaid removal to work around inconsistent data between hand-placed localizers and AIRAC data
  • ADF bearings are now relative and take into account pitch & roll

As always, thanks for being a customer with X-Aviation. We appreciate your feedback and support!


Enjoy these latest updates, and stay tuned to the forum as we continually announce the latest happenings.

  • Like 5
Link to post
Share on other sites
  • Replies 114
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello All, This will serve as a formal forum announcement that we have released the version 1.1.10 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an

I must say your advise is so far of all security thinking that i get sick to my stomach. I have worked as a security architect for the most of 20 year now. I have until now newer heard a software de

For everyone who still has issues to download the installer due to the false-positive trojan detection by Windows Defender: I posted on page 1 of this thread that I had sent the Linux installer f

Posted Images

My mac installer does not work. It´s the first time happens when Hotstart releases updates. Can anyone give advice on how to fix this?
 
 
107415814_Screenshot2019-12-07at09_39_19.thumb.png.a4d6b75dd08401b263b21b2df164712b.png


You have updated to Catalina since the last time you installed the TBM. You will need to manually delete the TBM that is already installed and also trash the TBM Uninstaller located in X-Plane/X-Aviation
  • Upvote 1
Link to post
Share on other sites
21 minutes ago, Cameron said:

 


You have updated to Catalina since the last time you installed the TBM. You will need to manually delete the TBM that is already installed and also trash the TBM Uninstaller located in X-Plane/X-Aviation

 

Thank you. That  worked.

Link to post
Share on other sites
Just now, marpilot said:

Not helpful. It is first time for 4 years I can't download the installer.

 

I don't have any assistance I can provide you for Windows Defender. Temporarily disable it or make an exception if you need to for downloading.

Link to post
Share on other sites
1 minute ago, marpilot said:

Strange thing, this is  the only file I can't download from the store.....

Not really that strange when you consider we don't ship Linux installers with other products but this one, and that the Linux installer is what Windows Defender falsely thinks is a virus.

  • Upvote 1
Link to post
Share on other sites
Guys, im not in any aspect "point fingers" on you OK ?
But im facing same issue while downloading TBM-900 new version.
Dont know what's going on.
Johnler Maia
 
Install.jpg.6f6907a9821441976882058e8c4eacf3.jpg


Please read the thread. It's already been explained.
Link to post
Share on other sites

I'm not sure what the proper way of reporting bugs is, so I'm just going to report it here.

I have had issues with the screens (PFDs and MFD) glitching a bit, flashing and reloading every now and then. I hoped this update would fix that, and the total glitchout happening when I try to reload the plane, but instead things got a lot worse. I think the best way to explain it is to just show a screen recording and attach a log file. I unfortunately forgot to save the log before starting X-Plane again, so the log file is a recreation of the flight and not the exact same flight. Below are links to two unlisted youtube videos showing the interesting experience I had.

Double rendering of the map in the MFD. CAS display missing. Flaps indicator nowhere to be found. Speed and altitude tapes just disappeared from the PFDs. Full throttle at climbout, no issues with overtorque or overtemp according to the meters, but if I have the warnings tuned on I do get warnings. Then when disconnecting the autopilot and starting a "somewhat" expedited descent things just went crazy. I lost all control of the aircraft way before even being close to overspeed. The weird camera movement is caused by a plugin (disabling the plugin doesn't help).

Not sure what to make of this. It's my favorite plane to fly in a sim ever, but I have had some issues with it lately unfortunately, and this update made things worse. It may be something wrong on my part, but I don't even know where to begin looking.

 

And here's what happens, and have happened for the past couple of versions, when reloading the aircraft. I have to exit the sim and restart to be able to reload the aircraft.

 

Log.txt

Edited by citronboll
Link to post
Share on other sites
  • Cameron locked and unpinned this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...