Jump to content

TBM freezes computer


Recommended Posts

Thought so.  This is one of those issues with AMD/Radeon GPU's and drivers.

Can you test in Windowed mode and see if that fixes it?

(I know it's not an ideal solution, but LR are aware of this issue and have contacted AMD several times about it.)

If it still hangs, let me know, and I'll look deeper.

Link to comment
Share on other sites

14 hours ago, agl said:

Ok, I will try a new flight with window mode.

But does the problem with AMD happen only with the TBM or also with other airplanes?

Thank you.

The tbm uses your graphics card and os drivers in complicated and unusual ways "compared to other aircraft" so what the other products do is irrelevant because their systems do not compare. 

Link to comment
Share on other sites

  • 3 weeks later...

Looking through your log file again, there is unusual activity going on.


First of all something about the gatekeeper license (our DRM) is showing up as "bad".  This might be nothing, but it might be something.

Is it possible that you can run X-Plane from your desktop instead of your OneDrive folder?  

Can you run a test with a new copy of X-Plane installed on your desktop.  No scenery.  No plugins.  Download the installer from the X-Plane website, run it, then update it.

Then install the TBM only.

Then test and see what happens.

Link to comment
Share on other sites

Are you using a 3rd party scenery?  

From what I can see, it looks as though X-Plane isn't even loading completely.  And it looks like it's your scenery (GMMI), with the TBM causing this.  If the TBM reads corrupt scenery, it will crash, because it's collecting information for the terrain radar.  Corrupt scenery will still load for other aircraft, because few aircraft use a terrain radar.

Try removing the scenery for the area, and just use default scenery.  Test and see if it crashes again.


Link to comment
Share on other sites

We both had a good look at your last log, and it looks like X-Plane just stopped.  

In particular, these lines...

3:48:43.752 I/SIM: Exiting the sim without confirmation
3:48:43.752 I/SIM: Exiting the sim without confirmation
3:49:00.015 D/STM: Transitioning from state state_Normal to state_ShuttingDown
3:49:13.372 G64:  core: Run: [OnBeforeXPSavePrefs]
3:49:24.142 G64:  core: Run: [OnBeforeXPSavePrefs]


So looking through everything, it looks like you flew for 4 hours, and then it seems you tried to exit the sim, but the sim froze.  

This is what we gathered.  

Can you confirm?


Edited by Goran_M
Link to comment
Share on other sites

The flight we are talking about is GCXO - LEAL (3:40 h am according to SimBrief) and it always freezes after half the flight. The order in which it happens:

I connect sim, 

30 minutes later I star to prepare the flight,


it freezes and then I try to exit the sim.

So, what did you see in the log that it means?, not caused by TBM?


Link to comment
Share on other sites

Ok, here are the important points we saw.

0:05:56.379 I/OVR: User is entering the holodeck.
0:05:56.379 I/WIN: Opened window Settings
0:06:03.025 I/JOY:      T.A320 Pilot Axis 0 assigned to joy_use_ptch
0:06:05.753 I/JOY:      T.A320 Pilot Axis 1 assigned to joy_use_roll
0:06:08.181 I/OVR: User is leaving the holodeck.
0:06:07.221 G64:  core: Run: [OnBeforeXPSavePrefs]
0:06:25.981 I/OVR: User is entering the holodeck.
0:06:25.981 I/WIN: Opened window Settings
0:06:32.623 I/OVR: User is leaving the holodeck.
0:06:31.663 G64:  core: Run: [OnBeforeXPSavePrefs]
0:08:19.175 I/OVR: User is entering the holodeck.
0:08:19.175 I/WIN: Opened window Settings
0:09:34.456 I/OVR: User is leaving the holodeck.
0:09:33.492 G64:  core: Run: [OnBeforeXPSavePrefs]
0:09:48.080 G64:  warn: Undefined function: ProcessKeyPress RawKeys_OnKeyHold
0:12:11.519 I/OVR: User is entering the holodeck.
0:12:11.519 I/WIN: Opened window Settings
0:13:53.812 I/OVR: User is leaving the holodeck.
0:13:52.851 G64:  core: Run: [OnBeforeXPSavePrefs]
0:14:23.765 I/OVR: User is entering the holodeck.


You opened settings, closed the menus. Back into settings, back out. Back in, back out. Several times in a row, separated by multiple minutes.

So far, so good.

0:04:20.439 I/WIN: Opened window menu bar
0:04:51.348 I/OVR: User is entering the holodeck.
0:04:51.348 I/WIN: Opened window Settings
0:05:03.063 I/JOY:      Saitek Pro Flight Rudder Pedals Axis 0 assigned to joy_use_rbrk
0:05:07.734 I/JOY:      Saitek Pro Flight Rudder Pedals Axis 1 assigned to joy_use_lbrk
0:05:18.474 I/JOY:      Saitek Pro Flight Rudder Pedals Axis 2 assigned to joy_use_hdng
0:05:34.106 I/JOY:      T.A320 Pilot Axis 2 assigned to joy_use_thro
0:05:43.018 I/JOY:      T.A320 Pilot Axis 3 assigned to joy_use_none
0:05:48.188 I/OVR: User is leaving the holodeck.

Assigning hardware.


Here's what we gathered so far up to this point.

1) Loaded the TBM at ICAO code GCXO

2) Gizmo checked the license, it's valid, 9 days remaining until a new license renewal

3) Opened settings window

4) Assigned a set of Saitek Pro Flight Rudder Pedals to left toe brake, right toe brake, and rudder yaw axis

5) Assigned the T.A320 throttle to left throttle and the other axis to nothing

6) Exited the menus

Still moving along smoothly.

7) Then reopened the settings and messed about a bit more with the throttle assignments

8) At some later point you tried to do an engine start on the TBM, which seemed to have worked (the ignition at least fired, it seems)

9) Then flew for nearly 4 hours

10) Exited the sim - At this point, this is the strange part.  The sim just stopped, but didn't properly unload.


So, everything up until this point is fine.  It's the shutting down of X-Plane that appears to be somehow stalled.

Is the above scenario what happened?  If not, can you clarify?

Link to comment
Share on other sites

Bien, parece que estamos en un callejón sin salida.

El lunes hice 2 pruebas con la TBM (GCXO-LEAL):

* Primera prueba: Limpié mi computadora, agregué ventilación extra (para descartar la posibilidad de calor) y bajé los objetos del mundo.

  Resultado: se congeló.



* Segunda prueba: todas las anteriores + Bajé la configuración gráfica.

  Resultado: se congeló.



Hoy martes hice 1 prueba (GCXO-LEAL):

* Con el airbus 319, sin ventilación extra y con efectos visuales en HDR, texturas en medio y objetos en medio.

  Resultado: perfecto.

Conclusión: no es mi computadora y no es X-Plane.

Creo que la complejidad de la TBM congela mi sistema.

Gracias por toda tu ayuda.


Edited by agl
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...