Jump to content

Unable to change radio decimal after 1.1 update

Recommended Posts


After updating to v1.1 the radio decimal (PFD radio inner knob) does not work unless I scroll super fast with my mouse scroll button. Slow or binding to joystick buttons does not work.

Radio whole numbers and other rotating knobs seem to work fine.

I have reinstalled completely, 3 times, both into old directory as well as into a new one.

Any advice appreciated,



Edited by osvaldsson
Correcting PFD and not MFD
Link to post
Share on other sites

There is no method to downgrade. 

I have tried to replicate this and I can not. I would recommend checking what other plugins you have, or perhaps a stuck button on a joystick. The radio commands are default X-Plane commands, so this issue most likely exists with something outside of the SR22 aircraft. 

Link to post
Share on other sites

I don't seem to be having this issue either.

I have never used the COM button on the MFD but did just give it a try when in pop-out mode.  Knobs spin fine.  The only weird thing is that it was tuning the COM 2 frequencies even though the cursor is set on COM 1.   That being said it's somewhat moot based on the way the Cirrus functions (no COM on MFD).

 COM button on PFD works fine.

Link to post
Share on other sites

I'll try and do a fresh X-plane install today and see how it goes.


It's not the peripherals as I've tried removing all of them. This also only affects the SR22 (and only this specific function), all other aircraft are fine.


And this is the PFD, not the MFD. That was my wires crossing. Left screen with the COM rotating knobs on the right side.

Writing on my phone but will upload a larger overview screenshot when I get to my computer.


Edited by osvaldsson
Adding the screenshot
Link to post
Share on other sites

Just to close this out, FlyWithLua has a built in module called radio.lua which executes the following code, amongst other things for consistency within scripts:

dataref("COM1_STDBY", "sim/cockpit2/radios/actuators/com1_standby_frequency_hz", "writable")
dataref("COM2_STDBY", "sim/cockpit2/radios/actuators/com2_standby_frequency_hz", "writable")

Setting those to "readable" will solve the issue, but doesn't help for those that intend to write to the datarefs from their Lua scripts. Using the 8.3 khz spacing datarefs will also fix the problem.

dataref("COM1_STDBY", "sim/cockpit2/radios/actuators/com1_standby_frequency_hz_833", "writable")
dataref("COM2_STDBY", "sim/cockpit2/radios/actuators/com2_standby_frequency_hz_833", "writable")


  • Like 1
  • Upvote 1
Link to post
Share on other sites
  • 1 month later...

Hey guys, just as a tip to get frequencies even faster....right above the keypad on the console is the "COM" button.  You can press that, enter the frequency on the keypad, press enter, and transfer it over.  If you see that there are FMS / COM / NAV buttons....that means you can use that number pad to enter information into either of those systems.  Much quicker than rotating knobs.  Sometimes it bugs out, but I found that if I enter XXX.YYY <enter> <--> it works fine. Ex: 119.3 would be entered as 119.300.

Happy IFR-ing.!


  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...