Jump to content
ocaravaca

Sun_Glow_socked.png . Critical error.

Recommended Posts

Good morning,
I acquired yesterday SkyMaxx Pro v 4.8.2
I am happy so far with it, but I have noticed a couple of bugs. I know they are related to this product.

The first one is XPlane does not like any more to change from one airport to another or change planes... sometimes it crashes even without the crash reporter. It just disappears and nothing can be found in the Log.TXT This has only happened since I installed SkyMaxx Pro

The second one, as per the screen below has been the second time. First I thought this archive was related to X-Plane, so I rerun the installer and was not fixed. Then as the only change I did yesterday was installing SkyMaxx Pro, had to reinstall and install it again, and it was fixed.
This morning, I have again the same  issue. Of course I cannot even open X-Plane at all. And I hope this has been either reported before (but I cannot find it in the forum) or I can do something to remediate uninstall/reinstall a couple of times a day.
This file gests corrupted because I noticed yesterday after reinstalling had a size of 5kb, and today and yesterday when the error happened although the file exists, the size is 0kb.
I do not have any LUAs running, nor nothing that could clash with SkyMaxx. Just the normal... (IVAO, Avitab, BetterPushback, XPUIPC, and I think that´s it)
Any help is appreciated.

image.png.3dd684951e7b3ee5c8ce74530c3ac6a5.png

Share this post


Link to post
Share on other sites
3 minutes ago, JohnMAXX said:

Something is definitely off here first step, please provide us a log.txt file....

Will do as soon it happens again (hopefully not). THANKS :)
I have reoladed Sky Textures this time after reading the documentation. Do not know if that will fix it, but the PDF says it is only related to XP v10.... That could be something to be fixed too.
 

Edited by ocaravaca

Share this post


Link to post
Share on other sites
Btw... Just testing again...The sun glow in the water is also not aligned with it. It was also happening yesterday.
image.thumb.png.af15985b00b00d6baa73cdd8e260cdb8.png



This is normal. X-Plane utilizes it's own sky model and we utilized one that mostly matched with X-Plane. Some times of the year they will slightly misalign.

Share this post


Link to post
Share on other sites
3 hours ago, JohnMAXX said:

Something is definitely off here first step, please provide us a log.txt file....

Hi @JohnMAXX

Find it attached. Unfortunately it has been the third time, after a crash that occurred moving to a new airport. 
I am going to reinstall it again. By the time it happened I had ASXP closed down if that is of help.
I am also doing a review of your product and it will be in Youtube in a couple of hours hopefully as I have really liked it and I am enjoying a lot your support so far.

Congratulations on this brilliant product!!!!

7 out of 10 so far, but in my opinion the best I have been playing with so far, hence... THAT IS GREAT!!!!!

Log.txt

Share this post


Link to post
Share on other sites

It has been the 5th time with the same error on that file :(
I do not know if this might be of any kind of hint but before I had installed UWXP. I do not want to go back, as now that I have added also Real Weather connector, the combination of SkyMaxx Pro + RWC + ASXP is absolutely the closest I have seen X-Plane to look to reality in flight...
Any clue @JohnMAXX (BTW, I am tagging you as I guess your are closely related to SkyMaxx if not one of the developers). Please do let me know if I should not.

Share this post


Link to post
Share on other sites

It seems like a file permission issue or perhaps a corrupt installation or drive at play here. I would install a fresh X-Plane into a directory where your user account has full permissions (not inside program files, for example), add SMP/RWC, and see if that works more reliably.

Under the hood we are replacing X-Plane's sky textures with our own when SMP starts up and replacing them when we shut down, and something is going wrong in that process.

  • Like 1

Share this post


Link to post
Share on other sites

Hi @Sundog
The fact is that it is not in "Program files", it´s in the folder shown below, and other software I used before that makes similar stuff (UWXP) had no issues with this.
image.png.5b679079f156e8d1cba37f2b25002446.png
The whole point is that before this started happening all was working fine. When this happened the first time I thought it was related to X-Plane, hence I rerun the installer. It found few files (related with textures and they were overwritten). Same thing I´ve done just an hour ago, as the problem appeared again. It also happens randomly, it is not everytime I close XP11...
I do not know if this can be of help, but I am sharing with you also an image of the folder that has this file...it calls my attention that the length of the file in dispute is 0kb.
I would not mind either grant you access to my computer if you´d like to take a look directly. 

THANKS A LOT FOR YOUR QUICK RESPONSE. Not only you have a great product, but you also have a great team supporting your clients.

image.png.a095e71cb33a1366cbbb243228db9d26.png

Share this post


Link to post
Share on other sites
2 minutes ago, ocaravaca said:

Hi @Sundog
The fact is that it is not in "Program files", it´s in the folder shown below, and other software I used before that makes similar stuff (UWXP) had no issues with this.
image.png.5b679079f156e8d1cba37f2b25002446.png
The whole point is that before this started happening all was working fine. When this happened the first time I thought it was related to X-Plane, hence I rerun the installer. It found few files (related with textures and they were overwritten). Same thing I´ve done just an hour ago, as the problem appeared again. It also happens randomly, it is not everytime I close XP11...
I do not know if this can be of help, but I am sharing with you also an image of the folder that has this file...it calls my attention that the length of the file in dispute is 0kb.
I would not mind either grant you access to my computer if you´d like to take a look directly. 

THANKS A LOT FOR YOUR QUICK RESPONSE. Not only you have a great product, but you also have a great team supporting your clients.

image.png.a095e71cb33a1366cbbb243228db9d26.png

Also worth indicating, that while XP11 is running I have just noticed that those files change the size... I guess this is what you have mentioned that you copy-replace original files on start, and exit. In the screen below you can see the same screenshot when XP11 is running as is now. (The previous was with XP shutdown)
image.png.a4d7dde5cde9757d5f3d5528b70d49db.png

Share this post


Link to post
Share on other sites

I wonder if having used UWXP previously somehow manipulated some of these files in ways we didn't anticipate. When you re-installed X-Plane as a test, did you completely un-install it and delete its directory within steamapps/common before re-installing?

Share this post


Link to post
Share on other sites

I think that might have been the issue. (UWXP)
I installed it again yesterday, as I found that to uninstall is not enough deleting the folder and I have unistalled it following the instructios (they mentioned something of restoring "textures" to standard X-Plane before removing the folder, and that is what I have done)
For the last 3 - 4 times I have opened and closed now X-Plane I did not received the error anymore, so I think it might be related to it. 
I have not contacted you yet as I am further testing...but so far, let´s assume together this has been fixed. Otherwise I will let you know. THANKS A LOT, and I have to admit not only SkyMaxx Pro is a MUST have product, but I can also say your help has been really great on this regards. Really surprised about you taking this huge interest.

If I am allowed to continue in this thread, as I do not want to make a big fuss...
Another two friends have bought SkyMaxx following also my advice and the video I made; and they have also find the following issues:
1) The sun reverb appeares offset from where it should be, regardless the date or the place where you are, so the comment from @Cameron I think it´s not accurate. There were some pictures also attached before, but find this one too.
image.png.310682a848fc7e8719808856a9d4b826.png
2) I think I did not report this, but  unless I choose "Skymaxx-Hosek Wilkie...." color configuration, I cannot see the sun in any other sky.... really weird, and also one of my friends that bought it mentioned the same yesterday.
image.png.a44e27213ad87c9339e894adf8fa5aed.png

3) is just a question... which I guess I could make some test to find out by myself, but it is as UWXP changes Water Textures (SkyMaxx Pro doesn´t) and lights during night. I wonder if both products could be compatible. I could disable clouds and colors in UWXP but just wondering if you have any news about this before opening a new thread once I have tested and check if it can work well together. I am sure you will see more and more people coming to SkyMaxx Pro from UWXP in the very soon future, so it would be good to create a thread with the things I am learning so far to support others ;)

Kind regards,
Oscar

 

Share this post


Link to post
Share on other sites
28 minutes ago, ocaravaca said:

1) The sun reverb appeares offset from where it should be, regardless the date or the place where you are, so the comment from @Cameron I think it´s not accurate.

What I stated is accurate.

29 minutes ago, ocaravaca said:

I am sure you will see more and more people coming to SkyMaxx Pro from UWXP in the very soon future, so it would be good to create a thread with the things I am learning so far to support others ;)

That would be great, but SkyMaxx Pro has been on the market much longer and things are pretty predictable now. I do not think there will be an influx. :)

I don't know if what you're asking from UWXP will work or not. Experiment, I guess!

  • Upvote 1

Share this post


Link to post
Share on other sites

@Cameron...
1) Then there must be something I have understood wrong around your comment... you mentioned it is because "X-Plane utilizes it's own sky model and we utilized one that mostly matched with X-Plane. Some times of the year they will slightly misalign.X-Plane"
So, what I understand from that, is that it is a fault from X-Plane and not related to SMP,  which I could understand it is, unless you check this other video I did some time ago, and then you will notice the reverberation of the sun in the water and the sun are almost perfectly aligned, and not that huge distance that I can only see after having installed SMP as in the pictures attached earlier. Honestly, I have tried different airports (so I change lat-long), different days, summer, winter, the exact day as I took the video below indeed, and I always see the gap-threshold between the sun and the reverb.
3) You are right, I will make few tests with UWXP and will share the findings about using water textures and night lights enhancementes.
2) Any news in regards to it? As mentioned, that "Skymaxx-Hosek Wilkie...." color configuration" is the only one that shows the sun in the skies. Everything else is hiding it.

THANKS AGAIN FOR YOUR QUICK RESPONSE BEFORE :)

 


 

image.png

Share this post


Link to post
Share on other sites
1 hour ago, ocaravaca said:

So, what I understand from that, is that it is a fault from X-Plane and not related to SMP,  which I could understand it is, unless you check this other video I did some time ago, and then you will notice the reverberation of the sun in the water and the sun are almost perfectly aligned, and not that huge distance that I can only see after having installed SMP as in the pictures attached earlier.

You're showing me a video of a sun with proper reflection that's controlled by X-Plane long before you ever purchased SkyMaxx.

As I've already told you, SkyMaxx has it's own sky model. The sun is a part of that SkyMaxx sky model. X-Plane still controls the sun reflection on the surface of the water based on its own sky model and where it thinks it should be. It can be slightly off at times. There's nothing we can do to alter that.

1 hour ago, ocaravaca said:

2) Any news in regards to it? As mentioned, that "Skymaxx-Hosek Wilkie...." color configuration" is the only one that shows the sun in the skies. Everything else is hiding it.

@sundog is the only one that can answer this.

  • Upvote 1

Share this post


Link to post
Share on other sites

Understood now... I thought you were only changing the colors, not also the sun position... now it seems more reasonable. Thanks @Cameron  :). Anyway the video was filmed using UWXP. By any meanings I am trying to say that is better at all...that is why I have moved to yours of course. I do not have the knowledge to tell you how the whole alignment sun-reflection is managed on it together with X-Plane. We will wait for Sundog to come back on the last one.
Anyway, as we only write to complain many times... I just want you to take the ocassion to congratulate you about this great product. For sure I will survive with sun reflections slightly moved in water ... LOL.
What a shame I did not hear about SMP earlier. I am already doing a good marketing of it on the FB groups I use to post, mainly in Spanish ;).

Share this post


Link to post
Share on other sites

It's certainly possible that the way X-Plane's sky is drawn has recently changed such that it draws over our sun. When you select Hosek-Wilkie (our default), we also draw the sky which is why things work in that case.

I'm planning to put together a minor bug-fix release soon, and I'll take a closer look at this. Thanks for reporting it.

Share this post


Link to post
Share on other sites
26 minutes ago, sundog said:

It's certainly possible that the way X-Plane's sky is drawn has recently changed such that it draws over our sun. When you select Hosek-Wilkie (our default), we also draw the sky which is why things work in that case.

I'm planning to put together a minor bug-fix release soon, and I'll take a closer look at this. Thanks for reporting it.

You are most than welcome sir.
As mentioned earlier to Cameron, I am really excited about your product, your quick response, and mostly your interest in helping the simulation community. A great surprise to start December. 
THANKS.

In any case you need to check anything in my computer, just count on me for support as I have spare time for it ;)

Share this post


Link to post
Share on other sites

OK, so I looked into this. It seems that X-Plane's sun returns when you restart the sim after changing the sky colors. That's expected; it's why we say in the config dialog that you need to restart the sim for changes to take effect.

When you select Hosek-Wilkie, SkyMaxx Pro draws the sky and sun over X-Plane's. When you select anything else, X-Plane draws the sky and sun and we don't mess with it. I think this is just a long-standing issue with X-Plane itself, but it's why we tell you to restart.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks you so much... as the background colors were changing, I did not even read through your information text on it and stopped in the detail... 

 

Edited by ocaravaca

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×