Jump to content

Help!! Can't run X-Plane 12 whatsoever


VirtualGAaviator
 Share

Recommended Posts

I have a computer running an i-9 14900K CPU with 32GB of RAM on an Samsung EVO Pro SSD with Windows 11 Home. The power supply is 1200watts. For some reason the system became unstable. I started getting X-Plane 12 crashes to the extent I could complete every 3rd or 4th - 1 hour flight in the 737-800NG. BSODs went from occasional to 1 or 2 per day. This seem to occur over a period of a month, or so.  MSFS would occasionally crash also for no apparent reason. I tested the RAM vigorously with MEM86+ and stressed the CPU and Motherboard. No BSODs. I concluded that the issue must be a failing M.2 SSD windows boot drive, so I replaced it. Same result.

Today, I reinstalled windows on a new Samsung Pro SSD.  I wiped the drive containing X-Plane, destructively formatted it and reinstalled X-Plane 12. Basically, Windows and X-plane are the only real apps on the computer at this point. Both are fresh installs.

X-Plane 12 tries to load but fails. Digging into the Event Viewer reveals the following error under Custom Views>Administrative Events:

Event 100, Application Error

Faulting application name: X-Plane.exe, version 12.0.9.7, timestamp: 0x65a5667e
Faulting module name: X-Plane.exe, version 12.0.9.7, timestamp: 0x65a5667e
Exception code 0xc0000409
Fault offset: 0x0000000001bd4051
Faulting application start time: 0x01da647a0df0c9fc
Faulting application path F:\X-Plane 12\X-Plane.exe
Faulting module path F:\X-Plane 12\X-Plane.exe
Report Id: 567fc31e-3285-42ae-86d8-14f83bc6944a
Faulting package name:
Faulting package-relative application ID:

Log Name   Application

Source       Application Error ... (there's more but I don't think it's germane to the issue)

 

I've tried restalling X-Plane on Drive C: the SSD Boot drive - same result. So far X-Plane is the only program that has this issue. A different licensed copy of XP12 is running on my older computer without issues. My motherboard is under warranty but ASUS believe's it's a software issue. I'm at my wit's end. Hopefully, you can help me fix this. I'm desperate.:(

Edited by VirtualGAaviator
clarity
Link to comment
Share on other sites

I'm still dead-in-the-water with my flight sim rig. I've concluded it's got to be a hardware problem so I'm going to try to RMA the motherboard. The issue I'm facing now is this:

I've reverted to my old computer with runs a i7-6700K CPU and a 1080Ti graphics card. Both a licensed copy of XP11 & 12 runs on the computer. However, I have a ton of add-ons that are registered to the misbehaving (preferred) computer. I don't know if I can transfer the addons to the old computer and back to the preferred computer if I get it working. To make matters more complicated, I also have an i9-12900k CPU, a separate motherboard (the i9-14900K and i9-12900K sockets aren't compatible) and 64gb of DDR4, sitting around. Again, If I were to deploy that hardware, I'd still have the problem of using add-ons since it'll technically be a different computer.

Kinda sucks simming without my favorite addons. I've RMA'd the 12900k motherboard last year and it took about two weeks to get it back.

If you're wondering why I'm hanging onto all this hardware - I lend the hardware to my EAA chapter during our Young Eagle events (I need to finish the build on the 2nd computer).

Edited by VirtualGAaviator
Link to comment
Share on other sites

  • 3 weeks later...

What a fiasco? Whew!

So I RMA'd my ASUS Hero Maximus Z790 motherboard. ASUS received it, claimed it was damaged (which I can assure you, it wasn't when I shipped it) and sent me an invoice for $663.00. That's close to $70.00 more than I paid for the motherboard. The damage they cited is a corner of the wafer that is broken, something I find it hard to believe happened in shipping. The damage, IMO, is more consistent with mishandling.

I ordered, received and installed a Gigabyte Aorus Z790 motherboard. To my surprise and horror, I got the same results. BSOD and frequent application crashes. Therefore, I concluded that I sent ASUS a perfectly good motherboard and the real culprit is the CPU.

Perhaps this theory is part of an active imagination, nevertheless; I present this theory anyway. ASUS received the motherboard, tested it and couldn't reproduce the issue. The tech, decided to create a real issue, rather than return it as received. Yeah, I know this is wayyyy out there, but I'm trying to make sense of how the board got physically damaged. Anyway a tech, during a phone call, suggested that I allow ASUS to file a claim on my behalf for the damage (I purchased the shipping label from ASUS). That's where I stand at the moment with this... crap.

At this point, I've replaced the SSD drive, motherboard, and finally the memory. The problem is apparently a faulty i9-14900K CPU. Yesterday, I started to process, with Intel, to RMA it. Wish me luck!

Link to comment
Share on other sites

  • 2 weeks later...

Yup. Perhaps I should have choosen AMD :(.

ASUS approved my claim so I should be getting the ASUS Maximus motherboard back soon. I would have purchased my own label rather than ASUS's shipping label. except I would have needed to add $500 worth of extra insurance. Anyhow, I've been working for days trying to RMA my Intel i9-900K processor. I think I have one more hoop to jump through before they'll take it back. In the meantime, I've purchased an I9-900KF CPU and the sim runs. The CPU was the root of my problems. My computer woes are costing me a fortune. If it wasn't for missing simming I'd waited. Guess I'll get in a flight now. Cheers.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...