Jump to content

vSpeed callouts for HotStart Challenger 650


Recommended Posts

vSpeed callouts for HotStart Challenger 650

View File

Hello Captains!

New callouts in v0.102. Check out demo below.

A LUA-script for v-speed callouts for the HotStart Challenger 650 v1.2 or higher.
It includes callouts for 80 knots, V1, Vr, V2 (V2 is optional) and positiv rate / gear up.

The script is tested on X-Plane 11.55 on Windows 11.

Feel free to leave a comment if you liked the script (or not) :)

Requirement:
- https://forums.x-plane.org/index.php?/files/file/38445-flywithlua-ng-next-generation-edition-for-x-plane-11-win-lin-mac/

Installation:
- Unzip the files in [X-Plane]\Resources\plugins\FlyWithLua\Scripts

You should get a structure something like this.

ttbVZx8.png

 

Settings:
Edit the Wizball_CL650_vSpeed.lua for the settings. 

-- Set to true to enable "V2" callout and false to disable. true and false have to be written with lowercase letters.
local Enable_V2 = false

-- Set to true to enable "Positive rate/Gear up" callout and false to disable. true and false have to be written with lowercase letters.
local EnablePosGearUp = true

-- Set to 1 for callout by totoritko(HotStart). Set 2 for callout by xplana.
local CalloutVoice = 1

-- Change "SoundLevel" to adjust volume for the callouts. Adjust between 0.10 min - 1.00 max.
-- Recommended value for CalloutVoice 1 - 0.70 - For CalloutVoice 2 - 0.30
local SoundLevel = 0.70

How to use:
Just make sure you set the vSpeeds in the FMS and you will get the callouts.

Demo:

Known bugs/limitations:
- Non at the moment.

 

Credits:
totoritko and xplana for the callouts
 


 

  • Like 1
Link to comment
Share on other sites

2 hours ago, corsica002b said:

Hello and thank you for this little extra I would like to know I modified the lines as you said but it does not work for me can you tell me exactly the lines to modify because I marked true instead false everywhere? I did something wrong thank you

Hi.

What settings did you try to change ? you don't need to change anything to get the callouts to work.

The default settings should work for everyone.. (This is the settings I use)

The only default setting that are false is

local Enable_V2 = false

If you want to have V2 callout you need to change it to 

local Enable_V2 = true

important here is that you write it true  with small letters. not True, TRUE etc...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...