Jump to content

VR compatability


Recommended Posts

Good day,

Having recently started to fly in VR, there are few things that would benefit VR experience with iXeg B733, namely please consider substantially reducing "sensitivity" of course, speed, heading, altitude, and com1 knobs (critical for us flying in online networks such as IVAO/VATSIM, with precious time during critical phases of flight). Adjusting these knobs through controllers is a torture, so I had to map all these knobs to keyboard buttons, which is not desired option. I did notice that rotating NAV1 knob with controller is easy and that is what the end result for the rest of knobs should be IMO.

I understand in real aircraft some of these knobs are also sensitive, but perhaps add a setting for 'VR reduced knob sensitivity'?

Thank you.

Edited by Morten
Link to post
Share on other sites
  • 4 weeks later...

It seems like iXeg is not compatible with XP 11.30 in VR. I have noted this during beta releases of 11.30 release candidate versions, but then reverted back to 11.26 hoping it will be resolved in stable 11.30, but it's not. At random, usually during DAYTIME flight (has not happened during night flight), most cockpit textures turn black (see screenshot below). Recycling views, turning VR off and back on, reloading scenery/aircraft does not help. BUT by turning VR off (that blue button in the bottom left corner) when I get back to conventional screen output, all textures are fine; back to VR and it's all black again. This has not happened in 11.26.

Basically, ixeg is now totally unusable in VR. 

 

Another issue I noted during my night time flight, was that I could see illuminated rain/snow particles inside cockpit with runway turnoff lights turned on during climb/approach (otherwise particles are outside, when aircraft is stationery). This is minor issue, obviously, compared to the first problem.

 

Draw vortices/etc setting is turned off.

B733_329.png

Edited by NZWW
Link to post
Share on other sites

I tested this for a few minutes and so far it works fine on my system. Now you said that it takes a while to show up - I will run some longer tests tomorrow to see if I can reproduce this.

Do you have any addons installed like XVision, Xenviro, etc? Or do you run a clean installation?

Thanks, Jan

 

Link to post
Share on other sites

This is my plugins folder. Heavy add-ons include ActiveSky, SkyMaxxPro and RealWeatherConnector.

No new plugins/addons since update to 11.30 from 11.26.

 

Additional observations: looks like it doesn't happen while aircraft is on ground, and definitely does not happen during night (dark) time flight.

Screenshot_3.png

Edited by NZWW
Link to post
Share on other sites

Thanks for the added clarification! I will check during daylight flight today!

My money is on the silver lining plugin. There are a few new problems in 11.30 with add-ons that mess with art datarefs that did not appear before 11.30. One example is our own "show vortices" option - it worked ok pre 11.30, but was really a borderline "hack", and doesn´t work with 11.30 anymore. Laminar will not maintain compatibility with these plugins on the way forward, because it considers them unsupported code to be done at your own risk.

So there is a good chance I won´t be seeing this (and so far you are the only user) - and if I put this up with Laminar, the response will be "try without ANY addons installed and see if it still happens. Then add them back one by one, see which one causes it and take it up with that dev!" :mellow:

Cheers, Jan

 

Link to post
Share on other sites

Spot on Litjan, it was SkyMaxxPro indeed. Apologies for pointing at iXeg for this. Luckily, after considerable elimination process it was specific cloud setting option that caused this on any aircraft, including default. It would have been shame not to be able to use SMP and iXeg together because they are the best products for XP! 

 

For those who encounter this problem too -- do not set "Broken Stratiform" clouds in SkyMaxxPro (version 4.7.3 in XP 11.30 with VR), select "HD Cloud puffs" instead.

As to rain inside the cockpit, it is also SMP's issue, to fix it set 'default' precipitation style, but rain/snow drops will move along with your head movements, which looks wrong, but not that critical and less noticeable in-flight. 

Edited by NZWW
Link to post
Share on other sites

Glad we got this sorted out - we are always bound to have compatibility issues like this as developers of all add-ons work on the cutting edge of whats possible with X-Plane. Sometimes it´s hard to say "who is to blame" (cough - show vortices - cough), but it helps to find out and reproduce these conflicts and let the devs know.

Thanks, Jan

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...