Jump to content

TerraMaxx not accurately detecting temperature


Recommended Posts

Or at least that's what feels like is happening. I've loaded up KTEX in Telluride, CO. Real world weather at the time was -6*C and snowing. TerraMaxx defaulted to off (Maybe because I loaded a situation from before I purchased TerraMaxx? Idno), set it to auto, and it starts loading summer. Now it did load up a kool fresh snow fall look, but not accurate or what's to be expected. Try setting the deep winter threshold to 10 C instead of the default 0. No dice. Go into manual weather setup to change the games displayed temperature units from Fahrenheit to Celsius, incase that actually changes something on the back-end. Still no dice. Set the season manually to deep winter. Loads up correctly. Try mild winter manually too. Also looks fantastic. So I'm not sure what's happening here.

I also seem to be having the same issue @jfwharton was having with TerraMaxx not retaining settings. Only I'm not using OpenGL, I'm using Vulkan. And @jfwharton seemed to have it retain under Vulkan but not OpenGL. But not initially? Or consistently? Which just leads me to believe the rendering engine has nothing to do with this issue. But it might be related to the temperature detection issue, if the plugin is failing to access the file system properly. The only thing I see with potential for issue is the permissions for the TerraMaxx folder being read/execute for Users and read/write/execute for Administrators/System. Does X-Plane silently run at administrator by default? It certaintly doesn't ask for admin execution at startup. And then if not, should it be run as administrator or should that folder be given user write permissions? I presume X-Plane should be run at the user-level and I should make it's resources read/write/execute at that level, but sometimes what's logical isn't always the case. I'll try some experimenting, but any help with this matter would be greatly appreciated.

Link to comment
Share on other sites

Ok. I went ahead and restarted X-Plane, and started a fresh new flight at KTEX. It remembered I had left TerraMaxx on mild winter. I'll just make an assumption that my load situation caused it to load off earlier. (No Idea why it didn't stick initially, works now) Go ahead and try auto again. Loads up summer. METAR still -6*C. I'll have to just do manual mild winter for a bit I guess. Weird that it's loading summer.


EDIT: Further testing today, loaded up KGUC. It's -16*C, try auto again with -2*C for the deep winter cutoff. Loads up mild winter. Figure it should be deep, but it does at least load winter this time. Then I goto the plugin folder to poke around, open seasons.txt config, and notice the WINTER MIN N LAT is 1 tile further north than KTEX. Go ahead and change it from 38 to 35 for testing, plus I know tiles in the +35 that get snow. Load up KTEX again, -11*C, loads up summer. Restart X-Plane, and with a fresh plugin load, loads up mild winter. I'll definitely tweak seasons.txt to my liking.

But still mild over deep, am I too close to the winter cutoff border? Load up KBZN, -14*C, still mild. Fiddle with the deep winter cutoff slider, hit +2*C, loads deep. +1 stays deep. Stupid mouse blows through 0, -1 loads up mild. Get it on the default 0, loads deep. Am I misinterpreting the function of the deep winter cutoff? For now I'll just leave it on the default setting.

Edited by nikdog
Link to comment
Share on other sites

Sounds like you uncovered the logic of how latitude and the month plays a role in addition to temperature. If your latitude and month maps to winter, then the decision between "mild" and "deep" winter is a simple comparison; if the current temperature (C) is greater than the cutoff temperature, we choose mild winter (assuming you are set to "auto" mode.)

We obtain the current temperature via the dataref sim/weather/temperature_sealevel_c - so one possibility is that this is not in sync with your METAR data for some reason. It's possible some other addon is modifying it, or even that X-Plane itself isn't setting it to match what's in your METAR.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...