Jump to content

Recommended Posts

I am using 1.1.9, which is a major improvement on 1.1.8 which didn't run on my machine.  However, now that I am back flying an excellent machine, I have found that the elevator trim is virtually ineffective using either my Saiteck  X56 stick or the mouse within VR.

 

Has anyone else come across this problem??

Link to post
Share on other sites
18 hours ago, ColSig said:

I am using 1.1.9, which is a major improvement on 1.1.8 which didn't run on my machine.  However, now that I am back flying an excellent machine, I have found that the elevator trim is virtually ineffective using either my Saiteck  X56 stick or the mouse within VR.

 

Has anyone else come across this problem??

@ColSig As @marpilot stated the big gotcha is not flipping the AP/TRIMS switch to ON. If the AP/TRIMS switch is positioned to On and the elevator trim is still in-op, then take a glance at the Circuit Breaker panel on the right side of the cockpit and make sure the 7 1/2 AMP AP SERVOS circuit breaker is not tripped as this breaker does effect elevator electric trim.

Also, if the above is not the issue take a look at your Saitek X56 and make sure the control/s you are using for elevator trim are still assigned.

Hope it helps!

Dwight

  • Like 1
Link to post
Share on other sites
21 hours ago, ColSig said:

Well done both of you.  Finger trouble during start up!!!  Never too old to learn and re-learn

Well I can't say I haven't made the same mistake a time, or two, or three.....:rolleyes: Most of the time in my rush to enjoy the wild blue skies and not following the 'After Starting Engines' checklist, I run into this too.....:lol:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...