Jump to content

Automated speedbugs script for vSpeed Call outs


Recommended Posts

  • 2 weeks later...

This one is also cool

Says 1000 to go, if plane is 1000 ft from altitude on mcp. Thats what they do, i heard

 

local thousand2go = load_WAV_file(SCRIPT_DIRECTORY .. "IXEG_Calls_Sounds/thousand2go.wav")
local thou2go_played = false

	dataref("mcpap_a_ann", "ixeg/733/MCP/mcp_a_comm_ann","readonly")
	dataref("mcpap_b_ann", "ixeg/733/MCP/mcp_b_comm_ann","readonly")
	dataref("autoalt", "sim/cockpit2/autopilot/altitude_dial_ft","readonly")
	dataref("cptheight", "sim/cockpit2/gauges/indicators/altitude_ft_pilot","readonly")
	

function Alt2go()
	if mcpap_a_ann == 1 or mcpap_b_ann == 1 then
		autoaltb = autoalt - 1020
		autoaltt = autoalt + 1020
		if (cptheight > autoaltb) and (cptheight < autoaltt) and not thou2go_played then
			thou2go_played = true
			autoalt_o = autoalt
			play_sound(thousand2go)
		end
		if thou2go_played and (autoalt ~= autoalt_o) and (math.abs(autoalt-autoalt_o) > 1900) then
			thou2go_played = false
		end
	end
end
do_often("Alt2go()")

 

Link to post
Share on other sites

I have instead use the following equations :


            if calageV1 then TakeoffDecision = (calageV1 * 1.5) - 90  end
            if calageVR then TakeoffRotate = (calageVR * 1.5) - 90   end
            if calageV2 then TakeoffReference = (calageV2 * 1.5) - 90 end

Link to post
Share on other sites
1 minute ago, XPJavelin said:

I have instead use the following equations :


            if calageV1 then TakeoffDecision = (calageV1 * 1.5) - 90  end
            if calageVR then TakeoffRotate = (calageVR * 1.5) - 90   end
            if calageV2 then TakeoffReference = (calageV2 * 1.5) - 90 end

If it works, it works...

Link to post
Share on other sites
  • 2 years later...

HI,

the captain speed bugs always go to the position on the screenshot below.

When I try to set them manually, the speed bugs always jump back to this position.

1036275761_Captainbugs.PNG.253c9f46590a01aba1029febffe60774.PNG

I updated to the IXEG V1.3 and I'm using the latest version of FlyWithLua.

Could that be the reason why the speed bugs don't work properly?

How do I fix this or can I remove the automatic bug setting in a safe way?

 

Edited by Nolemming
Update after several tests
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...