Jump to content

Recommended Posts

Hello all. 
I got home from work today and decided to download the 737 update along with the skymaxx update. 

I turn XP10 on, uninstall the old installations and install the new ones and get to the new activation box. I pop in my email address and password, and chose a name for my PC. I then get a message telling me that my Machine ID has been blacklisted?!! 

I uninstall IXEG - still get it,
I uninstall skymaxx - still get it
I uninstall - RWC and I still get the box. 

I have no X-A products installed yet I am getting hassled by an activation bow which only tells me that my Machine has been blacklisted (for unknown reasons). 

What should I do? I have submitted a ticket to support with hopes that it will be fixed. But maybe you guys need to be aware of this bug? If it is a bug that is. 

No issues with this until today! 


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.