Jump to content
cgw44

737 is autopilot unusable after update

Recommended Posts

Last year I had no problems with this aircraft prior to v1.21 but I've tried on 3 different occasions to use this aircraft  after the update

and the autopilot just doesn't work right at all. What happens is after I lift off I turn on the autopilot at above 1000ft

and when I try to activate ANY kind of vertical mode nothing works - I get a flashing autopilot amber light or sometimes it shuts off if I try vs mode.

VNAV does not engage at all no matter what. I've been in this hobby for years and never had issues like this and like I said prior to this update I had no problems.

I also redownloaded the aircraft each time I attempted to use it.

Totally stumped! 

 

Share this post


Link to post
Share on other sites

Increase the joystick deadband in the IXEG preferences menu - your joystick is sending a pitch signal to the autopilot, which will prevent engagement of the autopilot modes, just like in the real plane.

Let me know if this helped!

Cheers, Jan

 

  • Like 1

Share this post


Link to post
Share on other sites

YES....after a year - we're back in business!    Much appreciate the help!!

It never occurred to me that this was the issue. I did notice the red bands in the joystick deadzone menu on previous occasions looking thru the menus but I didn't think anything of it. I thought it was going to be a plugin conflict issue and I almost started shutting down plugins to see which one was the culprit.

Again...thanks for the help!

Edited by cgw44
  • Like 1

Share this post


Link to post
Share on other sites

Same problem here, increased from 0.17% to 0.20% and that nailed it.

Thanks a lot Litjan, as always so helpful :)

  • Like 1

Share this post


Link to post
Share on other sites

Dear Litjan,

I'm coming back with this problem again, it seems that did not really solve it. I increased the joystick CWS to maximum (0.25%) but I'm stumbling with the same problem as yesterday: LNAV enganges, VNAV fails to engage, without any warning or error on the FMC. I appreciate any help to troubleshoot this issue :)

Br,

A.

Share this post


Link to post
Share on other sites

Sorry, I have no idea what could be causing it - it works as expected (within the limitations of how - imperfect - we modeled it) for me.

Make sure the PERF INIT page is fully filled out and that your joystick is not spiking. Also if you are too far away from the vertical profile, VNAV can not engage. Remember that the FMC is a computer from the 80s - not an iPhone. It will often not tell you what is wrong, with no warning or explanation. Back then the coders expected the user to learn all the limitations and rules when using a computer system. So often sometimes something simply "will not work" and you can´t really tell why.

Another good example is the dual-channel autopilot approach. If one of the requisites is missing (like second ILS tuned), the second autopilot will simply not engage. There is no warning message or explanation. It simply won´t. You could often see real pilots sit in the simulator when doing the CAT3a part of the checkride scratching their heads over this..

So without looking at you performing the setup and flight I have no way of telling why it won´t work. But I have a good piece of advice from the real cockpit: If something doesn´t work, do something else that does work. ;)

Cheers, Jan

 

Share this post


Link to post
Share on other sites

Jan,

Thanks for your very nice reply. I'll try a couple of times again. I'll try engaging autopilot with V/S and HDG mode on and then take it from there. I like your approach, in fact yesterday I did the whole route  (LIMF-LFMT) using LNAV but V/S ("manual VNAV") and it was much more fun :)

I get your point about the lack of feedback on old system. However, I was hoping that maybe on some internal console one could see what's stopping it from engaing: not that in real life pilots have access to that, but in the simulator, isn't there some kind of behind-the-curtains debugging console?

Have a nice one,

Agustín

Share this post


Link to post
Share on other sites

Well, I just tried again and something really strange happens: after ascension manually, using V/S but LNAV enable, when I reached FL060 and holding altitude with the ALT button, if I click on VNAV, it turns on. However, as soon as I start increasing the ALT wheel from 6000 to the desired cruise altitude (28000 in my case). Flight route looks normal, ascension was done at a standard rate (12 degree angle).

Yesterday I even tried doing exactly the same with Zibo's modified 738, same flight route, engaging VNAV and LNAV at same altitude, etc., and it did work fine. I'm really puzzled.

Maybe the following screenshots help :)

Here, everything's stable and nice, even VNAV is engaged:

image.png.1ebc82931b276def92951a6fafd76646.png

Flight plan looks fine too:

image.png.86c462221b15dd551c50020a657f9894.png

However, after just turning the wheel one click, to say 6500, the following happens. After that, I can click VNAV as many times as I want but it wont engage again.

image.png.9f13e9aeca48d5e9db978a687c3a50f2.png

Once again, thanks to anyone who can help me troubleshoot this :)

Cheers from the summery sunny south,

Agustín

Share this post


Link to post
Share on other sites

Agustin,

I need to see the FMA anncouncements in the EADI (the green/white writing on your artificial horizon) to see what is going on.

The light in the VNAV button does not say anything about the status of the autopilot. The light only says "this mode can be disengaged if you click the button".

If you are in VNAV PTH at a certain altitude and then dial the altitude away (like you did), the mode changed to VNAV ALT. This is not really a VNAV mode, as the autopilot is maintaining the last altitude it held as a safety feature. If you turn the altitude knob DOWN (like you did) while the FMC (and VNAV logic) wants to climb, it won´t engage.

I am not sure how elaborate the VNAV logic on the Zibo mod is, I don´t have it or fly it.

Jan

Edited by Litjan
  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks Jan, I'll keep on trying, I must be missing something :(

Btw, I'm watching your tutorial videos on YouTube, they are great, couldn't be clearer, thank you very much for those!

Best,

Agustín

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×