Jump to content
dtiganas

Take Command SAAB340 GPS error

Recommended Posts

Hi, I was wondering if anyone experienced the same error and if there are any solutions.

Everytime I am trying to start the GPS on SAAB 340, I got the Gizmo console with the error:  257.997: Run(xp): G530_main: [string "JGX.2.G530.00.lua.ra1"]:1049: attempt to perform arithmetic on local 'buildPosEnd' (a nil value) . The GPS is dark and completely unresponsive. The same goes for both passenger and cargo variants. Of course,  I already tried:

- disabling all plugins

- re-installing the aircraft

- re-installing Gizmo plugin

- uninstalling all other Gizmo dependent airplanes (Ixeg 733) and installing only SAAB 340

- perform a clean install of X-plane 11 and SAAB 340 only.

it's quite clear that it's becoming quite frustrating that I can't simply get it working.

I attached log.txt and gizmolog.txt with all plugins re-enabled. I am running the latest X-plane 11.26 Steam version and SAAB 340 1.51. Thank you for any replies!

GizmoLog.txt

Log.txt

Share this post


Link to post
Share on other sites

Problem solved. The default earth_nav.dat file was corrupted. I checked the integrity of the files and this restored the default data files. Now it works fine. Thanks Cameron for excellent support!

Share this post


Link to post
Share on other sites
Problem solved. The default earth_nav.dat file was corrupted. I checked the integrity of the files and this restored the default data files. Now it works fine. Thanks Cameron for excellent support!


No problem, and happy to help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×