Jump to content
iGavB

Beech Duchess X-Plane 11

Recommended Posts

Hi team,

I just took up X-Aviations offer for the DC-3 and the Duchess. I am an X-Plane 11 user.

I see from other forum threads that you do intend to get the DC-3 fully compatible with XP11, which is great news. However, is your intent the same for the Duchess? I feel you may get asked this question a lot this weekend due to people getting it with their DC-3 purchase due to the promo, so figured it would be great to get in early with an answer on this.

Thank you,

Gav

Share this post


Link to post
Share on other sites

The Duchess is extremely simple.  No plug ins.  I'll take a look at it in XP11 and make sure nothing needs to be done.  If it does, I'll do a free compatibility update.  As for a complete XP11 upgrade, with PBR textures, I do plan on doing that, but it will likely be after the Saab and DC3 (which are being worked on now.)

  • Upvote 1

Share this post


Link to post
Share on other sites
6 minutes ago, Goran_M said:

The Duchess is extremely simple.  No plug ins.  I'll take a look at it in XP11 and make sure nothing needs to be done.  If it does, I'll do a free compatibility update.  As for a complete XP11 upgrade, with PBR textures, I do plan on doing that, but it will likely be after the Saab and DC3 (which are being worked on now.)

Thank you for the response. When I tried it yesterday, none of the avionics work / turn on. So I assume this is the only major issue I have seen, is there a way to work around that in the mean time?

Share this post


Link to post
Share on other sites

Just confirming you're turning on the Avionics by first turning on the Master Avionics switch in the upper right section of the panel.  (2 switches)

Share this post


Link to post
Share on other sites
31 minutes ago, Goran_M said:

Just confirming you're turning on the Avionics by first turning on the Master Avionics switch in the upper right section of the panel.  (2 switches)

Ok that ones on me ;) - I tried yesterday and those buttons didnt appear to be clickable, however, moving the mouse around a bit and there is indeed a click spot there for them. So yeah, thats all cool. Thanks :) 

Share this post


Link to post
Share on other sites

I have tried Duchess and just a couple of things:

 

1. Com 2 is linked with com 1(in gns 430). Is this intended?

 

2. Panel is generally too dark. Can't recognize numbers on com/nav

 

Well it's working well overall.

Share this post


Link to post
Share on other sites
10 minutes ago, mjjcyc said:

I have tried Duchess and just a couple of things:

 

1. Com 2 is linked with com 1(in gns 430). Is this intended?

 

2. Panel is generally too dark. Can't recognize numbers on com/nav

 

Well it's working well overall.

The Duchess was originally made for XP9, back in 2009.  It was updated, with the required updates, to make it somewhat compatible with XP10.  I would like to make a full XP11 upgrade, but I have no idea if or when that will be done.  X Planes rendering engine has changed, so textures will likely not look right in XP11.

Share this post


Link to post
Share on other sites

Hi, I am looking in to a Duchess add-on for XP11 to get familiar with procedures for flying in the real aircraft. I am quite interested in practicing engine failures.

Share this post


Link to post
Share on other sites

This is another vote for an xplane 11 port for the duchess please.  It is very popular MEP training aircraft in the UK. Thank you.

Share this post


Link to post
Share on other sites

Yesterday I bought the Beech Duchess. Unfortunally it is impossible to install it. After to start the setup-file, he ask to put a value !? But there is no field for put any value. At this point he dont allow to continue with the installation. My configuration: Windows 10 PRO, X-Plane 11.30, Dell XPS15-9550, Intel I7, 16 GB Memory, 1 TB HDD. Any idea, what´s to do ?

Share this post


Link to post
Share on other sites
3 hours ago, tyskelk said:

Yesterday I bought the Beech Duchess. Unfortunally it is impossible to install it. After to start the setup-file, he ask to put a value !? But there is no field for put any value. At this point he dont allow to continue with the installation. My configuration: Windows 10 PRO, X-Plane 11.30, Dell XPS15-9550, Intel I7, 16 GB Memory, 1 TB HDD. Any idea, what´s to do ?

Check your windows scaling and make sure it is set to 100%

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×