Jump to content

Aileron PCU Yellow Symbol on Flight Control Page & PCU Failure Not Resetting Properly


Wordpress
 Share

Recommended Posts

When I pulled up the flight controls synoptics page, I noticed a yellow symbol on my right aileron. No failures at this point were turned on. As suggested in another post, hydraulics were on and cycled, aileron disconnect handle was pulled and then stowed. My ailerons worked just fine and I had no CAS messages.

1549503698_PCU1.thumb.png.972537193333acda349c55dd6536c9eb.png

I then decided to set failures for left and right aileron PCU jams and tried to reset them to see if maybe that would reset the fault. After resetting the failures however, this only gave me my aileron indications back, but now both sides had the same yellow symbol and the "AILERON PCU" amber CAS message appeared.

425185847_PCU2.thumb.png.2521f5cacfed6dedcca9185ff5b9a08d.png

To be clear, the ailerons work just fine.

Edited by Wordpress
Link to comment
Share on other sites

That’s interesting. Was seen once in testing, but was unable to replicate despite many attempts. If you get it again, steps to reproduce (if you can remember) would be helpful to try and diagnose.

And to be clear, to fix you shutdown the Challenger avionics and power, or reloaded via X-Plane? 

Link to comment
Share on other sites

16 minutes ago, Graeme_77 said:

That’s interesting. Was seen once in testing, but was unable to replicate despite many attempts. If you get it again, steps to reproduce (if you can remember) would be helpful to try and diagnose.

And to be clear, to fix you shutdown the Challenger avionics and power, or reloaded via X-Plane? 

If it happens again, I'll try my best to give steps to reproduce, but I'm honestly not sure how I did this. The only way I can reproduce this is to manually set a PCU jam failure and reset that failure through the failure menu.

I restarted X-Plane and that removed the CAS message associated with the failure menu, but not the indications on the synoptics page. To remove the entirety of the failure (CAS and amber synoptics), I had to shut down the aircraft fully, removing AC and DC power. Once I powered on the aircraft again, I had normal indications on the flight controls synoptics page.

Edited by Wordpress
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...