Jump to content

XP-12 SR-22 Beta install & activation issues


IronCroptop
 Share

Recommended Posts

Good morning. 

I downloaded the SR-22 G1000 Beta for X-Plane 12 from my X-Aviation account last night and attempted to install it. 

My first attempt failed after the installer had downloaded the core files and was attempting to unzip the package. It reported that the destination folder (in my case "D:/Gaming/X-Plane 12/Aircraft/X-Aviation") didn't exist or was not writable.

The Airplane directory in my X-Plane 12 has correct permissions (and other aircraft have installed without issue). So I manually created the "X-Aviation" directory and tried again.

This time, the installer was able to finish the install. So I fired up X-Plane and attempted to finish activating the aircraft so I could take it for a short test flight.

When I load the SR22 I get two errors. One reporting a missing file (".../TorqueSim SR22TN/objects/EFFECTS/SR22_IVS_IN.obj") and one reporting an issue with the sound bank (".../TorqueSim SR22TN/fmod/SR22TN.snd  sim/flightmodel/failures/prop_ice"). 

Error1.jpg.0eba79f7861edd2b8adccc53049623b3.jpgError2.jpg.13f15fc17e1d07aff9ae0f4d33a8c7d2.jpg

Soldiering on, I dismissed these errors and attempted to activate my license but was met with the final error (which I concede is a Gizmo error):

Error3.thumb.jpg.fdf398bc57d124fcea0dfaaca5255f7d.jpg

In case the red text gets munged by the jpg compression, it reads:
"251 .580 http API call_back: function handle:: 6: [string "core/utils_api.lua.gfys"]:113: stat(x) failed: (D:/Gaming/X-Plane 12/X-Aviation)"

I've tried deleting the install and re-installing to no avail. Any suggestions on additional steps to try would be appreciated.

Edited by IronCroptop
  • Like 1
Link to comment
Share on other sites

  • IronCroptop changed the title to XP-12 SR-22 Beta install & activation issues
3 hours ago, IronCroptop said:

When I load the SR22 I get two errors. One reporting a missing file (".../TorqueSim SR22TN/objects/EFFECTS/SR22_IVS_IN.obj") and one reporting an issue with the sound bank (".../TorqueSim SR22TN/fmod/SR22TN.snd  sim/flightmodel/failures/prop_ice"). 

Soldiering on, I dismissed these errors and attempted to activate my license but was met with the final error (which I concede is a Gizmo error):

In case the red text gets munged by the jpg compression, it reads:
"251 .580 http API call_back: function handle:: 6: [string "core/utils_api.lua.gfys"]:113: stat(x) failed: (D:/Gaming/X-Plane 12/X-Aviation)"

I've tried deleting the install and re-installing to no avail. Any suggestions on additional steps to try would be appreciated.

I think @Pils advice should get it sorted for activation.

The FMOD warnings are known (we haven't done the FMOD XP12 upgrade process yet).

Regarding the object missing, if it persists after activation, please file that bug. https://torques.im/bugs 

 

Link to comment
Share on other sites

2 hours ago, Cameron said:

A note to people here:

Do NOT drag files from X-Plane 11 to 12. Always do a fresh install from your installer if you want future updates to go correctly. This is a classic case of not using the installer to place the product in v12.

Uh... No it's not. I did NOT drag _anything_ from my X-Plane 11 install. I downloaded the Beta release and (attempted) to install it into my X-Plane 12 folder.

I'll cop to not having seen the "known issues" list on the Discord post (since I wasn't on Discord) but I refuse to be made an example of for something that I absolutely *didn't* do.

Link to comment
Share on other sites

1 hour ago, IronCroptop said:

Uh... No it's not. I did NOT drag _anything_ from my X-Plane 11 install. I downloaded the Beta release and (attempted) to install it into my X-Plane 12 folder.

I'll cop to not having seen the "known issues" list on the Discord post (since I wasn't on Discord) but I refuse to be made an example of for something that I absolutely *didn't* do.

Easy tiger.

Link to comment
Share on other sites

 

@IronCroptop,

The beta falls into the same equivalency to dragging files rather than having a full install from retail, hence the errors. It is intended to supplement a full retail install. My post stands. This is a public service announcement, not some weird thing to make an example out of you. Please lower the temper a few degrees.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...