Jump to content

Recommended Posts

Noticed recently that if I deactivate Skymaxx through the plugin admin menu the tick goes from the box and the weather reverts back to the default.  I do this sometimes as I find low visibility is depicted better in X-Plane than in SkyMaxx and never encountered and problems.  Recently for some reason, when I try to reactivate Skymaxx I cannot select the tick box and X-Plane shuts down. I have an i9 processor, 32gig RAM and 2070 Super graphics card so unlikely to be a resource problem.

I have removed Skymaxx and re-installed it but the problem remains.

Attached is the X-Plane log file which may shed some light on the problem.

Log.txt

Link to post
Share on other sites

Strange this one. X-plane only crashes when I try to turn Skymaxx back on. Nothing else causes any problem. Looking at the log text (most of which I do not understand), the last but one line states that 'SilverLining' deleted followed by the statement of application crash. Surely, must have some connection to Skymaxx?

Link to post
Share on other sites
On 6/6/2021 at 11:51 AM, Geoff Akehurst said:

Strange this one. X-plane only crashes when I try to turn Skymaxx back on. Nothing else causes any problem. Looking at the log text (most of which I do not understand), the last but one line states that 'SilverLining' deleted followed by the statement of application crash. Surely, must have some connection to Skymaxx?

X-Plane is very good about pointing the finger at any plugin at fault.

It's very possible that you're exhausting memory by re-activating and building the cache for SkyMaxx Pro when you are re-enabling at that phase of the simulation environment.

Of course, the software is not designed to be used in the way you're trying.

Link to post
Share on other sites

For what it's worth, I looked into this more deeply. I think what changed is that X-Plane no longer has a valid OpenGL context active at the point where our plugin is re-enabled in this case. So when we try to recreate our sky, clouds, etc. it crashes because OpenGL / Vulkan isn't in a state where you can operate on it yet.

It's more of a technical answer than you probably want, but the bottom line is: yes, it seems to be a new problem and it has nothing to do with your specific system.

For now, if you want to temporarily disable SkyMaxx Pro, I'd do so by using a plugin manager that moves the "SilverLining" plugin (that's us) before you start X-Plane, instead of enabling and disabling it on the fly.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...