Jump to content

No G5 options in X-Plane plugin menu


Recommended Posts

I have the latest release (PB5)  of the M20, but haven't flown the G5 in quite a while.  I have also got the Islander with the G5, and that has G5 options in the X-Plane plugins menu.

However, although the G5 gauges are in the Mooney, and they work just fine, there are no entries in the X-Plane menu, and I don't see the G5 plugin loaded either - which is strange.  In order to see a popup of the HSI, I have had to asign a keystroke.   Maybe I'm dreaming, but I'm sure I had a menu option in PB4.   As an experiment, I just re-installed PB5, but it looks the same.

Am I supposed to run my G5 installer again?  The G5 files seem to be in the M20 already.

 

Edited by diamonddriller
Link to post
Share on other sites

As I said, I thought about that, but didn't see why, because the G5 set up was already in place.  Anyway, I ran the installer - which immediately told me that it was installed!   Looking at the Mooney again in XP, nothing had changed.   I have already said that I have assigned a key combination to give the HSI popup - that took two seconds.

Reading about the .cfg file reminded me that I have never had to fiddle with that - either before I upgraded to PB5, and certainly not in the Sundowner G5 nor both the Islander G5 versions. 

Inspecting further, I saw that there is no g5.cfg file installed from the PB5 installer into the Mooney M20 G5 directory, nor anywhere else in the Mooney tree.   Reading the page you referred me to, indicates that G5 is now at 1.20.  That would presumably be the version that installs the plugin to X-Plane's menu.  The installer I had bought from you is v1.0, and appears not to have changed when I checked the download link in my account.   When running X-Plane, I can list the loaded plugins, of course, and the AFM G5 appears in the list with the Islander and Sundowner, but not with the M20.

So, obviously, the Mooney does not have the X-Plane menu yet, and I see that many of the plugin files' creation dates are earlier than in the latest planes.

As a reminder, I use an iMac, and Catalina.

It's no big deal, because my key combo gives me my HSI popup, if I need it, but I'm just surprised that the Mooney pack hasn't had an upgrade. 

Also, it seems silly to click on the HSI G5 and get the AI popup, when I can't imagine that getting the appropriate instrument up in 2D is difficult to accomplish........

Loooking at the weather in Texas, aren't you glad you are in FL?  :rolleyes:

 

Screenshot 2021-02-18 at 20.18.43.png

Screenshot 2021-02-18 at 20.16.48.png

Link to post
Share on other sites

Currently the G5 that ships with the manual installer is an older version compared to the Islander. You can copy the G5 from the Islander's plugin folder and replace the one in the M20 folder. With the 1.2 update (that ships with the Islander), the "acfConfig.cfg" file that was inside G5/settings, is now "g5.cfg" and lives in the base of the installed aircraft directory. Copying that file out of the M20's plugins/G5/settings folder would ensure you keep the same integration.

Link to post
Share on other sites

Thanks Coop.   I must admit, I'd thought about doing that, but held off until you or Cameron suggested it (just in case it might mess things up).  Thank you both for the service.   Of course, I would have always had the recourse of just installing again from the PB5 installer.

Have a great weekend - well, as much as you can in these crazy times.......

  • Like 1
Link to post
Share on other sites

Never assume anything is a piece of cake :huh:

I substituted the plugin for the newer version, and resited the .cfg file to the base directory.  Loaded up - and "Yippee" - had the menu in the X-Plane plugins menu - and it worked!  The G5 screens all sat where they should.  Looked promising!

However, the G5 screens were blank (as if they were off - the "glass" looked normal).  Undeterred, I had a look at the popups and they were off, too. So, I turned them on, and they both fired up.  Whether the HSI was properly slaved to the GPS, I can't remember but, unfortunately, the panel G5s remained blank, no matter how I tried to fiddle with the switches on them.  I moved the .cfg file around, renamed it to g5.cfg, and back again to no avail.  I think I tried all combinations, but gave up after a while.   Re-installing the PB5 got rid of the menu, of course, but somehow made the G5s power up inside the GNS530 screen!  Very odd.  There they were with the AI and HSI side by side......  It was getting very late, so I gave up.

Today, rather than re-installing (which lets Cameron's uninstaller work), I just totally deleted both the "M20 Collection" and the "G5 Aircraft Installer" directories, and replaced them from Apple's great Time Machine, so things were back to where they were before I started playing.  It all works again.

So, obviously, there is an alteration to be made, somewhere in a file, to let the panel G5s fire up in the M20.  If it's a simple edit, I'm happy to try.  For me, it gives me something else to do on a Saturday :D

 

Link to post
Share on other sites

Hi Coop.  No, it didn't work.  I know you have better things to do with your time, so I'm not stresed with this at all.  It's keeping me amused for a few minutes, while we are still locked down!   I still get the dark screens, and can only start up the G5s from a popup.

You can see what the file structure looks like. I just duplicated the G5 plane and called it G5 1.2, and experimented in that.  Or could that be the problem?   I deleted the settings directory, which had the old cfg file.

What is interesting to me is that, somehow, a new (slightly smaller) g5.cfg file gets created in the plane's root directory, and I'm attaching it here.

Screenshot 2021-02-25 at 11.23.26.png

Screenshot 2021-02-25 at 11.23.06.png

Screenshot 2021-02-25 at 11.20.37.png

g5.cfg

Link to post
Share on other sites

The g5.cfg should go into the aircraft root directory, not inside the G5 plugin (this is what we are switching to, so updating wouldn't have the same issues where the old config file could get wiped out. 

Try placing the g5.cfg file I provided where the automatic generated one is now located. That should hopefully get it working!

Link to post
Share on other sites

That did it!  Well done.  Your earlier instruction to put it into the G5 folder was the hang-up.  Funnily enough, I thought I'd tried putting the .cfg file into the root directory, and on reflection I had - but it was the earlier version, not your new and improved one :D

Nice of you to take the time to indulge this old f--t!

Take care.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...