Jump to content

Stutters caused by AntiAliasing


Recommended Posts

i experience this only in the TBM

  • No stutters: AA off (60fps)
  • No stutters: FXAA on (60fps)
  • medium stutters: 2 x SSAA+FXAA (50fps)
  • bad stutters: 4x SSAA (30 fps)

I only have a nvidia 1060GTX, so i don´t want to have 4xSSAA. But 2 x SSAA+FXAA worked really good in version 11.41. Does anybody have the same problem?

Video evidence:

 

Link to post
Share on other sites

Yes I have this Exact problem with XP Vulkan, I have an i7-8700k and 1080 Ti.   The stuttering is only with TBM 900.  It's very annoying and makes this product unusable to me.  Also still seeing the obligatory random crashes after all this time. It never gets solved.  I don't get random crashes with other aircraft.  Only TBM 900.  What's going on after so long?  It needs fixing.

Greazer.

Link to post
Share on other sites

Try this: in Nvidia control panel, 3d settings, set Max Frame Rate to around 35 frames per second. That's all the FPS you'll get but the stutters will be gone and it looks great. I have all my X-Plane settings at or near maxed out. GTX 1080, I9 processor, 32 gigs ram. Play around with the frames per second setting till you find what works for your system. Mine works great at 45 fps.

  • Like 1
Link to post
Share on other sites

Not a good solution. It's SSAA anti aliasing that is causing stutters with this aircraft only and there needs to be an official patch which addresses it.

Developers also need to focus on why their aircraft is causing crashes to desktop and handle the exception in the code and not let the sim crash.

No other aircraft has the random crashes to desktop like the TBM 900. 

Stop blaming all third parties and fix your code! 

Greazer.

  • Downvote 1
Link to post
Share on other sites

@Greaser, when you're ready to be reasonable, we'll help you.  Making demands will get you nowhere.  I've addressed the stuttering issue in other threads.  I've also mentioned to everyone to stop mentioning "This only happens with the TBM."  This statement is, literally, of no help to us.  I've tried to see this stuttering issue on my end, and I'm getting nothing like what you're stating.  ie. Unusable.  We've seen streamers who are flying it with no issue.  So I reiterate.  This issue seems like it's isolated to a specific type of setup.  Either with hardware or plugins.  And when you're willing to accept that, we can move forward.

 

  • Like 1
  • Upvote 3
Link to post
Share on other sites
8 hours ago, Greaser said:

Not a good solution. It's SSAA anti aliasing that is causing stutters with this aircraft only and there needs to be an official patch which addresses it.

Did you somehow get the impression the TBM takes over X-Plane's rendering engine and tells it how to do anti aliasing? Surely not, right?

8 hours ago, Greaser said:

Stop blaming all third parties and fix your code! 

Do you say the same thing to the third party plugins whose dirty code is getting exposed? Just curious since you seem to be a programming genius.

  • Like 1
  • Upvote 2
  • Downvote 2
Link to post
Share on other sites

@fehrster and @Greaser, I have no stuttering issues with the TBM when using 11.50 Vulkan.  Not so with 11.50 OpenGL unless I turn the graphics settings down a bit. Same for earlier versions of XP.  And the same with other 3rd party aircraft models as well.  This has nothing to do with the TBM expect perhaps there's a lot going on with the system modeling.  And you need to take that and other factors - plug-in's, etc. - into consideration when tuning your system.  

Link to post
Share on other sites

@fehrster Sarcasm aside I took the time to look at your log.txt to see if anything stood out.  Nothing in there struck me as a cause of your issue.  It is puzzling since my install has a good number of plug-in's, Orbx, Ortho and 3rd party airports yet it is smooth with the TBM.  And everything else for that matter.  So, looking outside of the basic install and the TBM are you at 1080, correct?   More than one monitor?  Other processes running?  I see you've been at this for a while so I'm guessing you know all the Nvidia "stuff" - max power preferred and high performance selected in the control panel.  Have you tried using a utility like HWiNFO64 to monitor the CPU and GPU while flying?  I'm looking to upgrade my Mobo and CPU shortly but I'm concerned about issues that some i9-xxxx users are reporting.  I hadn't considered AMD but it's in the mix now...

Link to post
Share on other sites

And again @mrogers0547....thank you! I can enjoy the plane now again!

Let´s pretend everything is fine, and please give a **** on my feedback! All problems on my side!

 

Last thing i have to state:

FFA320 - no stutters

FJS732 and 727 - no stutters

IXEG737 - no stutters

Bell 407 - no stutters

FF767 - no stutters

Zibo738 - no stutters

ini A306 - no stutters

AFL C172 - no stutters

Hotstart TBM 900 - guess what!

 

Edited by fehrster
Link to post
Share on other sites

There are so many possibilities, that it's almost impossible to determine what is causing it.  At the risk of sounding arrogant, not all add ons are created equally.  The TBM has very complex systems and code implementation, and it could be forcing the CPU to work that little bit extra than other add ons.

  • Like 1
Link to post
Share on other sites

I don´t think that it is arrogant. You and Toto have created IMO the best single prop and maybe the best x-plane addon - and i am looking forward to your next release.

On my system it feels like there´s no limit for the gpu (when flying with the TBM on Vulcan 11.50). With GPU-Z monitoring the performance, there was first the voltage limiting the GPU. With MSI Afterburner i gave more voltage, than the temperature was the limit. Next step bringing up the fan to 100%, than the general power was limiting. Then power up and the voltage was the limit. And so on and so forth. The stuttering was always the same - frames went up. I also get the highest FPS in the TBM. Maybe it´s coded too clean? CPU is bored at 40%.

And i don´t think that there is the magic solution for this - beside locking frames, which works wonderful. My intention was to find out, if there are other user experiencing the same thing, or if it is just on my side.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...