Jump to content
Sign in to follow this  
RobH

TerraMaxx & Vulkan.

Recommended Posts

OK so I got TerraMaxx a couple of hours ago. The problem I'm having is that it's just not working with X-Plane 11.50 B11 for me at least, as soon as I select what season I want and go to load it in then it just sits there with the loading new scenery message forever ( ok maybe not forever as that's a long time ) I let it sit like that for more than 15 minutes and nothing happens so I have to ctrl-alt-del and use task manager to quit X-Plane.

I did find a sort of work around which isn't ideal, if  I turn Vulkan off, load X-Plane using opengl, change the season and it loads the textures in around 20 seconds, then if I enable Vulkan and quit X-Plane then launch X-Plane again I have whatever season I set in opengl but with Vulkan enabled which is a royal pain as that means if I want to use another season I have to do all that again and of course the Auto option isn't an option if I use Vulkan as it just locks up at the loading season textures message.

This is an X-Plane install with no custom scenery or planes, no plugins other than TerraMaxx. I'm at a loss what to try next to get TerraMaxx working in Vulkan.

Anyone got any ideas ?

Edited by RobH

Share this post


Link to post
Share on other sites
58 minutes ago, RobH said:

I did find a sort of work around which isn't ideal, if  I turn Vulkan off, load X-Plane using opengl, change the season and it loads the textures in around 20 seconds, then if I enable Vulkan and quit X-Plane then launch X-Plane again I have whatever season I set in opengl

Thanks for that datapoint. @sundog ?

Share this post


Link to post
Share on other sites

When you load scenery for the first time under Vulkan, X-Plane undertakes a lengthy process to compile shaders for it. You end up taking that hit when you switch seasons, at least for the first time.

15 minutes sounds excessive however, and this sounds like it may be a bug in the X-Plane Vulkan beta. We are using X-Plane's API's for reloading scenery (XPLMReloadScenery) and my guess is that it doesn't work as expected under Vulkan. I'll file a bug report with Laminar about it.

For now, you should stick with OpenGL with TerraMaxx or use the workaround you identified.

Share this post


Link to post
Share on other sites

Ok thanks. I did end up just letting it sit for a while but 40 minutes passed and nothing happened. I will for now just switch from vulkan to opengl and back again.

Share this post


Link to post
Share on other sites

It definitely looks like a bug in X-Plane 11.50b13, possibly related to the Vulkan memory manager. I filed the details with Laminar.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...