Jump to content
neilw

Feedback on PB5 Mooneys with XP 11.50b11

Recommended Posts

Loaded the new PB5 Collection today in a fresh install of XP 11.50b11.

  • Only plugin: newest X-Camera for beta.
  • Only Custom Scenery; zOrtho4XP_Arizona. 
  • Graphics settings: Vis Effx = Max; Text = High; AntiAli = 2xssa+FXAA; New AF = off; Objects = High; Shadows = Off
  • Mac Mojave with Radeon Pro 580 8 GB
  • Flying out of Tucson KTUS and the area

As a benchmark, the Laminar Cirrus Jet runs butter smooth. Sharp detail, no stuttering, great frame rates both cockpit and exterior.

Initial Testing:

  • Ovation II did reasonably well. Inside the cockpit about 20 fps and pretty smooth. Exterior it was giving about 30-40 fps with no micro-stuttering, sharp detail, etc. Fairly pleased with the results, although the cockpit views were quite a bit less fps than the Cirrus with the G1000's. EDIT: 2nd test about the same. In the air, the cockpit was about 21 fps while the exterior views were around 32-39 averaging about 35 and no stuttering (smooth). On final, around 20 fps. Noticeably better than the O3 or Acclaim.
  • The Acclaim struggled. Inside the cockpit I was only getting about 17-22 fps with a lot of variance. On final approach I was getting 17-24 fps with a lot of stuttering. Exterior views on the runway were about 25-27 fps. In the air, while I was getting about 30-35 fps, there was a lot of stuttering making it unpleasant to fly. Not sure why the Acclaim exterior is so different than the O-2, but in a few separate tests, it was quite bad as compared to the O-2. Frame rate was nice but just terrible stuttering. 

Just providing my initial feedback from today's testing. Will keep trying with variations to the graphics settings, etc. But as stated above, the benchmark Cirrus Jet is smooth as butter with high frame rates (40+) in the same conditions, so that's what I'm using for comparison. 

Edited by neilw

Share this post


Link to post
Share on other sites

Just tested the Ovation III and didn't get very good results. Same scenario as before.

  • Cockpit on the ground, around 19 fps
  • Exterior on the runway, around 26-30 fps
  • In the air cockpit, around 19 fps but blurry ground textures
  • Outside in the air, around 30 fps but micro-stuttering
  • On final, around 17 fps.

Not as flyable as the O2.

As a benchmark, the LR Cirrus Jet in same conditions:

  • Runway cockpit (w/G1000's): 28 fps
  • Runway exterior: 38-59 fps
  • In the air cockpit: 30fps
  • Air exterior: 44
  • Final approach: 29 fps
  • All smooth, no stuttering or texture reductions (fuzzy)
Edited by neilw

Share this post


Link to post
Share on other sites
On 6/27/2020 at 1:24 PM, neilw said:

Just tested the Ovation III and didn't get very good results. Same scenario as before.

  • Cockpit on the ground, around 19 fps
  • Exterior on the runway, around 26-30 fps
  • In the air cockpit, around 19 fps but blurry ground textures
  • Outside in the air, around 30 fps but micro-stuttering
  • On final, around 17 fps.

Not as flyable as the O2.

As a benchmark, the LR Cirrus Jet in same conditions:

  • Runway cockpit (w/G1000's): 28 fps
  • Runway exterior: 38-59 fps
  • In the air cockpit: 30fps
  • Air exterior: 44
  • Final approach: 29 fps
  • All smooth, no stuttering or texture reductions (fuzzy)

The LR G1000 uses quite a bit of CPU time if you are CPU limited (which it sounds like you might be). With high objects set, X-Plane can really start to struggle. We will have some further tweaks coming, but our plugin uses a very minimal quantity of CPU resources besides the default LR G1000. It could potentially be a VRAM usage issue, we have 2K texture packs available, linked at the bottom of the page here: https://afmsim.com/m20-liveries/

Share this post


Link to post
Share on other sites

@neilw I think @Coop may be right.  On my mid-range (sounds better than old) rig I'm getting over 50FPS with Ortho and custom airports.  You haven't provided any detail about your system but I think you may have a setting or two a bit too high.  Especially Visual Effects.  I find the Mooney collection pretty well optimized.  Of course, as @Coop advised the G1000 can stress a cpu.  Mine seems to handle it fine but there is a difference when using steam gauges. 

Share this post


Link to post
Share on other sites

What I was reporting on was performance in the new beta 11.50b11 with Metal. For clarification, I don't have issues in XP 11.41, so what I am reporting is the change when using the same Mooneys in the beta versus 11.41. 

In 11.41 the O2 and Acclaim have low fps with my iMac (20-30 fps) but run very smoothly with reasonably excellent graphics inside and exterior views. That's with the Graphics Settings fairly high in 11.41.

  • Visual Effects = HDR
  • Texture = Maximum (not Max No Compr)
  • AA = 2x SSAA+FXAA
  • Objects = High
  • Reflec = Min
  • Shadows = on

So the Acclaim with Synthetic Vision on, etc. is very acceptable, even with Orbx True earth HD, complex airports, etc. The problem arises when going to the 11.50b11 where the fps goes up nicely, but with the O3 and Acclaim there is significant micro-stuttering  and stuttering inside and exterior views (where the G1000 shouldn't affect things). 

As an example, I just flew LOWI (stock) in both 11.41 and 11.50b11 in the Acclaim with the same graphics settings. In b11 the fps was better, but I still had stuttering in flight both interior and exterior views. 

This, of course, can possibly be an issue with beta 11 (as reported on the XP beta threads), and supposedly the flawed beta 12 (OpenGL issue, and being re-released soon) is better. But thought I'd report this for your development purposes for 11.50 since I don't get any of these issues with the stock Cirrus SF50 with G1000. Get significantly higher fps and no stuttering whatsoever with the SF50. Different planes, obviously, but just reporting the testing for informational purposes only. In beta 11, the O3 and Acclaim are not pleasant to fly, whereas in 11.41 they are very enjoyable, especially for a real-world previous Mooney owner. Just my 2¢. Maybe beta 12 will cure these issues.

Late 2017 27" iMac 40 GB with Radeon Pro 580 8 GB. 

Share this post


Link to post
Share on other sites

No issues with either b11 or b12 (for the short time b12 existed).  I know absolutely squat about macs.  I do run at 1080x1920 so that may be a factor.  But then this begins to exceed my paygrade :lol:.

Share this post


Link to post
Share on other sites

Just installed into b11 from my 11.41: 1) FlyWithLua and 2) 3jFPS-Wizard. That did cut back my fps on the Acclaim (down to about 20-24 fps), but it did smooth out the stuttering. That does make the Acclaim flyable again for me in 10.50b11. Hopefully b11 will resolve stuttering a bit more since it's a common complaint on the XP 10.50 beta. We'll soon see.

5 minutes ago, oldflyguy said:

No issues with either b11 or b12 (for the short time b12 existed).  I know absolutely squat about macs.  I do run at 1080x1920 so that may be a factor.  But then this begins to exceed my paygrade :lol:.

All iMac 27's are 5k monitors, so, yes, that does make a big diff in performance. Fabulous pic quality but it does take some hp to get it. (I do video and photo production, so am used to very high resolution work.) Many had high hopes that with 10.50 going to Metal/Vulkan it would really help things. So far it isn't there yet, but it is still a beta, so hope springs eternal! 

Share this post


Link to post
Share on other sites
18 hours ago, Coop said:

 It could potentially be a VRAM usage issue, we have 2K texture packs available, linked at the bottom of the page here: https://afmsim.com/m20-liveries/

FYI @Coop, I installed the 2k skins on the Acclaim in XP 11.41 and it did smooth things out even better than it was before and increased fps. Plus on a 5k monitor, it is still very sharp. Hard to discern a real difference, so the trade off is acceptable. Thanks for the idea!

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, neilw said:

FYI @Coop, I installed the 2k skins on the Acclaim in XP 11.41 and it did smooth things out even better than it was before and increased fps. Plus on a 5k monitor, it is still very sharp. Hard to discern a real difference, so the trade off is acceptable. Thanks for the idea!

Perfect!

Share this post


Link to post
Share on other sites

As an update and FYI, I just updated XP to beta 13. Ovation II still smooth as butter with 4k textures and decent fps. However, the Acclaim w/2k still has serious stuttering. Interestingly, the fps for the Acclaim has improved (25-40 fps) but the stuttering is still there, both inside and exterior views. Had hoped that the newest beta would resolve this. 

Again, the O2 is great as is the stock Cirrus SF50 and the G2 SF50 (getting 70 fps). 

Just keeping you updated on what I'm seeing. 

Edited by neilw
  • Like 1

Share this post


Link to post
Share on other sites

Latest update. Seems like it is an issue with Metal (Mac issue) with the betas. In the past, I found that Metal was better than OpenGL, but in b13 it looks like OpenGL (which they had worked on) reduces the micro-stuttering. Keeping in mind that Metal works VERY well in modern major video, photo and publishing apps and adds tremendous performance advantages on Macs with appropriate gpu's), it looks like Laminar still has not got it right for 11.50.

By using OpenGL, VSync, less than HD effects, I'm now getting a fairly smooth Acclaim with reasonable fps (30-35) and decent clarity. This is with the 2k textures fro the Acclaim. Hopefully Laminar can resolve the Metal issue in future betas.

Here are my graphics settings for anyone with a Mac experiencing similar issues. 

 

Screen Shot 2020-07-02 at 3.06.22 PM.jpg

Share this post


Link to post
Share on other sites

Just an FYI,

There is a known issue Laminar cannot solve (up to Apple) where stutters will happen when orthoimagery is in use while using Metal. They have significantly reduced it since early developer beta's, but it's about as good as it's going to get for now.

Share this post


Link to post
Share on other sites

Thanks Cameron for pointing me to this forum. Great product you guys have made available.

I am testing this M20 update on the Ovation II with X-Plane 11.50 b16  and noticed the following issues:

  • the pop-up "settings" windows to configure weight load, options, etc open up but have no content, are completely blank
  • The passengers are always on, even when in x-plane's  "w" view mode, pretty much you are looking out from inside the pilot's head. 
  • some cockpit components do not visually turn "on" such as transponder / bendix / chronograph 
  • many of the "afm/m20r/" cockpit dataref commands such as for nav lights / beacon / strobe, etc do not work
  • on external view, looking at the aircraft, if you turn off the engine (i.e. cut off gas, turn key to off position, etc), sound still continues as if engine was still running but prop stops.

Has anyone noticed this with b16?

Edited by GAPlanesOnly

Share this post


Link to post
Share on other sites
3 hours ago, GAPlanesOnly said:

Thanks Cameron for pointing me to this forum. Great product you guys have made available.

I am testing this M20 update on the Ovation II with X-Plane 11.50 b16  and noticed the following issues:

  • the pop-up "settings" windows to configure weight load, options, etc open up but have no content, are completely blank
  • The passengers are always on, even when in x-plane's  "w" view mode, pretty much you are looking out from inside the pilot's head. 
  • some cockpit components do not visually turn "on" such as transponder / bendix / chronograph 
  • many of the "afm/m20r/" cockpit dataref commands such as for nav lights / beacon / strobe, etc do not work
  • on external view, looking at the aircraft, if you turn off the engine (i.e. cut off gas, turn key to off position, etc), sound still continues as if engine was still running but prop stops.

Has anyone noticed this with b16?

This sounds like the aircraft isn't being activated by Gizmo. Perhaps are you running an Gizmo beta which expired? 

Can you upload your log.txt after loading the M20 - that will tell me what is going on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...