Jump to content

Issues with 11.50b10


Recommended Posts

For me it is not that bad, the plane is OK on manual flying, the RNAV approaches are working fine.

The plane is a bit picky on the trims, but with some 'fights' it is OK

Try with and without the Experimental Flight model, see if it makes any differences, I saw some messages where there were complaints, even if, I think, the plane should be flown with the Experimental model on. I always have it ON and it is OK

How you lost the control, on autopilot, cruising, preparing to land?

Link to comment
Share on other sites

Just something to be aware, it seems that even for the real TBM, if the winds get strong, the AP disconnects sometimes!

It happened to me a few times, once I crashed, because I was too confident that the plane is on AP and was not near it....

The other time I got the control and reactivated the AP


Link to comment
Share on other sites

As I wrote in some other threads, this COVID lockdown I flown the TBM around the world in X-Plane.

I had a few very strange happenings.... :)

I stopped in Miami, Opa Locka - KOPF, Steveo1Kinevo's place and I thought to make a quick stop in Bahamas...

Arriving at MYNN, I got some electrical failure, the engine stopped, luckily I was on the final, I thought that I can glide to the runway.... Suddenly the engine restarted and landed OK....:rolleyes:

I doubt that they modeled the Bermuda Triangle in X-Plane or TBM.... But it was a really strange happening...

I only realized that Bahamas is part of Bermudas later....

Link to comment
Share on other sites

is my observation correct, that the TBM in B10 with EFM enabled, does need a lot more pulling on the yoke to rotate? I have sometimes the feeling in some situations that there isn't enough control authority regarding the stabilizer.

Also i noticed that with recent updates the TBM became much more sensitive on the yoke. Don't know it it's the X-Plane Beta Update or the TBM update.
Maybe it's because XP in Version 11.5 is running on my machine very smooth and with higher Frames. About 40 all the Time. 


And wasn't there in the beginning an option regarding the TBM that would make the control surfaces "stiffer" with higher speed? Or do i mix things up?    


All in all the TBM is still great joy to fly in XP 11.50
Done about 12 hours of flying in the last days and not a single CTD and smooth as Hell

Edited by flieger28
Link to comment
Share on other sites

My question is: Before putting AP and YD, after taking off, you have to fly Manual to reach the waypoint heading?


Marius_B, the problem I had with TBM was not of Vulkan 11.50 b10; the problem was that I had  version 1.12 of TBM, that I had downloaded, but not executed, so I was running with version1.11.

Link to comment
Share on other sites

I tried a few add-on planes, they all seem to not have any G1000 issues

I downloaded yesterday the HoldMyBeer SR22T freeware airplane (it is amazing by the way ;)) and it has no issues with the G1000, even if it is also 'tampered'

The Kodiak is fine also

Attached the SR22T approach, same approach like the one having issues in our TBM

X-Plane Screenshot 2020.06.13 -

Edited by Marius_B
Link to comment
Share on other sites


Same problem here with the ILS.

If it helps debugging... in my case for instance, KOPF rwy 27R shows some vertical signal but not lateral, you can see the glideslope sign but not the 'middle bar' for the localizer. You can also see the distance to the localizer.



But rwy 09L in the same airport, shows nothing. No distance, no 'middle bar' and no glideslope. 


As other commented, I tried in same airport with other planes using G1000 and works OK.

Other than that, a fantastic plane. Thank you.


Link to comment
Share on other sites

9 hours ago, Felipe Mendes said:

For who are experiencing this ILS bug, just go to navigraph.com, "manual install" section, and download the 11.40 database, instead 11.50. The ILS approach will work fine.

Hope it helps.



What about the ones we don't use Navigraph?

Link to comment
Share on other sites

  • 3 months later...
  • 2 weeks later...

I have a similar issue with my new  StartHot TBM 900 and Xplane 11.50 as follows:

When I enter a Localiser frequency into Nav1 ie 110.9 MHz for 26L EGKK and select Loc1 on the CDI the entry goes green but the code for the Localiser is never shown as it should be, and the green line never shows any cross track information. Although the Nav 2 shows the correct VOR code when the corresponding Frequency is entered ie 114.00 Mhz for the UK Midhurst VOR shows Mid correctly and navigation data is correct. I have tried lots of ways to correct this even totally deleting the TBM 900 and reloading but nothing I have tried works so far. I can confirm that the G1000 in the default C172 Skyhawk works fine I understand that RNAV approach can be used instead but it would be nice to have this issue fixed. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...