Jump to content
Coop

Beta 11.50 SVS Compatibility

Recommended Posts

We have made the necessary changes to Synthetic Vision so it now works in X-Plane 11.50 with Vulkan/Metal!

Before we push out the update in the release version, we are making the plugin update available as a patch file for your existing file to test out. Let us know if it works, or especially, if it doesn't. 

No other significant changes are in 1.1.1 except for SVS compatibility.

Download patch file HERE.

 

To Install:

  1. Delete the existing Pocket Rocket/plugins folder
  2. Add the new plugins folder from the zip at the same location of the old plugins folder (X-Plane 11/Aircraft/X-Aviation/Pocket Rocket/plugins)
  3. Replace the Version.txt file with the new version in the zip
  • Like 2

Share this post


Link to post
Share on other sites

Greetings again Coop;

I found your posting late last night so I haven't had time yet to put her through all her paces. After installing the patch I only took a quick initial run. I started the flight at my test airport KLVK with the default C172 and was getting my usual 40+ FPS and stable. Switched A/C to Pocket Rocket. Slow A/C load. When she appeared, without a crash, the engine was running and SVS was functioning. That's the good news; unfortunately my FPS dropped to between 18 - 20. My last recollection of PR performance was 27 - 30 FPS. I tried engaging/disengaging SVS which resulted in no change in FPS status. After a quick perusal around the cockpit I shut down the sim so I could give you a pristeen initial load/startup log for you to chew on.

Today I plan get things cleaned up, tuned on my end and turn down my settings since the X-Plane log shows heap usage/heap budget issues with PR. Once my side of the street is cleaned I'll try different scenarios/system tests and provide you with the logs and reports .

My usual Beta test method is to slap it, steal it's lunch money, give it a wedgie, and send it home crying to Mommy but I'm so happy to have the PR back in the hanger I think I may take a tactical analytical approach. More to follow.

Film @ eleven...

Roger

Log 1.txt

  • Like 1

Share this post


Link to post
Share on other sites

Disclaimer: For those of you that don't read the full Log.txt and just scoot to the juicy parts I'm testing with Win 10 2004 Build 19041 Beta and X-Plane 11.50b9 Beta.  Any/All/None of the issues mentioned could be related to running Beta software not related to Torquesim PR (Pocket Rocket). Until both Betas are stable, finalized, and released can you be assured of consistent/reliable test results and performance.

And now for something completely different.

Setup 
Cleared Shader Cache
Scaled Back Settings from Mid-High to Mid.
Data Output On – Frame Rate
Initiate Sim 
Calibrate Controls
Select PR @ KLVK Rwy 25R
Start Flight

Load time slow due to shader cache rebuilding. Once A/C appears it freezes for a few seconds for what I can only guess is the plugins initiating. Once running Frame Rates and CPU/GPU Usage climbs, systems come on line, and everything spools up. Stop right here and celebrate; no crashes and the SVS is working. Good job guys!

Spoiler Alert: The Exhaust Effect requires adjustment. It's obscuring the lower quadrant of the windscreen all the way past the leading edge of the wing disrupting both forward and side view. No, it's not the dreaded blurries, I checked.

I forgot how much fun this thing is to fly even though I'm a RW Citabria KCAB and SF 260 driver. You only need about a third of the resources available and anything more will put you behind the A/C. The trick is to always stay ahead of A/C for proper operations; the further the better.

My CPU/GPU Usage is about twice what is for everything else in my hanger and Frame Rate about half with no stutters or blurries. Heavy lifting. Your results may vary.

Ran a standard pattern and set up on final. Here's where I remind everyone that having brakes is a good thing. As the saying goes, “Old Brakes Are Hard To Habit”. Throttle to beta, flare, settle, touchdown, reverse prop, brakes? Brakes? BRAKES?? OS! Out of reverse and into Beta and it's off like rocket. Pull the Fuel Conditioner back to idle and the prop to feather driving the ITT Temp to skyrocket. Rolling, rolling, rolling. Go to fuel cut off. Rolling, rolling, rolling. Pull the Parking Brake. Stop. I had crossed the runway threshold at minimums, ate up 5250 ft. of runway, careened off the last possible intersection at the end of the runway and rolled a third of the way back down the taxiway. Just think how much time I saved on the Hobbs. I guess that makes up for what wear/tear I put on the tires. Lucky I wasn't in the tailwheel version because the lateral forces would have been fatal.

Added Gear & Brakes to my Data Output and confirmed my suspicions. When you put pressure on the brakes the number climbs accordingly until you hit the stops and the number immediately drops to zero. I fixed all Failures via the X-Plane GUI and tried again. Same results. I switched A/C to Default C172 and brakes tested 100%. Back to PR, no brakes. Now you can call me a coward but I do really prefer to have working brakes.


Restarted the sim and flew several more pattern circuits with same results but I did get my stopping distance down. Friendly reminder; always memorize your emergency checklist so you'll have something to think about while you're fumbling around to find your hard/electronic copy.

Other than that Mrs. Lincoln what did you think of the play?

To sum it up, other than the aforementioned issues which I know will get corrected, I want to thank all those involved for the hard work, blood, sweat & tears they took to make a really great A/C. 

Roger

Log 2.txt

Log 3.txt

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...