Jump to content

Recommended Posts


I bought the islanders. Now I wanted to start but no button worked. Properly installed and activated in my X-Aviation account. You only hear a muffled clicking sound when I activate the battery switch. No switch works. I can only move the thrust levers, that's it. And besides, the load manager doesn't work for me either. If I point to the left side with the mouse, no window opens with this menu. Urgently ask for help

Link to post
Share on other sites

Probably one of your plugins are incompatible and interrupting the system simulation. Try disabling and enabling them one by one to check which one. A few others experienced same thing by using an older version of a landing rate plugin. That is one of the usual suspects. Try disabling that one first. If that is the case, download the newer compatible version of that. If disabling plugins don't solve the issue for you, post your log.txt so devs can check.

Edited by 0zz
  • Like 1
Link to post
Share on other sites
3 hours ago, gigabenga said:

Thats it XGS plugin not worked. Now fine the Aircraft worked Perfect thanks for all help this Aircraft is absolutly fantastico

Glad it is working now :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...