Jump to content
Ben Russell

Gizmo64 v20.05.26.0354 beta

Recommended Posts

Gizmo64 v20.04.15.0230 beta is now available.

Compatible with X-Plane 11+. Does not work with X-Plane 10.

Mac and Windows only. No Linux support.

 

Please make backup copy of your original Gizmo64.plugin folder before installing.

Expect bugs.

 

1. Download the zip file from the URL below.

2. Make a backup of X-Plane/resources/plugins/Gizmo64.plugin

3. Copy the zip file you downloaded into X-Plane/resources/plugins/

4. Extract the zip file.

5. Start X-Plane.

 

New Beta Out. Go Here.

 

Supports new GUI and Widget styles.

Better Vulkan support.

No longer creates GizmoLog.txt files, all data is merged back into Log.txt for easier support.

Supports HTTPS.

Many other internal optimizations and bug fixes.

 

Look forward to your feedback.

  • Like 6
  • Upvote 2

Share this post


Link to post
Share on other sites

Thanks for this update,

I couldn't enter my email in the login box, or rather the @ character, I had to use copy and paste, but it works.
 

Quote

:00:00.000 G64: Gizmo64 Script Engine v20.04.15.0230 Windows
0:00:00.000 G64:      built: Apr 15 2020, 02:21:01
0:00:00.000 G64: Digital Signature Verified.
0:00:00.000 G64: GizmoImGUIManager::setupImGuiFonts()
Loaded: G:\X-Plane 11/Resources/plugins/Gizmo64.plugin/win_x64/Gizmo64.plugin.xpl (gizmo.x-plugins.com).

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello.

When i unzip file, the Input email doesn't work like @giacer.

But X-Plane CTD

 

2020-04-14 22:04:40 TBM900[except.c:171]: Caught EXCEPTION_ACCESS_VIOLATION
Backtrace is:
0 00007FF7AA3406F7 D:\Games\X-Plane 11_Testes\X-Plane.exe+00000000010506F7 ()
1 00007FF7A9D3DE3E D:\Games\X-Plane 11_Testes\X-Plane.exe+0000000000A4DE3E ()
2 00007FF7A9D403B0 D:\Games\X-Plane 11_Testes\X-Plane.exe+0000000000A503B0 ()
3 00007FFAD7F21A6A D:\Games\X-Plane 11_Testes\Resources\plugins\XPLM_64.dll+0000000000011A6A ()
4 00007FFA75BCBBBC D:\Games\X-Plane 11_Testes\Resources\plugins\Gizmo64.plugin\win_x64\Gizmo64.plugin.xpl+00000000000ABBBC ()
5 00007FFA75B4108F D:\Games\X-Plane 11_Testes\Resources\plugins\Gizmo64.plugin\win_x64\Gizmo64.plugin.xpl+000000000002108F ()
6 00007FFAD7F1EE57 D:\Games\X-Plane 11_Testes\Resources\plugins\XPLM_64.dll+000000000000EE57 ()
7 00007FFAD7F1BE09 D:\Games\X-Plane 11_Testes\Resources\plugins\XPLM_64.dll+000000000000BE09 ()
8 00007FF7A9DC9E99 D:\Games\X-Plane 11_Testes\X-Plane.exe+0000000000AD9E99 ()
9 00007FF7AA0EDCEB D:\Games\X-Plane 11_Testes\X-Plane.exe+0000000000DFDCEB ()
10 00007FF7AA0EDAAC D:\Games\X-Plane 11_Testes\X-Plane.exe+0000000000DFDAAC ()
11 00007FF7AA31D5F7 D:\Games\X-Plane 11_Testes\X-Plane.exe+000000000102D5F7 ()
12 00007FFAE3D37BD4 C:\WINDOWS\System32\KERNEL32.DLL+0000000000017BD4 ()
13 00007FFAE3EECE51 C:\WINDOWS\SYSTEM32\ntdll.dll+000000000006CE51 ()
 

Edited by Casmatos

Share this post


Link to post
Share on other sites

Hi, Installed, it seemd to go well ,asked for licence update, said something about a cant be null, seems its updated licences but its seems to be stuck in a loop, and didnt generate a log, last log i have was from yesterday see Xplane log. Also teh GUI couldnt be shut down, kept popping back. Can it be rezized.

Log.txt

Edited by mjrhealth

Share this post


Link to post
Share on other sites
1 hour ago, mjrhealth said:

After reboot, always requesting licence.

Log.txt

Have a look in the Gizmo Preferences window and try turning off:

"Update license at sim start"

 

Thanks for the feedback..

 

 

Share this post


Link to post
Share on other sites

Worked yesterday, today tried it, CTD twice, shortly after the aircraft loaded and the Gizmo license update screen was displayed.

0:04:40.748 G64:  warn: X-Aviation Licensing: RX New license data from server.
0:04:40.748 G64:  warn: X-Aviation Licensing: License is valid.
0:04:40.748 G64: utils.newFolder(D:/X-Plane 11-50/X-Aviation/)
0:04:40.748 G64:  warn: X-Aviation Licensing: Saved license data to disk.
0:04:40.794 G64: debug: --- -- --- -- --- -- --- -- --- -- Firmware Reboot -- --- -- --- -- --- -- --- -- --- -- ---
0:04:40.794 G64: Boot Count: 22
0:04:40.794 G64: OpenAL: Shared OpenAL context..
0:04:40.794 G64: debug: Firmware v20.04.11.0334
0:04:40.794 G64: debug: * gxt.refresh()..
0:04:40.794 G64: debug: gxt: AutoLoading..
0:04:40.794 G64: debug:   gxt.load: Console
0:04:40.794 G64: imgui.NewWindow(Console)
0:04:40.794 G64: debug:   gxt.load: ToolTray
0:04:40.794 G64: debug:   gxt.load: Mute
0:04:40.794 G64: debug:   gxt.load: Preferences
0:04:40.794 G64: debug:   gxt.load: RebootButton
0:04:40.794 G64: debug:   gxt.load: GateKeeper
0:04:40.794 G64:  warn: X-Aviation Licensing: Load license from disk..
0:04:40.794 G64:  warn: X-Aviation Licensing: License is valid.
0:04:40.794 G64:  warn: X-Aviation Licensing: Post load: found valid table.
0:04:40.794 G64: debug: IPC v20.04.10
0:04:40.794 G64: debug: IPC Load complete.
0:04:40.794 G64: debug:   gxt.load: MAXX_RWC
0:04:40.794 G64: debug:   gxt.load: LuaGC
0:04:40.794 G64: debug:   gxt.load: Shell
0:04:40.794 G64: debug: gxt: Completed AutoLoad.
0:04:40.794 G64: debug: firmware_init.lua completed.
0:04:40.794 G64: Run: OnKickStart..
0:04:40.794 G64:         Register Draw Call: OnDraw_Windows
0:04:40.794 G64:                 Alias: toast_Windows_OnDraw
0:04:40.794 G64:                 Alias: shard_OnDraw_Windows
0:04:40.794 G64:                 Alias: OnDraw_Windows_MuteSymbol
0:04:40.794 G64: KickStart completed.
0:04:40.794 G64: X-P Lua Memory Stats:
0:04:40.794 G64:            Max Used;  52933800 bytes
0:04:40.794 G64:              In Use;   7620503 bytes
0:04:40.794 G64:               Gizmo;   6264336 bytes
0:04:40.794 G64:               Delta;   1356167 bytes
0:04:40.794 G64: Setting Graphics-Ready flag true.
0:04:40.794 G64: debug: Calling for TTF load..
0:04:40.794 G64: debug: font_h:0
0:04:40.794 G64: imgui.NewWindow(Gizmo Preferences)
0:04:40.794 G64: imgui.NewWindow(X-Aviation Licensing)
0:04:40.794 G64: debug: Toast Message:(type:info) (X-Aviation Licensing) / (Your license was updated.)
0:04:40.794 G64:  warn: X-Aviation Licensing: Auto license update is on.
0:04:40.794 G64:  warn: X-Aviation Licensing: Always update is on.
0:04:40.794 G64:  warn: X-Aviation Licensing: Requesting license update..
0:04:40.794 G64:  warn: X-Aviation Licensing: update_license()
0:04:40.794 G64: imgui.NewWindow(Gizmo64 Garbage Collector)
0:04:40.794 G64: debug: Undefined function: Run(timer) main
0:04:45.429 G64:  warn: X-Aviation Licensing: RX New license data from server.
0:04:45.429 G64:  warn: X-Aviation Licensing: License is valid.
0:04:45.429 G64: utils.newFolder(D:/X-Plane 11-50/X-Aviation/)
0:04:45.429 G64:  warn: X-Aviation Licensing: Saved license data to disk.
0:04:45.472 G64: debug: --- -- --- -- --- -- --- -- --- -- Firmware Reboot -- --- -- --- -- --- -- --- -- --- -- ---
2020-04-15 08:41:06 TBM900[except.c:171]: Caught EXCEPTION_ACCESS_VIOLATION
Backtrace is:
0 00007FF7568D06F7 D:\X-Plane 11-50\X-Plane.exe+00000000010506F7 ()
1 00007FF7562CDE3E D:\X-Plane 11-50\X-Plane.exe+0000000000A4DE3E ()
2 00007FF7562D03B0 D:\X-Plane 11-50\X-Plane.exe+0000000000A503B0 ()
3 00007FFC72441A6A D:\X-Plane 11-50\Resources\plugins\XPLM_64.dll+0000000000011A6A ()
4 00007FFC5619BBBC D:\X-Plane 11-50\Resources\plugins\Gizmo64.plugin\win_x64\Gizmo64.plugin.xpl+00000000000ABBBC ()
5 00007FFC560FCE6D D:\X-Plane 11-50\Resources\plugins\Gizmo64.plugin\win_x64\Gizmo64.plugin.xpl+000000000000CE6D ()
6 00007FFC5610AB6F D:\X-Plane 11-50\Resources\plugins\Gizmo64.plugin\win_x64\Gizmo64.plugin.xpl+000000000001AB6F ()
7 00007FFC5611092B D:\X-Plane 11-50\Resources\plugins\Gizmo64.plugin\win_x64\Gizmo64.plugin.xpl+000000000002092B ()
8 00007FFC7244587F D:\X-Plane 11-50\Resources\plugins\XPLM_64.dll+000000000001587F ()
9 00007FFC7243BA22 D:\X-Plane 11-50\Resources\plugins\XPLM_64.dll+000000000000BA22 ()
10 00007FF7563582AC D:\X-Plane 11-50\X-Plane.exe+0000000000AD82AC ()
11 00007FF755966433 D:\X-Plane 11-50\X-Plane.exe+00000000000E6433 ()
12 00007FF755D6634A D:\X-Plane 11-50\X-Plane.exe+00000000004E634A ()
13 00007FF75668A8CA D:\X-Plane 11-50\X-Plane.exe+0000000000E0A8CA ()
14 00007FF75667DAA2 D:\X-Plane 11-50\X-Plane.exe+0000000000DFDAA2 ()
15 00007FF7568AD5F7 D:\X-Plane 11-50\X-Plane.exe+000000000102D5F7 ()
16 00007FFC81C07BD4 C:\WINDOWS\System32\KERNEL32.DLL+0000000000017BD4 ()
17 00007FFC8274CED1 C:\WINDOWS\SYSTEM32\ntdll.dll+000000000006CED1 ()

Share this post


Link to post
Share on other sites
9 hours ago, Ben Russell said:

Have a look in the Gizmo Preferences window and try turning off:

"Update license at sim start"

 

Thanks for the feedback..

 

 

ill try but it doesnt give me much time before it resets itself as you can see in the log

Share this post


Link to post
Share on other sites
3 minutes ago, mjrhealth said:

ill try but it doesnt give me much time before it resets itself as you can see in the log

X-Plane/output/preferences/gizmo_prefs.txt

Find (or create) this:

{
 name="AutoLicenseUpdate_Always",
 value=false,
},

 

Make sure the value is false.

 

HTH

Share this post


Link to post
Share on other sites

General note; Please attach full copies of Log.txt when filing bugs with any product.

Giving your developers snippets makes the job much harder.

It would be useful for the posts in this thread to tell me if there's a specific foreign language setting that's causing trouble and it also allows us to see patterns with which products and plugins are loading.

The entire story is needed.

 

Thanks.

Share this post


Link to post
Share on other sites
41 minutes ago, Ben Russell said:

X-Plane/output/preferences/gizmo_prefs.txt

Find (or create) this:

{
 name="AutoLicenseUpdate_Always",
 value=false,
},

 

Make sure the value is false.

 

HTH

All good, manged to save the change before it reset, if you dont teh GUI keeps popping up and clearing the option list, maybe set that as default.

Share this post


Link to post
Share on other sites

Im pretty pleased to see the smoothness difference with version 20 when using the IXEG 733 X-Plane 11.50b4. My FPS is locked at 40.

I also had problems to enter my email address. Could not enter @ . So had copy/paste me email.
And also this activation loop when the option "Update license at sim start" was enabled. Ill send you log.txt and a demostration video.

Gizmo v18

VRT25kd.png

 

Gizmo v20 Beta

vx0dSZh.png

 

Edited by Tom Stian
  • Like 1

Share this post


Link to post
Share on other sites
On 4/15/2020 at 10:29 PM, Ben Russell said:

General note; Please attach full copies of Log.txt when filing bugs with any product.

Giving your developers snippets makes the job much harder.

It would be useful for the posts in this thread to tell me if there's a specific foreign language setting that's causing trouble and it also allows us to see patterns with which products and plugins are loading.

The entire story is needed.

 

Thanks.

I did have this issue with my Swiss French Keyboard but got around pasting the address

FYI, I did have some initial trouble with ctd, but after restart it seems to be working fine.

 

cheers

Share this post


Link to post
Share on other sites

just installed the beta. working great so far, feels very smooth.

xplane 11.50b4 + ixeg 733

only issue i did encounter (mentioned above already), had to copy/paste the email account during activation due to the @ thing

 

great work Ben :)

Share this post


Link to post
Share on other sites
14 hours ago, Tom Stian said:

And also this activation loop when the option "Update license at sim start" was enabled. Ill send you log.txt and a demostration video

Hes already aware, read further up

Share this post


Link to post
Share on other sites
39 minutes ago, Litjan said:

Hi Ben,

having awesome results with this beta.

When I start up, I keep getting this pop-up... any ideas?

Cheers, Jan

1708036218_Gizmoerror.thumb.jpg.8084b2fec87987438cf5500cc85cd658.jpgLog.txtLog.txt

Resolved through DM.

Share this post


Link to post
Share on other sites

You didn't move or erase the existing Gizmo64.plugin folder before you installed the new one.

You merged them.

Delete your Gizmo64.plugin folder and re-install.

Share this post


Link to post
Share on other sites
6 hours ago, Ben Russell said:

You didn't move or erase the existing Gizmo64.plugin folder before you installed the new one.

You merged them.

Delete your Gizmo64.plugin folder and re-install.

Thank you, that did it, I wasn´t sure if deleting the folder was going to remove the license given some posts I´ve seen in the forum.

 

Share this post


Link to post
Share on other sites

A new beta is available for testing:

Hopefully this version will fix the activation errors people have been seeing.

 

If you file a bug report please include a complete copy of Log.txt.

If you do not include a complete Log file your report is of no real use to me.

 

https://www.dropbox.com/s/ehqwaq0yvzsyxmj/Gizmo64.plugin-20.05.26.0354-beta.zip?dl=1

  • Like 2

Share this post


Link to post
Share on other sites

Hello Ben. I downloaded and installed the latest beta. But in the list of simulator plugins, the gizmo does not appear. Version 18 is working fine. Maybe something is missing in the operating system itself? X-Plane 11.50b9. 

Sorry for google translation. 

Annotation 2020-05-26 014800.png

Share this post


Link to post
Share on other sites
17 minutes ago, AtariX said:

Hello Ben. I downloaded and installed the latest beta. But in the list of simulator plugins, the gizmo does not appear. Version 18 is working fine. Maybe something is missing in the operating system itself? X-Plane 11.50b9. 

Sorry for google translation. 

Annotation 2020-05-26 014800.png

Try installing this:

https://go.microsoft.com/fwlink/?LinkId=746572

 

Thanks for your comment.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...