Jump to content

TBM 900 v1.1.7 Update Released!


Recommended Posts

Hello All,

This will serve as a formal forum announcement that we have released the version 1.1.7 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an e-mail by X-Aviation with complete instructions on how to obtain your update. We have made this a very simple process! For those that purchase the TBM 900 from today forward, your purchased download will already be updated to version 1.1.7 for you.

What if I didn't get the update e-mail?

If you did not receive your update e-mail don't fret! X-Aviation has updated our system to allow all customers to update with ease, regardless of whether you received an e-mail for the update! Here's what to do:

1. Login to your X-Aviation account here: https://www.x-aviation.com/catalog/account_history.php

2. Find your original TBM 900 download and re-download the file. It will download as the latest version!

The following is a list of additions/fixes included:
 
What's New / Changed:

Improvements / New Features:

  • Implemented waypoint VNAV constraint entry via the keypad numerical keys.
  • Dropped WXR resolution to get more performance and more realistic "grainy" radar look.
  • Implemented rain, ice and HUD rendering in VR.
  • All sidebar drawer buttons are now available in Plugins menu for enhanced VR usability.
  • All windows can now be opened natively in VR.
  • Reorganized plugins menu to make it more logical.

Bugfixes:

  • Rain effect compute shader would misbehave when camera was far away from aircraft.
  • Legacy rain effect would misbehave when sim was paused.
  • Fixed crash when using multiple monitors on Windows.
  • Fixed deadlock in synthetic vision code causing the terrain not to update and sim to hang when SVS is toggled.
  • Handle the case when minimums are set to 10,000 ft and the number goes outside the PFD box.
  • Missing tire_skid_speed_mtr_sec broke XP11.26 compatibility.
  • Fixed dark outline around windshield due to bad stencil masking in normal vector computation.
  • Copyright on MFD should show build year.
  • Build OpenGPWS with Garmin audio, not Honeywell.
  • Don't allow overflowing the approach minimums value.
  • Disable all GL arrays before starting effects rendering to avoid crashes when arrays are left enabled by external code.
  • Refined gear brake failure messages.
  • Added check for O2 refill to only allow it to be done when the tank isn't full.
  • Fuselage & gear leg repair buttons shouldn't be available when the parts are ok.
  • Fuel caps shouldn't be auto-closed when the user reopens the payload manager after leaving them open.
  • Added crash sound when the aircraft falls on the tail or nose.
  • Moved headset audio source position to right seat cushion to match visual model.

As always, thanks for being a customer with X-Aviation. We appreciate your feedback and support!


Enjoy these latest updates, and stay tuned to the forum as we continually announce the latest happenings.

  • Like 1
  • Upvote 3
Link to post
Share on other sites
  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello All, This will serve as a formal forum announcement that we have released the version 1.1.7 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an

The reason we ask people to remove plugins is to find out which one is causing the CTD.  That's just the first step.  Once we find out which plugin is the problem, Saso then tries to figure out a way

I should precise that this happens only when AOA is up.

Hi guys

That's always a good news when there's an update, and there were many from HS TBM 900 ! ;-)

but the last one..... first try: stuck with 1.1.6 (warn by the plug-in itself !)

soooo i redownload the Installer (second time....), uninstall/install as usual But NOW AS I Enter in the COCKPIT the all THING is Blinking (especially the dedicated Menu)

Skymaxpro Off helped a bit, but it still unusable....

Any idea ?

Link to post
Share on other sites

Just downloaded and tested.  Nothing blinking.  Tried Windowed mode and full screen mode.  

Could you both please attach log files.

Can I ask, are you running more than 1 monitor?

Do you also have updated GPU drivers?

Edited by Goran_M
Link to post
Share on other sites

HI

second time i managed to "solve" this blinking problem by deactivating the more plugins i can, especially "scenic flyer" (but ok when i turn it on again, as the others).

The best solution was to deactivate lens flare effect in skymaxpro.....then turn off terrain plugin's from gluck, then on....

See my log i sent, it was a nice fligt though (tarbes --> bagnère de Luchon, French Pyrénées :rolleyes: B)

Log.txt

Link to post
Share on other sites
1 minute ago, Protes said:

hi, I can not start up x-plane with TBM900, it happened with v.1.1.6 and with this new one too. I think it has to do with maintenance but I do not know how to solve it. Any suggestions?

Please update your GPU driver. You are running a fairly old version and it has helped other users with such an old version before.

Link to post
Share on other sites

Thank You for Update!

Working to me ok, after first test no problems. My only one existed problems in previous versions - Exception with Handler. Will test and in any case will report.

WIN10 Home, i7 8700, GTX1070Ti

Edited by Ico
Link to post
Share on other sites
2 hours ago, skiselkov said:

Please update your GPU driver. You are running a fairly old version and it has helped other users with such an old version before.

In effect, that was the problem, with the new driver all solved.
Thank you very much for the help.

Gracias de nuevo y un saludo.

Link to post
Share on other sites
2 minutes ago, MarkyG said:

Just wanted to say a big thank you to the devs for quickly implementing windshield rain effect VR support. Looks absolutely fantastic! :D

That was all Saso, Ben Supnik and Sid (the latter 2 are from Laminar)
Saso's work ethic is next level.  When he see's a problem, he attacks it with a vengeance.

  • Upvote 1
Link to post
Share on other sites

Hi pilots!

I didn't download the new update yet, just seen the email.

Even if I was in "bad mood" lately with my favorite GA because she broke my World Tour due to CTD in a row, I just want to congratulate the team support to be so responding by providing many hotfix and updates in a short time in order to make our TBM experience better and better.

This "statement" is valid even if I have a future CTD with the new update or not!

Thank you!

 Lkn

Link to post
Share on other sites
1 hour ago, Ico said:

Hello,

sry but must confirm now about that flashing left panel and also other windows opened (Vatsim XSB, also f.ex. PFD window if opened) when AoA is rised. Never before this issue.

OM-ICO

Can you try rebooting your pc and see if that fixes the flashing. 

27 minutes ago, LKN said:

Hi pilots!

I didn't download the new update yet, just seen the email.

Even if I was in "bad mood" lately with my favorite GA because she broke my World Tour due to CTD in a row, I just want to congratulate the team support to be so responding by providing many hotfix and updates in a short time in order to make our TBM experience better and better.

This "statement" is valid even if I have a future CTD with the new update or not!

Thank you!

 Lkn

Thanks!  

  • Like 1
Link to post
Share on other sites
11 minutes ago, Blaser said:

Hi. 1080ti, latest driver. Have restarted PC after install... and I still have the flashing issue. This is the first time I experience this

Same here. Blinking menus, windows, etc... like crazy.  Never before today. Latest updated drivers, rebooting several times, and this only happens with the TBM , after the today´s update.  The other planes load perfectly.  :-(

(Even with the sickness of the blinking, I managed to load a rainy weather situation to admire the windshield effects. I love them.) 

  • Upvote 1
Link to post
Share on other sites
28 minutes ago, Blaser said:

I should precise that this happens only when AOA is up.

Exactly !!!

THAT'S the only CULPRIT ! :-)

but as others said, we can manage to fly our VERY FAVOURITE ACF !!! ;-), though !

No doubt a 1.1.8 will quickly adress this issue.

So NO AOA, an d everything return as usual !

Correct ?

Pierre 

Thanks^2 to the Whole Team/support/community !

(XP11.32r2 build 113201 64b - I7 4790K - Asus Z97PRO+ 16 GB RAM DDR3 2200 + Strix 1080 GTX Oc on SSD = XP11 0.9TB !!! )

Edited by pierolowfinujaz
english 's hard for a french guy !
Link to post
Share on other sites
  • Cameron locked and unpinned this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...