Jump to content

Problems with autopilot altitude

Recommended Posts


I am having issue with the altitude hold with the autopilot. Last flight I made I selected 17,000 feet limit but the autopilot went through that limit. I finally realized that when over 18000 feet so I pressed the VS and nosed down to 800ft/min. The plane would not pitch down. It keeps climbing at 1,500ft/min... I then hit the altitude button again to try to stabilize but no luck, keeps climbing! I am using the latest version of the TBM and the latest non-beta version of X-Plane 11.3x. I doubt it is something I am doing wrong because I use the same procedure with other airplanes and the G1000 without issues, but if it's me, please somebody tell me. Any help would be greatly appreciated. And yes, the autopilot was on. I also tried disconnecting and enabling again, using the speed limit for climb, FLC, etc but same results. Thx


Link to post
Share on other sites

Thanks to both of you for your reply. I just tried another flight as I was pretty sure I had switched the AP trim on but now I made sure and it worked perfectly. I guess I did not do it the time before or perhaps I just flipped it to AP Off instead... Anyways, all good now. Thanks again for the help!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...