Jump to content

VR and Threaded Optimization


Recommended Posts

Hi All,

I wanted to share some thoughts and experiences I've noticed trying to lock down my settings to achieve a constant 45fps in VR with a smooth as possible flight experience.

You can see from my signature that my PC is no slouch and I am one of those "tinkerers" that love going through all the possible combinations to try and achieve the perfect result. As an avid X-Plane VR pilot, the TBM is one of my absolute go-to aircraft when I don't want to fly a tube. Unfortunately I've been really struggling with an issue around threaded optimization (If you are unclear about what I am talking about, I have added a screenshot from the Nvidia control panel below).

For my system, having Threaded Optimization ON helps and gives me a boost in FPS across the board allowing me (with the joint effort of 3jfps) to maintain a constant 45fps in 95% of situations. An example of what I'm trying to achieve is to maintain 45FPS into complex airports, flying into regions such as ORBX's full terrain UK with the TBM in stormy weather. I have included two additional images of the frame rate difference, one with Threaded Optimization on and one with it off. I know it's not a huge jump but when we're talking VR and only needing 45, every one counts when you put all that excess load on X-Plane/your system.

This is now where I hit the problem, every other aircraft I have from the Flight Factor 767, Zibo 737, Aerobask aircraft all run like button in VR. The TBM? I get this sort of pulsing and slight jumping non-fluid movement. Well why not simply have Threaded Optimization turned off when flying the TBM? Well the increase in performance by having it on means I can hit that 95% of situations whereby I can maintain the 45fps for VR. With threaded Optimization off, yes my TBM/Sim is buttery smooth (in less demanding areas) but I take that hit and reduction in FPS when flying into more complex areas that are normally alleviated by having Threaded Optimization on.

Video of Threaded Optimization ON with ASW OFF: https://youtu.be/ECWpQNCwrdA

Video of Threaded Optimization OFF with ASW OFF: https://youtu.be/kh5Wfm_Y6s8

Video of Threaded Optimization ON with ASW ON: https://youtu.be/K84a7xHas2c

Video of Threaded Optimization OFF with ASW ON: https://youtu.be/TwfvpPgHDfE

Video of the Zibo 737 with Threaded Optimization ON and ASW ON for comparison: https://youtu.be/p5o3ZjobORQ

On a side note:

  • All videos taken using an Oculus Rift and OTT 0.85.1
  • I experience the same warping regardless of having 3jFPS on/off
  • locking the framerate to 45 on/off.
  • Using Oculus Tray Tool to Limit the ASW on/off/45
  • My 8700K has Hyper Threading turned off - I got another boost from doing this, So instead of 6 cores + 6 threads, its just 6 cores.

I hope this doesn't sound like nitpicking but I'm curious to know the reasons behind it, if something can be done and what other people's experience has been?

threaded_opti.PNG

threaded_opti_off.png

threaded_opti_on.png

Edited by DJSean00
fix formatting, forgot to add CPU information
Link to post
Share on other sites

Hey mate i can give you straight up advice that the situation you have is more than likely caused by ingame A.A or objrcts setting being to high ..can i ask what you have it set at. ASW is always best to be off. There is also a fallacy that you need on screen fps to be 45fps to have smooth V.R when you can be as low as 22 -25fps and still have a smooth experience.

Sent from my SM-G900I using Tapatalk

Link to post
Share on other sites

Hi @VAL067

Thanks for getting back to me, 

7 minutes ago, VAL067 said:

Hey mate i can give you straight up advice that the situation you have is more than likely caused by ingame A.A or objrcts setting being to high ..can i ask what you have it set at. 

It's currently set to 2x SSAA+FXAA - which I thought was pretty easy going? I will retest now turning it off.

7 minutes ago, VAL067 said:

There is also a fallacy that you need on screen fps to be 45fps to have smooth V.R when you can be as low as 22 -25fps and still have a smooth experience.

Hmm using something like Nvidia Inspector and locking the frame rate to 25fps just made it all stuttery in my headset so I don't know?

XP_Settings.PNG

Link to post
Share on other sites

Do you use Process Lasso if not download it and use. Also in your nvidia settings you have V.R pre rendered settings set a 2 try revert to global and make sure global is set to application controlled. Turn threaded optimization OFF and and set up your affinity mask (how many cores you want dedicated) in Process Lasso. Are you running ant A.A outside of XP11..? The system you have should eat V.R for breakfast so more likely is you have a conflicting setting thats causing your issue, when was the last time you cleared out the shader cache and cleaned out your preferences folder in Xp11 remember to back up your controller and custom settings ,are you using Xenviro ..? where is your ORBX G.B stored seperate drive..?  I run a 4770 not even a K at 3.9Mhz to 4.0mhz and a GTX 1070 and my AA sits at FXAA maybe 2SSAA in rural settings and world set to med  and i run occulus tray at 1.8 and i average 23-45 fps smooth V.R.

Link to post
Share on other sites
2 hours ago, VAL067 said:

Do you use Process Lasso if not download it and use. Also in your nvidia settings you have V.R pre rendered settings set a 2 try revert to global and make sure global is set to application controlled. Turn threaded optimization OFF and and set up your affinity mask (how many cores you want dedicated) in Process Lasso. Are you running ant A.A outside of XP11..? The system you have should eat V.R for breakfast so more likely is you have a conflicting setting thats causing your issue, when was the last time you cleared out the shader cache and cleaned out your preferences folder in Xp11 remember to back up your controller and custom settings ,are you using Xenviro ..? where is your ORBX G.B stored seperate drive..?  I run a 4770 not even a K at 3.9Mhz to 4.0mhz and a GTX 1070 and my AA sits at FXAA maybe 2SSAA in rural settings and world set to med  and i run occulus tray at 1.8 and i average 23-45 fps smooth V.R.

I use Process Lasso however same result, I will revert everything back to default including the drivers and see what happens. No AA outside of the sim and no to Xenviro.

2 hours ago, VAL067 said:

Hey mate im sorry my mind is a bit fried in the middle of renos and cleaning up so im reading half of what is should..if you problem is only with the TBM have you got any of the special effects turned on,,? 

One of the thought mentioned to me is that possible (unlike other addons) the TBM is heavily threaded resulting in a stutter as I have Hyperthreading off. Maybe I should keep everything how it is and go downclock my CPU, put HT back on and retest?

Link to post
Share on other sites

Just to echo my post from the .org so the guys over here can see it.

Hi Sean, 

I recently started watching your twitch streams/youtube videos all beit I have to watch the VOD's as I'm in the UK :D Having said that I don't use VR yet (although I have spoken to you about it on twitch) but I am able to relate to what you are seeing with the TBM.

I am actually seeing the exact same symptoms as you with the TBM even on my monitor. Every other aircraft is fine. When I'm sitting on the ramp with the engine and power off in the tbm my frame rates are normal. 

However whenever I start up and start my take off roll I'm seeing the exact same thing. Its almost as if the sim is slowing down then speeding up in a pulsing manor as you stated. I don't recall seeing this effect in previous versions of the TBM. Please note that I've tried threaded optimization on and off and HT on and off and I still get this exact effect.

I can only assume that the TBM draws a lot of cpu power, removing the resources from xplane and causing these constant slow downs.

If you manage to find a fix for this it would be great. I'm also hovering over the buy it now button on an oculus :D .

Love the streams, keep up the good work.

  • Like 1
Link to post
Share on other sites
9 hours ago, joers182 said:

but I am able to relate to what you are seeing with the TBM.

I am actually seeing the exact same symptoms as you with the TBM even on my monitor. Every other aircraft is fine. When I'm sitting on the ramp with the engine and power off in the tbm my frame rates are normal. 

However whenever I start up and start my take off roll I'm seeing the exact same thing. Its almost as if the sim is slowing down then speeding up in a pulsing manor as you stated. I don't recall seeing this effect in previous versions of the TBM. Please note that I've tried threaded optimization on and off and HT on and off and I still get this exact effect.

I can only assume that the TBM draws a lot of cpu power, removing the resources from xplane and causing these constant slow downs.

If you manage to find a fix for this it would be great. I'm also hovering over the buy it now button on an oculus :D .

 

Great to hear I'm not the only one @joers182 its a bit of an interesting one as I'm in love with the TBM but cannot run it the same as the other aircraft.

It would be good if we could get further comment maybe from the Devs shedding some light on this?

Thanks for the kind words also mate! Glad you're enjoying the streams! ;)

Edited by DJSean00
Link to post
Share on other sites
2 minutes ago, DJSean00 said:

Great to hear I'm not the only one @joers182 its a bit of an interesting one as I'm in love with the TBM but cannot run it the same as the other aircraft.

It would be good if we could get further comment maybe from the Devs shedding some light on this?

Thanks for the kind words also mate! Glad you're enjoying the streams! ;)

Yeah it would be good if anyone else experiencing this could pipe up in this thread.

The interesting thing is that you are able to make it less noticeable by disabling threaded optimization. I've done some more testing today and even tried the 3JFPS plugin which does not help. The fps seems to hold around 30 but I see a lot of fluctuating. The TBM has always been fairly heavy on my system but it is only since the latest version that I'm experiencing this warping.

 

To get the best out of the sim I've now set HT ON, threaded optimization ON and use process lasso to take the sim off of LP1 on my cpu. With all aircraft this seems to work nicely and is the smoothest I've seen so far, however the TBM remains the same and it really makes it un-enjoyable for me.

Link to post
Share on other sites
  • 2 years later...

I know this thread is very old but there's another way of getting a perf boost in the TBM.

Just kill PFD 2 on the CB board, nets me a small FPS gain and makes VR smoother. You don't need PFD 2 for anything so it's fine to have it off.

  • Upvote 1
Link to post
Share on other sites
2 hours ago, Ghhhh said:

I know this thread is very old but there's another way of getting a perf boost in the TBM.

Just kill PFD 2 on the CB board, nets me a small FPS gain and makes VR smoother. You don't need PFD 2 for anything so it's fine to have it off.

Interesting. I will try it. Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...