Jump to content

[SOLVED] Can't disengage brakes


Recommended Posts

Did a bit of testing with 1.0.6.  I've been having the same problem as some where my left and right brakes won't disengage when I have them assigned to my toe brake axis on my pedals.

Preface - My pedals are a bit of a jury rig.  Uncalibrated, I cannot get full deflection on either toe brake axis (maybe about 70%ish).  Usually this is not a problem and once calibrated in XP11, they'll show up in the joystick config page as going from 0-100%.  I also need to reverse the axis for normal usage.  There's no noise at all or problems otherwise.

I tested using the data output for Gear & brakes (index 14).

On the default XP11 C172, I get lbrak and rbrak values of 0.0000-1.0000 without issue.

 

With the TBM900 1.0.6, chocks out, I get:

Pedals released: lbrak: 0.2913; rbrak 0.2190

Pedals depressed: lbrak: 1.0000; rbrak 1.0000

 

Here's what I find interesting - If I untick reverse axis on my left and right toe brake in the joystick config page, here are the values that I get:

Pedals released: lbrak: 0.2118; rbrak: 0.3082

Pedals depressed: lbrak: 0.0000; rbrak: 0.0000.

 

I'm wondering if there's something strange going on between x-plane's calibration and what the TBM is picking up for inputs.  My rudder/toe brake setup is definitely a satellite case, so I can completely understand how this would likely not be noticed in any kind of testing.

Hope the data helps with troubleshooting and thanks for all the incredible support for the module to date.  I'm blown away by the quality of what you folks have produced here.

Link to post
Share on other sites
  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Thanks for the effort guys, 1.0.3 changed things.  The parking brake still doesn't work but is set with the brakes off instead of always on and no option to stop the plane.  After start, the plane run

I've confirmed that X-Plane Joystick Settings.prf is the offending preferences file.  I restored everything besides that one from backup and the issue remains fixed.  I will keep analyzing to find out

If it were easy do you really think we'd be here?

11 hours ago, skiselkov said:

The next build contains a reworking of the way we scan brake assignment axes for changes and should address this. Please test build v1.0.6 when it's out (should be any moment now).

I'll do this both with and without the bad values in the preferences to check

Link to post
Share on other sites
  • borrrden changed the title to [SOLVED] Can't disengage brakes

Not solved in my case with 1.0.7 unfortunately.  I'm almost 100% sure the problem is that the aircraft is interpreting X-plane's calibration settings incorrectly.

I tried recalibrating my toe brakes by artificially only slightly depressing the pedals to about 30% deflection.  The default C172 will go from 0.0000 at brakes released to 1.0000 now at that same 30% deflection, remaining at 1.0000 on through full deflection.

The TBM900 starts at about 0.7000 with brakes released and linearly moves to 1.0000 with brakes fully depressed.

Once again, I'm running my toe brake axis reversed in x-plane.  The results are different, but similarly skewed with them not reversed as per my original post.  I believe this should be easily testable with any set up, just calibrate and accept an axis part-way to its limit.

Please advise if you would like me to start a new thread as this looks like a different problem from what borrrden has been seeing.

Edit: I should note that I'm running a clean install of 11.26, no plugins installed.

Edited by thecurtster
Link to post
Share on other sites
2 hours ago, thecurtster said:

The TBM900 starts at about 0.7000 with brakes released and linearly moves to 1.0000 with brakes fully depressed.

Thank you for the test! This data was the critical bit I've been missing these past few days. An incredibly stupid mistake of mine. Expect a fix in the next build. Apologies it took so long, been chasing my tail around on this and looking in unrelated pieces of code.

Link to post
Share on other sites
  • 2 years later...

I had this problem too.  Thrust master rudder peddles.  Try Reversing the Brakes in the Joystick configuration menu under Thrust master.  Then press full left then full right brake and this solved my problem.

Edited by Kadetsr
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...