Jump to content

[Merged] XP11.10 BETA ISSUES

Recommended Posts

No issues here so far, including ixeg 733


Updated my working xp to 11.10b1 as always do (do not do this at home please, people may result injured :lol:). All my plugins including my external hardware yoke, peddals tq, radios seems to be working just fine.


has to perform some flights yet to test new dynamics, landing on ground effect, etc.


Thanks good ground no longer shakes, now i can go rest in piece


Edited by mmerelles
  • Upvote 1
Link to post
Share on other sites
32 minutes ago, mmerelles said:

Thanks good ground no longer shakes, now i can go rest in piece


This is a good one.. It have always been annoying with that ground shake.

Im making a backup now (yea im a coward ;) ) So soon gonna test the beta myself..

I also hope the default clouds are better and not pixelated. Getting this issue with my ultrawide screen.

  • Upvote 1
Link to post
Share on other sites

as I am not a guru in scripting I would like to ask around if your joystick assignments still work in 11.10b2 with the flywithlua joystick.lua script.

i am aware there is the new profile feature, but some of these "precise" commands are not available, therefore I was trying to go back to lua

here's my script:

--- Joystick and axis definition
local RUDD = (0*40)
local X55S = (4*40)
local X55T = (8*40)
local ARud = RUDD/8
local AXSt = X55S/8
local AXTh = X55T/8


function set_b733()
set_axis_assignment( AXTh + 10, "throttle 2", "normal" )
set_axis_assignment( AXTh + 11, "throttle 1", "normal" )
set_axis_assignment( AXTh + 14, "reverse", "normal" )
set_axis_assignment( AXTh + 15, "speedbrakes", "normal" )
set_button_assignment( X55S + 0, "ixeg/733/autopilot/AP_A_cws_toggle" )
set_button_assignment( X55S + 1, "ixeg/733/autopilot/AP_disengage" )
set_button_assignment( X55S + 2, "ixeg/733/autopilot/at_disengage" )
set_button_assignment( X55S + 3, "ixeg/733/autopilot/AP_A_cmd_toggle" )
create_positive_edge_flip( X55T + 1, "ixeg/733/MCP/mcp_at_arm_act", 0, 1, 0 )
set_button_assignment( X55T + 2, "sim/engines/TOGA_power" )
create_positive_edge_trigger( X55T + 12, "ixeg/733/lighting/land_light_all_act", 0, 1, 0 )
set_button_assignment( X55T + 34, "ixeg/733/flaps/flaps_15" )



if PLANE_ICAO == "B733" then

Link to post
Share on other sites

My joystick script per aircraft assignment is still working just fine.


i wonder what error do you get? without any information provided, it comes to my mind your new xplane install renumbered your hardware, and you are trying to assign over non-existing ids.


have you tried going on xplane to plugins menu, flywithlua, macros, and run provided joystick button map script? press any button to see the id realtime and compare to your script.

Link to post
Share on other sites

thanks mmerelles for your reply,

the issue is that the ixeg specific commands do not get assigned, the X-plane generic ones do.

yes, I have checked the axis and button ids and they did not change vs. previous version

I will try to re-download a clean flywithlua to see if anything got messed up there during backup and update processes

Link to post
Share on other sites

Since upgrade to XP11.10, while configuring the joystick the computer shuts down. This happened in B1, B2 and now in B3. Self shut down comes between 25 seconds to 1 minute 30 seconds from going into config screen...puff black screen and computer is off. When restarting I don't get any dreaded windows blue screen or messages...

I have tried with other aircraft (Laminar 737, Zibo mod) but nothing happened with them only IXEG...XP log file is attached.

OS Win 10 pro. Saitek Pro Fight System with Sergei's throttle mod.

Any help would be much appreciated.



Link to post
Share on other sites

You need to narrow it down. You have a tonn of plugins and scenery that might conflict in some way.  Try disabling all of them except the 737 and see what happens. As you have just discovered, trying early beta's is risky in itself, and if you also fill it up with all sorts plugins and scenery it is russian roulette.... :P

If things that used to work in 11.05 and suddenly don't in 11.10B, then everything should get reported to LR, thats the whole purpose of the beta. 

Link to post
Share on other sites

I've noticed that since XP11.1, when you start the APU, you can hear a default xplane engine sound (horrible synthetic noise) spool up on top of the IXEG APU startup sound. This is from inside the cockpit.

Anyone can confirm this too? Or was this always there and I never noticed it?



Vital Vanbeginne

Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...