Jump to content

[FAQ]Solution to freeze and stutter using FMC


Recommended Posts

15 minutes ago, sthenion said:

Sorry to disagree...in my case the stutter every couple of seconds has nothing to do with the FMC because I haven't been using the FMC, but I tested it with no difference in the results. Also in my case the stutter has nothing to do with Windows Defender, Antivirus etc. I have tried that too. This issue is a specific conflict with this one aircraft. I just got the new PMDG DC6 and was a bit concerned about how it might perform, but it is excellent, silky smooth, no issues whatsoever. No issues with the MD80, 767 or any of the Airbus aircraft. The 737 Classic is the hanger for me too. It doesn't sound like anyone knows what is really causing this or that it is high on the priority list. If you look at the number of posts related to this issue it far outweighs posts on any other topic. Very disappointed.

So I've been doing some non-trivial amounts of Lua development for X-Plane (working on an open-source RAAS implementation, about to be released) and I believe I have an idea where the problem might be coming from. If you're experiencing a periodic stutter, irrespective of actions on your behalf, then one likely source is the Lua garbage collector. There is little you can do to fix this. It depends largely on the developer working on their code trying to lower its memory requirements by e.g. explicitly setting unused data structures to `nil' to inform Lua that it can free them early, or by trying to just create code that is lean on memory consumption as far as practicable. One possible general workaround would be if the plugin implementing the Lua interpreter itself were to run the garbage collector periodically on its own in a background thread (i.e. while no other Lua code is running in the foreground), rather than relying on the Lua engine to determine when to run it (which might not be at an optimal moment).

Link to post
Share on other sites
  • Replies 223
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I'll be working closely with Tom and the team to optimise things like this. I might have to add "Worker Threads" to Gizmo64 so we can do the heavy lifting stuff outside of the game loop. Tha

Most people don't have an issue with frames when not using the fmc. And considering no one knows why, it's hard to pinpoint and work on a solution. As well its computer based. Not fully ixeg based. 

I'm going to allow tweaking of the Lua Garbage Collection allowing you to force it to run every frame. I might add a more interesting GUI to allow full control of the Lua GC params which will all

Posted Images

2 hours ago, skiselkov said:

One possible general workaround would be if the plugin implementing the Lua interpreter itself were to run the garbage collector periodically on its own in a background thread (i.e. while no other Lua code is running in the foreground), rather than relying on the Lua engine to determine when to run it (which might not be at an optimal moment).

Ben Russell can elaborate further, but I believe Gizmo does control Lua garbage collection in the background and he has optimized this process.

Link to post
Share on other sites
8 hours ago, Litjan said:

I beg to disagree as well - the post I quoted was specifically mentioning the performance problem you experience while you MOD a route - and it disappears if you EXECute the mod. I am sure you missed this at a cursory glance, like I am prone to do when skimming over threads.

The problem you experience is certainly not outweighing every other topic, and if you look at the many videos out there on YouTube you may find that the problem varies from computer to computer and is also very differently perceived by users - as in some consider it a total showstopper, some don´t notice it at all.

We are very concerned with this problem that some are having and are determined to cure it - but it is not an easy fix and may take a while. Don´t mistake that for us not caring, though, we do!

Jan

I'm glad to hear its still on the radar. I must have misunderstood one of your replies to another poster that said we are pretty much not able to do anything about this. I kind of gave up at that point. Also as was just suggested I had not done a clean complete reinstall, which seems like an obvious and great idea, so i just re-downloaded the aircraft and reinstalled it. I also pulled all plugins except Gizmo from the plugin folder, but the stutter/hiccup still persists every 2-3 seconds. Some may have a periodic negligible stutter that is tolerable, but few would tolerate what I am experiencing. It destroys the immersion on the ground and at low altitude. The only way to avoid seeing it is to fly at high altitude and never look at the aircraft from an external view. Please keep looking for a solution. Thanks

Link to post
Share on other sites
7 hours ago, sthenion said:

I'm glad to hear its still on the radar. I must have misunderstood one of your replies to another poster that said we are pretty much not able to do anything about this. I kind of gave up at that point. Also as was just suggested I had not done a clean complete reinstall, which seems like an obvious and great idea, so i just re-downloaded the aircraft and reinstalled it. I also pulled all plugins except Gizmo from the plugin folder, but the stutter/hiccup still persists every 2-3 seconds. Some may have a periodic negligible stutter that is tolerable, but few would tolerate what I am experiencing. It destroys the immersion on the ground and at low altitude. The only way to avoid seeing it is to fly at high altitude and never look at the aircraft from an external view. Please keep looking for a solution. Thanks

Absolutely - what you are experiencing sounds completely unacceptable and we are determined to find out why this is. I will make a short movie with my handheld camera (videocapturing software tends to introduce some lagging sometimes) and post it here so you can see how it runs on my system - then we can compare to figure if this is akin to what you see on yours.

Jan

 

Link to post
Share on other sites

Jan

Very hard to tell through video. Looks like the headshake might have been on, but I would have to say that what I saw in the video is not what I am experiencing. If you will look at the 1:34-1:35 mark you will see a more defined and abrupt stutter. Thats close to what I see every 2-4 seconds. If I had to describe it, its as if the sim literally pauses for a millisecond every few seconds. You can watch the wheel rotation from the external view stop/pause as it rolls down the runway. Thank you for making the video and your interest in this issue.

Steve

Link to post
Share on other sites

For me the stutter occurs every 3 seconds or so, very regularly with a background of extremely high frames per second, as if was caused by something not connected with the gpu or cpu load, but rather by something inside the code itself. I've put the plane on a runway in the middle of the ocean with all plugins and stuff removed from the folders but unfortunately the strange issue persists. Maybe it's more noticeable by people like me with a hw not powerful enough (double core cpu etc), but what is weird is the high fps anyway and the fact that the other heavy addons don't cause any trouble...

Link to post
Share on other sites

Greetings all.
I have a solution to my problem with IXEG with fluctuations FPS at regular intervals( for example 45-33-45-33-45-31 every 7-10 seconds)
In the PC I have, among other things: i7 3770K OC 4.6 Ghz and Asus Strix GTX 980Ti 6GB. So, with this did not have a problem with IXEG normally 40-55 FPS for example on KSEA (of course depending on the setting buildings, roads, traffic, etc.)

I've tried several older drivers for NVidia GTX 980 - without success.
I ended up at 368.29

I did some things, and maybe together that solved my problem or maybe it is all resolved only one change in the setting NVidia.

All those things as elimination of the X-Plane from antivirus software and others tips  I had long before the release IXEG.

I used these plugins: PluginAdmin,AutoGate, CustomSBDatarefs004,Gizmo64, PythonInterface, RealWeatherConnector, SilverLining (SkyMaxxPro v3.2), SoundMaxx, X-Life, XPUIPC.

I use FSGRW as weather injector. 

I removed prior to testing the World Traffic plugin and already currently I not use it.  

I changed the number of objects, shadows, traffic, etc., and I stayed in this setting (attached picture 1)

Then I tried to shut down in the scenery.ini all files W2XP (SCENERY_PACK_DISABLED Custom Scenery / 4.w2xp_Africa / America / Europe etc)
It probably has no direct impact on IXEG but it has to do with setting the density of buildings and thus CPU load) But as I write above, most of the time I had no problem to have a high FPS.

And now maybe the main thing that's solved my problem . Changes in the NVidia panel settings/Manage 3D Settings (Second and third image. I am sorry. Panel is in my native language)

 I changed:
 Ambient Occlusion - Performance
 Optimizing Threads - off
Triple Buffering - off
 Vertical Sync - Adaptive (half the refresh rate of the monitor) I have Samsung 27" 60Hz

In the previous GPU (GTX 680) after changing drivers (I can not remember the version) Were more profitable and better  with setting vertical sync  - off.
That's why I used this setting (vertical sync- off)  with GTX 980. Now I use what is written in the blue font.

I now have a stable 30 FPS and perfectly smooth flight simulation without fluctuation FPS. There is still a bit of a problem when changing clouds or weather, but it is probably a problem SDK X-Plane

If after this setting will be the mouse slow.Turn off in the mouse settings "shadow indicator" and increase the speed indicators.

Okay. I think, it is about everything I wanted to write. Perhaps this helps someone. Sorry for my english.

Just a little note 1: In me PC these changes will take effect after the restart not only X-Plane but the restart the entire computer.

Just a little note 2: Before running X-Plane I use this utility from Asus "Asus GPU Tweak II"  section "Gaming Booster" (The image 4)

Best Regards

IXEG1.jpg

IXEG3.jpg

IXEG2.jpg

IXEG4.jpg

Edited by letec
  • Upvote 1
Link to post
Share on other sites

Hi letec,

I am very happy to hear that! I will try to replicate your findings on my computer - we will nonetheless work on this issue - after all it is only our plane that seems to be affected, so it must be something within our plugin code that is causing it.

I am very happy that you were able to find an interim solution for yourself, though, and hope that you can get to enjoy our plane now!

Happy flying, Jan

 

Link to post
Share on other sites

Ok...here is an update after reading letec's post. To be fair I added a new cooling system last weekend, some overclocking changes, a disk cleanup and defrag. Since then I had not used x-plane until tonight. The only Nvidia Control Panel change I had to make was from Vertical Sync 'off' to Vertical Sync 'adaptive half refresh rate' and I now have a noticeable improvement. By the way, I found long ago that I had to use an old driver for x-plane (Im on 337.88). So, on the ground taxing, during takeoff and just after take off its still there, about every 3 seconds, but its much less abrupt and the faster I accelerate for take off the less noticeable it is. Once over 500ft altitude or so and away from the airport the stutter appears to be gone. I did not notice it again during this test flight until I landed and was turning off of the runway. It was definitely more noticeable turning the aircraft during taxi and I could count off a slight, but less abrupt hiccup every 3 seconds, but a dramatic improvement. I fly mostly from airports with freeware addon scenery, my system is an old quad, but its hot rodded, has good ram and graphics card and still gets the job done with all heavy payware aircraft in x-plane and in P3D V3.3. That being said I think the issue is still there for many if not most of us regardless of our systems, but the severity of the problem could vary system to system. If it is ultimately a coding issue I can now use the aircraft and more patiently wait for a final fix. Thanks Letec for the post. You might be on to something.

Link to post
Share on other sites

I'm glad it helped. Try change in the NVidia Panel "The maximum number of pre-rendered images" to 4? There is just problem that will be on each system to react differently.

Here are the figures after changing settings. Such a "jump" is still visible in the data, but in my the simulator( taxi, flying, landing) now this not see.

IXEG5.jpg

IXEG6.jpg

IXEG7.jpg

Edited by letec
Link to post
Share on other sites
  • Litjan pinned this topic
On 21. 6. 2016 at 9:52 AM, letec said:

Try change in the NVidia Panel "The maximum number of pre-rendered images" to 4?

Hm, that unfortunately didn't help in my case. As others say the effect is more pronounced with more overall FPS. I measured this on less populated airport with clear weather and I was running at 48 FPS but dropping to ~34. When I was running on lower FPS (see my post above with the previous measurement) the drops were just about -5 which was not very noticeable but with higher overall FPS the drop is -15.

edit: Locking to 1/2 refresh rate & setting prerendered frames to 4 mostly eliminates the issue. That seems to be the workaround.

I've noticed that these drops seems to fall to about 34-35 FPS for everyone. Well at least for me and letec according to what he described before. So locking FPS to 30 eliminates the drops. It seems to me that there is some periodic function that is unable to run more than ~35 FPS which is the source of these drops. Limiting to 30 makes the FPS smooth because that is apparently within the ~35 FPS limit of that bottleneck. The downside is that you lose the overall smoothness of higher FPS altogether in order to eliminate these perceived drops.

didnt_help.jpgworkaround.jpg

PS: My FPS in the second image is actually locked to 25 as I have a secondary screen a big 50 Hz TV but it's the same result as when letec locked his FPS to 30.

Edited by lanmancz
Link to post
Share on other sites

How do you lock at 1/2 refresh rate? The only option I have on the NV control panel is Vertical Sync - Activated (not Adaptive) which sets the cap at 60 Hz hence no effect on eliminating the stutters.

Link to post
Share on other sites
6 minutes ago, crisk73 said:

How do you lock at 1/2 refresh rate? The only option I have on the NV control panel is Vertical Sync - Activated (not Adaptive) which sets the cap at 60 Hz hence no effect on eliminating the stutters.

Set it to "Adaptive (half refresh rate)" in the NV panel. I have that option there. If you do not perhaps you have old drivers ? Or you can try locking it in Nvidia Inspector.

GTX-680-120.jpg

Edited by lanmancz
Link to post
Share on other sites
On 6/21/2016 at 9:45 PM, sthenion said:

Ok...here is an update after reading letec's post. To be fair I added a new cooling system last weekend, some overclocking changes, a disk cleanup and defrag. Since then I had not used x-plane until tonight. The only Nvidia Control Panel change I had to make was from Vertical Sync 'off' to Vertical Sync 'adaptive half refresh rate' and I now have a noticeable improvement. By the way, I found long ago that I had to use an old driver for x-plane (Im on 337.88). So, on the ground taxing, during takeoff and just after take off its still there, about every 3 seconds, but its much less abrupt and the faster I accelerate for take off the less noticeable it is. Once over 500ft altitude or so and away from the airport the stutter appears to be gone. I did not notice it again during this test flight until I landed and was turning off of the runway. It was definitely more noticeable turning the aircraft during taxi and I could count off a slight, but less abrupt hiccup every 3 seconds, but a dramatic improvement. I fly mostly from airports with freeware addon scenery, my system is an old quad, but its hot rodded, has good ram and graphics card and still gets the job done with all heavy payware aircraft in x-plane and in P3D V3.3. That being said I think the issue is still there for many if not most of us regardless of our systems, but the severity of the problem could vary system to system. If it is ultimately a coding issue I can now use the aircraft and more patiently wait for a final fix. Thanks Letec for the post. You might be on to something.

I tested again last night and to my amazement the stutter was completely gone, on the ground taxiing, taking off and in the air. Very strange, but I am thrilled. Maybe it had to do with making the vertical sync change two nights ago, doing the test flight then shutting down and not rebooting again until last night? I don't know for sure what has cured this, but its gone, at least to my eyes. Will hope that it continues. Not sure that I want to do anymore aircraft updates for fear of it returning?

Link to post
Share on other sites

The tweak is working indeed! I was able to set the vsync to 1/2 refresh through NV inspector and it actually eliminates the strange fps "heartbeat" or at least it's no more noticeable by eye while taxiing. Well, at the cost of capping frames at 30 Hz and losing some mouse sensitivity which is annoying, but the sim becomes very smooth. Great finding guys! [emoji106]

Link to post
Share on other sites
  • 4 weeks later...

I've had these stutters too. I was using a GTX760 with 2GB, the stutters were extremely prominent and annoying.

So I've upgraded to a GTX980 ( MSI ) with 4GB, which was a noticable improvement, however, stutters were still existant at complex Airports whilst operating in complex weather-situations ( Aerosoft EGLL and Skymaxx v3 plus RWC ).

I've decided to return the GTX980 and upgraded to a GTX980ti with 6GB ( Manufacturer: Gigabyte ). This almost eliminated the stutters, they occur occasionally, however, these occurrences are rare and in most situations not a problem to me.

However, I do observe that these stutters are evidently related to the IXEG 737, so I'm hoping that the team will find the cause for these hick-ups.

Whilst the upgrade was a rather expensive solution, it did what it was supposed to do, so I stick to the 980ti now.

I use "adaptive 1/2 refresh rate" and "Threaded Optimization OFF". These tweaks seem to be an absolute requirement. 

Best regards!

Edited by N55E008
Link to post
Share on other sites
  • Litjan pinned this topic
  • Litjan unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...