Jump to content

[FAQ]Solution to freeze and stutter using FMC


Recommended Posts

Could be possible that it is caused by Windows 10? 

I recently moved to w10 and i´ve never experienced OOM issues with Xplane. Now I get OOM very often,especially when I got Chrome,737 and SMP working at the same time.  I got 8gb of ram and never use more than 40%, I think it´s due to the way W10 manage memory.

And this I can´t proof but I think V.1.0.0 was smoother for me.

Edited by Javier
Link to post
Share on other sites
  • Replies 223
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I'll be working closely with Tom and the team to optimise things like this. I might have to add "Worker Threads" to Gizmo64 so we can do the heavy lifting stuff outside of the game loop. Tha

Most people don't have an issue with frames when not using the fmc. And considering no one knows why, it's hard to pinpoint and work on a solution. As well its computer based. Not fully ixeg based. 

I'm going to allow tweaking of the Lua Garbage Collection allowing you to force it to run every frame. I might add a more interesting GUI to allow full control of the Lua GC params which will all

Posted Images

Hello

Just updated to 1.0.2 and really appreciate all of the fixes and efforts in making improvements. I was hoping that there might be something in the first two updates that would mysteriously cure the stutter/pause, but not yet. It starts immediately as I begin down runway. When viewing the plane from the outside as it rolls down the runway you can see the hesitation and the main gear momentarily stop spinning with every stutter. Its a nagging enough issue for me that unfortunately I will have to put her in the hangar and patiently wait for more updates and hopefully a fix.

Link to post
Share on other sites
6 hours ago, sthenion said:

Hello

Just updated to 1.0.2 and really appreciate all of the fixes and efforts in making improvements. I was hoping that there might be something in the first two updates that would mysteriously cure the stutter/pause, but not yet. It starts immediately as I begin down runway. When viewing the plane from the outside as it rolls down the runway you can see the hesitation and the main gear momentarily stop spinning with every stutter. Its a nagging enough issue for me that unfortunately I will have to put her in the hangar and patiently wait for more updates and hopefully a fix.

Also browse the forums a bit with those keywords - quite a few people had problems like you did, and quite a few managed to find a solution (usually not attributed to this aircraft).

Thanks, Jan

 

Link to post
Share on other sites

Although my system is not a powerhouse by any means...by the looks of some of the other systems that are being posted who are also having the same issue, the stutter doesn't seem to be a direct result of an inadequate system, although it could have a bearing on the severity of the issue. I have done everything recommended in the forums Ive even gone into the ACF file and tried reducing the size of the the instruments which maybe made a negligible improvement? I also was running an older Nvidia driver which seemed to work better in X-Plane, but I just updated to the latest driver, set it for performance, lowered X-Plane resolution to Low, but no luck. As mentioned, my stutter not only takes away from immersion it is down right nagging. I will watch and wait for other improvements.

Link to post
Share on other sites
19 hours ago, TimeTraveler said:

Adding my 2cents worth here...I, too have some micro stutters about every 2 to 3 seconds. Some so small they're hardly noticeable but do take away from the immersion.  Like the poster said above, 'Not a JoyBreaker' :)

I have exactly the same problem after going to V 1.0.2

Do not experience this anywhere else (no micro stutters in any of the other of my X-Plane planes - I have a fairly sharp eye for this as this is one of the more important  no-no's in my sim experience. I rather take lower frames than live with micro stutters.

I honestly have to say that it feels as if we have gone slightly backwards since V 1.0.1

Happy coding,

Cheers,

 

Link to post
Share on other sites
15 hours ago, Cheetah349 said:

I have exactly the same problem after going to V 1.0.2

Do not experience this anywhere else (no micro stutters in any of the other of my X-Plane planes - I have a fairly sharp eye for this as this is one of the more important  no-no's in my sim experience. I rather take lower frames than live with micro stutters.

I honestly have to say that it feels as if we have gone slightly backwards since V 1.0.1

Happy coding,

Cheers,

 

heres a video...I'll post this also with a bug report unrelated to this . I agree with you too!

http://youtu.be/7ReRk13wszY
 

Edited by TimeTraveler
vid link
Link to post
Share on other sites
On 27.4.2016 at 5:02 PM, Litjan said:

Hi Philip,

fortunately I get these weird sound "cracks" on my laptop as well - so there is a chance we will track them down. Working on it!

Jan

 

 

Hi Jan,

this one was a hard one (at least for me) but i "think" i have found the issue!

After a while of using X-Plane i noticed the following: these little stops (not the heartbeat every 2 secondes but the ones with more time in between) are not only with the IXEG B733 but also with all other planes. But i did only noticed them annoying with the B733 because of the sound "cracks". Other aircraft with these little "pauses" do play the sound through so i don't noticed them.

Now the searching begun! After a lot of trying i did found this for me. If i do enable the "send data to laminar" i get the stutters with "soundcracks" but if i don't enable this, the sim runs smooth without any stutter for me!! @Litjan  you said you also have these stutters on your laptop but not on the other machine. Could you check if you do have the following button enabled on the laptop and disabled on the other one? Than we would have proof of my finding!

Miniruckler.jpg

  • Upvote 2
Link to post
Share on other sites
On 4/25/2016 at 1:14 PM, Ben Russell said:

The dataref subsystems are highly optimized for X-Planes OBJ8 rendering engine. This was responsible for massive speed increases last year (20%~) with the Saab.

You're going to need to be patient with me on this one.

Thanks for reporting and exploring.

 

12 hours ago, Ubbi said:

Hi Jan,

this one was a hard one (at least for me) but i "think" i have found the issue!

After a while of using X-Plane i noticed the following: these little stops (not the heartbeat every 2 secondes but the ones with more time in between) are not only with the IXEG B733 but also with all other planes. But i did only noticed them annoying with the B733 because of the sound "cracks". Other aircraft with these little "pauses" do play the sound through so i don't noticed them.

Now the searching begun! After a lot of trying i did found this for me. If i do enable the "send data to laminar" i get the stutters with "soundcracks" but if i don't enable this, the sim runs smooth without any stutter for me!! @Litjan  you said you also have these stutters on your laptop but not on the other machine. Could you check if you do have the following button enabled on the laptop and disabled on the other one? Than we would have proof of my finding!

Miniruckler.jpg

 

10 hours ago, Litjan said:

A good lead - I will try that!

Ditto THAT! gonna try it now

Link to post
Share on other sites
12 hours ago, Litjan said:

A good lead - I will try that!

 

13 hours ago, Ubbi said:

Hi Jan,

this one was a hard one (at least for me) but i "think" i have found the issue!

After a while of using X-Plane i noticed the following: these little stops (not the heartbeat every 2 secondes but the ones with more time in between) are not only with the IXEG B733 but also with all other planes. But i did only noticed them annoying with the B733 because of the sound "cracks". Other aircraft with these little "pauses" do play the sound through so i don't noticed them.

Now the searching begun! After a lot of trying i did found this for me. If i do enable the "send data to laminar" i get the stutters with "soundcracks" but if i don't enable this, the sim runs smooth without any stutter for me!! @Litjan  you said you also have these stutters on your laptop but not on the other machine. Could you check if you do have the following button enabled on the laptop and disabled on the other one? Than we would have proof of my finding!

Miniruckler.jpg

That was IT! Totally smooth flight....not one micro or any other stutter issue...my flight LPPT-LPFR was Smooth As Silk. ANY time before changing that setting, always micro stutters...very small, not too distracting, but a real pain in the you know what.

Here's my gizmo log for any forensics ;)

btw, I also unchecked xplane update notification on the theory if I give one permission to check my system, the problem may still be there, but who knows. Nevertheless, unchecking send data to xplane seems to have solved this little annoying problem :) Thank you Ubbi!!!

GizmoLog.txt

  • Upvote 1
Link to post
Share on other sites

I get very high frame rates but with stutter every 5 seconds which is more visible when taxiing.

Perhaps a solution would be to change the frequency that the plugin reads data (less data but more frequent) at the expense of a little frame rate loss.

This sophisticated aircraft has amazingly higher frame rates as compared to similar complex aircrafts.

Sent from my iPad using Tapatalk

Link to post
Share on other sites

Strange, I, too have the Stutter Syndrom back. Was nice while it lasted. Anyway, taking all plugs out and virtually everything possible other posters have done to eliminate this, despite my beefy system etc etc, the nagging stutter is doing it again. And like mrene stated above, high frame rates and while taxiing its more apparent. STILL...The ac is simply amazingly sophisticated and enjoyable :)

Edited by TimeTraveler
Link to post
Share on other sites

No change since the 1.0.3 update. I have no world traffic and only a few airport scenery addons. I uninstalled the airports, but that had no effect. My issue is still the same, exactly as another poster said...good framerates, but my stutter/pause is every 2-3 seconds and worse while on the ground taxiing and taking off.

Link to post
Share on other sites
On April 25, 2016 at 5:51 PM, Litjan said:
  • make sure you don´t fly with a MOD route - it recalculates the route every two seconds (until you EXECute), this is a heavy load on the CPU

I'm hit by this every time I'm instructed by ATC to fly direct to a point, try to execute a step climb or even just modify a VNAV constraint. Any reason why these couldn't be performed in a background thread? It's not like there's a reason why this needs to be performed on the main rendering thread. Most of us have spare CPU cores available, but almost nobody has a CPU fast enough that a one-second computation could all of a sudden be done in an unnoticeable fraction of it.

Link to post
Share on other sites
  • Litjan pinned this topic
  • Litjan unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...