Jump to content
Sign in to follow this  
ionfresko

Gixmo stops DreamEngine and other plugins to load (not SASL)

Recommended Posts

Hi,

I been going crazy about this issue for a while, which I just realized depend on the Gizmo plugin.

It all started some time ago when I realized that the DreamEngine plugin and some other plugins (such as for example X-Tridents 412 and, recently, Colimatas F18) did not load during start. If I however used the XReload plugin I could get things working, although it is a hassle do have to do each time, as I has to reload also the plane afterwards and, in the process, lose all GroundTraffic. The SALS plugin is not affected though.

Then I moved every plugin out from the resources/plugin folder, and everything worked. And then I moved them back, one by one, and everything worked perfectly until I put the Gizmo plugin back in.

I have difficulties to understand, though, why this is so: this problem started, it seems, out of nowhere a month ago or so, and I had the Gizmo plugin  - I have the LES SAAB and the DC-3 - earlier, and everything worked fine then.

This is, as you can understand, a big problem. What exactly does Gizmo control? Is it used only for LES aircrafts, or is it also necessary for SunDog/Maxx-XP SkyMaxx and RWC (which I have both, as well as SoundMaxx)? I can live with having to move the Gizmo plugin back and forth concerning aircrafts, but if I cannot use SkyMaxx, well, that is of course not possible. 

Anyone having a clue?

I have attached two log.txts: one without the Gizmo plugin, when everything is working, and one with the Gizmo plugin, when things doesn't work. In both cases I start with Airfoillabs C172 (which uses the DreamEngine plugin).

Regards, Mikael (ionfresko)

LogGizmo.txt

LogWorking.txt

Share this post


Link to post
Share on other sites

Edit:  just realized that it is not only Gizmo which causes the problem: If I move Gizmo out, and put SilverLining/SkyMaxx and RWC back in the plugin folder, the same issue occurs. It cannot be RWC itself, though, as I bough that on yesterday.

I'm getting even more confused: what is it about Gizmo and SkyMaxx which has happened recently? As for SkyMaxx, it cannot be due to the 3.1 and 3.1.1 updates, as the problem occured earlier. Neither can it be due to v3, as it was released (and I bought it) before the problem started. Neither is the problem the combination of Gizmo or SilverLining/SkyMaxx, as the problem occur when each by themselves are loaded (as well as when they are both loaded).

?

Share this post


Link to post
Share on other sites

Hi.

Creator of Gizmo here.

This is the first report I've seen of these clashes.

I'm about to start reading your Log files and investigating... 

 

Please bear in mind that we have many other customers as well and this is the first report I've seen of any clashes for a couple of years now.

Share this post


Link to post
Share on other sites

Thanks for quick response!

Really strange issue, I agree. The only thing I've changed recently I can imagine affecting things, is the X-Plane update to 10.45.

Some new findings also: when only SilverLining (ie, not RWC nor Gizmo) is loaded, the DreamEngine plugin loads, but not other plugins, such as for the AFL 172 and F18. None of the plugins for the latter two crafts loads. But for some reason the Bell 412 still works perfectly (including its plugin(s) in addition to DreamEngine).

So the case is that, when Silverlining is loaded together with Gizmo, it stops DreamEngine from loading (for all DE crafts), but NOT the other plugin for AFL172 (the one for Colimatas F18 doesn’t load though, in neither case)!? And, then, with only Silverlining loaded, it is the other way around!

I can also add that, when trying differ plugins back and forth, I only change that. To gain systemacy everything else is the same all the time (i.e., settings, airports etc),  and I also try with only these three crafts (i.e., X-Tridents Bell 412 [DreamEngine + other plugin(s)], AFL 172 [DreamEngine +other plugin(s)], and F18 SuperHornet (no DreamEnginge, only other plugin(s)]).

I have also tried things on another, although identifical (except for photo sceneries), installation, and the problems is also identical.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×