Jump to content
Sign in to follow this  
ccleanthous

Saitek yoke and X-Plane 10.xx

Recommended Posts

Greetings.

I have had X-Plane 10.xx for several months and have not been able to resolve the following issue; any help toward this end would be greatly appreciated. I am using the Saitek proflight yoke system with X-Plane. The problem is this: No matter what I do to the settings, the airplane (it doesn't matter which one I use) banks to the left to the point where I simply cannot fly straight and level. Incidentally, I do not have this problem with MSFS-X. I would like to use X-Plane as a training platform as I am working on the instrument rating. Any help will be greatly appreciated.

Cheers,

Charlie

Share this post


Link to post
Share on other sites

Just to make sure but are you sure it is not P-Factor you are experiencing? I know in MSFS X you can turn P-Factor off. 

 

If it is not P-Factor check the yoke calibration settings in windows to make sure it is centering correctly. If not you might have a bad yoke. All Saitek products come with a 2 year warranty. 

Share this post


Link to post
Share on other sites

Pull out the USB-cable and replug it again. It will reset the jittery effects of the Saitek sensors.

Edited by wim1976

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×