Jump to content
Aquilam

Gizmo64, MaxxFX and Alabeo/Carenado conflicts?

Recommended Posts

I'm flying X-Plane 10.30 with Maxx FX and SkyMaxx Pro and I've noticed that the transponder controls do not work for either Alabeo's C172R Cutlass II or Carenado's B200 King Air. Suspecting a plugin conflict, I discovered that disabling the Gizmo64 plugin restores the functionality of the transponders. Unfortunately when Gizmo64 is disabled, Maxx FX stops working too.

 

How do I get both to work--a functional Maxx FX and working transponders for the Alabeo and Carenado aircraft? Suggestions?

 

Thanks.

Edited by Aquilam

Share this post


Link to post
Share on other sites

Define: "Do not work"... what have you tried? Are they manipulators? Can you map hotkeys to them? What happens if you map and press hotkeys?

 

I don't own the Carenado products and no one else has reported any issue. More information will help narrow down any potential resolution.

Edited by Ben Russell

Share this post


Link to post
Share on other sites

By not working I mean that the transponders have a rotary knob that is supposed to turn when you click and drag your mouse cursor over it, except they were not responding to click and drag. Again, I started disabling plugins until I discovered that disabling Gizmo64 enabled the transponders to respond to click and drag. 

 

Note that the transponders were the only click-and-drag panel controls that I found had this issue; so far as I can tell all other click-and-drag panel controls for the Alabeo and Carenado aircraft work fine when Gizmo64 is enabled.

 

Maybe there's a way to hot-key the transponder, but I couldn't find any way to do this.

Edited by Aquilam

Share this post


Link to post
Share on other sites

Thanks for clarifying.. can't offer any advice at this point as you're the only one to report the error and I can't test myself at this time.

 

Watch this thread for more info.

Share this post


Link to post
Share on other sites

I purchased a copy of the King Air from Carenado.com

 

There is no conflict on my system.

 

 

 

More info required:

OS Version info.

X-Plane version info.

 

Copies of Log.txt and GizmoLog.txt

 

 

Please avoid jumping to conclusions and spreading preliminary findings across multiple forums before product authors have had a chance to review and confirm.

It may provide you with some satisfaction but it's not very useful.

 

http://forums.x-plane.org/index.php?showtopic=80397&p=856390

Share this post


Link to post
Share on other sites

I can confirm it's working with those two planes and with MaxxFX (and Gizmo64) installed. I can click and drag around the transponder knobs in every aspect.

OS: Win7

X-plane 10.30

Latest Aircraft and product version

  • Upvote 1

Share this post


Link to post
Share on other sites

I can confirm it's working with those two planes and with MaxxFX (and Gizmo64) installed. I can click and drag around the transponder knobs in every aspect.

OS: Win7

X-plane 10.30

Latest Aircraft and product version

 

Thank you for your independent verification.

Share this post


Link to post
Share on other sites

Thanks for everyone's feedback. Playing with this some more I find that if I work on it enough I can tease the transponder knob from Off to Standby with Gizmo64 running, but not more than that. With Gizmo64 disabled I can then move the knob to On, and in general it's much more responsive when Gizmo is disabled. 

 

Another thing I tried was I went to the Gizmo64 homepage and downloaded the latest version (Gizmo64.plugin-14.01.16.0253.zip) and unzipped it and copied it over the existing installation of Gizmo64 (backing up the existing version first). That solved the transponder knob issue, but then the Maxx FX interface would not function properly (none of the usual options were available when I opened it).

 

I note that the Gizmo64.plugin-14.01.16.0253 files are time stamped one to two days later than the existing Gizmo64 installation, for what that's worth. 

 

Given that this issue thus far appears to not be reproducible, and I'm very much an X-Plane newbie, I'll have to conclude for now that it's due to some peculiarity with my configuration and/or hardware.

 

Thanks again.

Edited by Aquilam

Share this post


Link to post
Share on other sites

Glad to hear you got it working to your satisfaction in the end.

 

I'm not sure why there would be any effect at all when Gizmo64 is running..

Gizmo64 is not intentionally designed to "stomp" on any other plugin or product. There have historically been issues but they have been resolved with help from Laminar.

 

 

To restore full DRM functionality copy the folder Gizmo64.plugin/firmware/extensions/XA_Activation from the officially installed plugin into your custom-patched plugin...

If this restores DRM functionality but also re-creates the reduced functionality you experience when using your other products please report your findings.

 

 

Thanks for your patience and further investigation. Your time and entire X-Plane experience is important to us.

Share this post


Link to post
Share on other sites

...To restore full DRM functionality copy the folder Gizmo64.plugin/firmware/extensions/XA_Activation from the officially installed plugin into your custom-patched plugin...

If this restores DRM functionality but also re-creates the reduced functionality you experience when using your other products please report your findings.

Hi Ben,

 

Thank you again for your attention to this issue. I performed your suggested operation above and the result is that while it restores transponder functionality, Maxx FX no longer works correctly. To help shed light on this I have attached a zip file containing my system specs, relevant log files, and screenshots. Hope this helps.

 

BTW, I should probably mention that my version of X-Plane 10.30 came as a digital download from Steam.

 

Thank you.

 

Walt

 

******************** SYSTEM SPECS ********************
 
OS: Windows 7 Home Premium SP1 64bit
CPU: Intel Core i7-960 Bloomfield 3.2GHz
GPU: GeForce GTX 780 v344.11
Primary monitor: HP ZR24w 1920x1200
Secondary monitor: NEC 90GX2 1280X1024
RAM: 12GB (3 x 4GB) 240-Pin DDR3 SDRAM 1600
Power supply: 750w
 
Mouse: G602 Logitech Wireless Gaming Mouse
Keyboard: Logitech G510 USB Wired Gaming Keyboard
HOTAS: Saitek X52 Pro Flight System (throttle & joystick) 
 
Other USB devices:
 
Razer Tartarus Gaming Keypad
Wacom Intuos tablet model PTK-440

Caranado Transponder Issue.zip

Edited by Aquilam

Share this post


Link to post
Share on other sites

For what it's worth I just purchased Carenado's CT206H Stationair HD and its push-button operated transponder is working fine. The only rotary function that seems a little touchy is the KFC225 autopilot altitude selector which is overly responsive and impossible to set to exact altitudes, but that may be unrelated as I haven't talked to Carenado about that yet.

Share this post


Link to post
Share on other sites

Walt. 

 

I'm sorry but I cannot offer further support.

 

There is no common conflict between Gizmo64 and Carenado products. 

 

I have invested $35 USD of my own funds to investigate this issue. The King Air is useless to me beyond this Quality Assurance test.

Dan is welcome to download my products free of charge and "prove" any conflicts. 

(There are no issues with modern Gizmo64 and his products. There was an issue with X-P 10.25 Steam on Mac but that has been resolved.)

 

We do not offer support for hand modified installs. A date stamp difference of three days will essentially be exactly the same product.

I offered the hint that you may be able to patch your install with the Activaiton Files as a courtesy only. I'm sorry that it has not worked.

 

 

I reviewed your Log.txt files, have you tried removing the FlyRealHUD plugins?

They're very rarely seen in customer installs.

 

 

My advice at this time is to wait for the upcoming Gizmo64 update that will be released for Christmas 2014.

There is a small chance that it may work better with X-P Steam 10.30+.

 

 

As you are the only user out of many thousands reporting this issue I cannot invest further tim, effort or money to resolve it. Sorry.

Edited by Ben Russell
Clarified X-Plane Steam version number.

Share this post


Link to post
Share on other sites

Hi Ben,

 

Thank you for everything you've done to help resolve this. I really appreciate it! And thank you for Gizmo64 which opens up a whole new world of possibilities for X-Plane.  :)

 

Regards,

 

Walt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×