karingka

X-PLANE 10 DEMO!!!!!!!!!!!!!!!!!

137 posts in this topic

yes. About the same here. Some settings are affecting Big time the fps, some seems to be just ignored. For example, chaning the anisotropic filtering to 16X from 2X AND , at the same time, increasing the amount of roads, treees and objects, affected the whole fps by... 1.5 to 2. TWO!!! wtf. However, turning off HDR made a big difference... until there were clouds.

I think its easy to summarize..... there is a problem with Clouds AND/OR HDR. If GPU and CPU are not the bottleneck... what is ???? certainly not RAM ??(coughing 64 BIt)

For me, turn HDR off, I get at least 18-20 fps. NO CLOUDS.. turn clouds on, go back to 12-13 fps. Turn clouds off and turn HDR on, same... 10-12 fps. Both on.... its slideshow

and maybe its worth repeating my specs

i7 core

Windows 7 64 Bit

24 Gb of RAM (useless in 32 Bit environment)

ATI Radeon HD 5870 PCI 16x

:(

I'm still pretty disappointed. I find myself flying XP10 for 10 minutes and switching back happily to X-plane 9 to fly happily with maxed out settings, at 250 knots in a mix of sun and clouds..........at 35-40 fps

Oh and should I mention the few bugs too ?

Like my plane loads at KSEA and move backward slooowly until I apply throttle

no cars on the roads for the first 30 seconds of every flight.

and yes... I have the latest catalyst drivers

I think they've got some homework to do. I'll certainly let them do the homework before I even think of purchasing it.

1

Share this post


Link to post
Share on other sites

Which version of windows 7 are you running that your 24GB of ram is useless. You running the home version?

0

Share this post


Link to post
Share on other sites

Which version of windows 7 are you running that your 24GB of ram is useless. You running the home version?

X-Plane is a 32-bit application. It cannot use the max ram he has.

0

Share this post


Link to post
Share on other sites

As per bens table on the dev blog, a few settings like cars are CPU bound, more like HDR are GPU bound and most are bus bandwidth bound

I must say that I am more than happy with x-plane 10 once you sort out sweet spot settings - for me I have texture res and objects set quite high but HDR and shadows set off.

This gives me a much better looking environment than v9 and some settings that I'll turn on in a few years once i get faster hardware.

I have an i7 at 3.8GHz and an Nvidia 570.

Edited by Kesomir
0

Share this post


Link to post
Share on other sites

I found that my quad core i5 doesn't have more than about 80% load too, RAM isn't the bottleneck, nor is the GPU. hmm..

I also found that if I lower the amount of objects, I get worse FPS than with "tons". Very, very weird, but I don't mind the details.

Sitting on the tarmac at KSEA means the sim isn't really doing anything: no flight model, no scenery loading, etc. There's nothing for the CPU to do.

I did some quick tests. Load the AW139 in v9 at KSEA, with Howdy's custom scenery, and fly around Seattle gives 35-55 fps. Load the AW130 in v10 at KSEA, and fly around some, gives 25-45 fps. Looks about the same.

I think I'm going to have to wait until my DVDs get here to get a real idea of the difference between the two.

0

Share this post


Link to post
Share on other sites

I decided to wait, and went ahead and deleted the demo from my disk.

Here's what I posted on the developer blog, after they posted the "tips for better framerate" post.

thanks for this post. I did exactly as described. However, I still think there is a problem with X-plane 10. I am running the latest version 10.03b. I have 8 cores all running below 50% average, and GPU never exceeds 75% usage with HDR on. I get 30 fps at KSEA sitting on ground blue skies. As soon as I reach 4000-5000 feet, FPS descent to 10!!!! 10-12 fps. GPU is the same as well as CPU. there is definitely something wrong. I can’t be out of RAM for sure.. I have WAY more than 4 gb.

If I put everything to default, and HDR on, and 40% clouds, I still can’t MAX the GPU Activity, nor the CPU activity, nor the memory ? How am I supposed to find the “bottleneck” ?????

It has to be Bus speed. Anyone here knows how I could check that ???

Here's the response I got back on the blog:

Chris Serio says:

December 9, 2011 at 6:32 pm

No one’s denying that there may be something that can/should/will be improved in the sim. You did exactly what you’re supposed to and you now know that your bottleneck is not your CPU or GPU or RAM…so perhaps it’s bus bandwidth. You can try to reduce things that consume bus bandwidth. This also means you can INCREASE your settings so that you consumer more CPU/GPU and make the sim “prettier” without hurting performance so long as you don’t increase bus traffic. We’ll be getting to performance tuning soon where we can talk in more specifics and we’ll have tools to help figure out what’s going on.

In any case, I have to let go. I spent too much frustrating time trying to improve for flyable sim. TO me, having to reduce the number of roads to improve FPS is ridiculous. Less roads mean a lot of houses, line up in the green environment with no roads leading to them, which to me.. is not PLAUSIBLE at all.

Until 10.XY comes out, when they fix this, I will certainly not spend any money on X-plane 10.

I switched back to version 9 now, flying high in the sky :-) at 50-55 fps at 3840x1024, all maxed out settings.

what a deception

Patrick

1

Share this post


Link to post
Share on other sites

I hate to say it but I'm "happy" I'm not alone.

Performance on my machines with the latest betas is VERY bad:

- MacPro 3GHz, 16GB RAM, ATI5870, SSD, 2560x1600, 4Mpix

- i7 4.2GHz, 12GB RAM, OC ATI5870 Eyefinity6, SSD, 5400x1920, >10Mpix

- MacBookPro 2.2GHz, 8 core, 8GB RAM, AMD5970M, 1920x1200, >2Mpix

I have HDR + low shadows on because without those two features I prefer XP9 !

I get extra smooth 40-70fps on each system including MacBookPro in extreme settings on XP9.

(Also I prefer the look of REX clouds. Of course they're not perfect, sometimes doing weird rolls etc but in general look very real, not just "plausible like" an impressionist painting or simple bunch of flat sprites)

On those XP10 betas I get almost slideshow framerate, 12-14fps.

CPU load is in best case is 5-10% of my 8 cores on each computer (max 15% with high speed flying).

It seems a little funny for me, the developers are talking about the hardware bottlenecks instead of programming efficiency and optimization. I think these days no other game developer would sell unfinished beta application with tons of issues and bugs just because it's Winter Holidays time...

But I really wish XP10 all the best!

For now XP10 on my systems is usable only for fine screenshots with 4xSSAA.

I don't think my hardware is outdated just because one simulation application can't run it smootly.

I swichted back to XP9. What a relief, back with very smooth motion with 5 full HD monitors from single PCI 2.0 GPU.

regards

arti

0

Share this post


Link to post
Share on other sites

Posted this at the .org:

So, after messing around with various settings for a while, I'm only sure of a few things.

One is that, if you have a powerful enough machine, with two exceptions which I'll mention later, there isn't one setting which will bring your machine to its knees. I have a 3.33 GHz six-core W3680 and a 1GB Radeon HD5870, and with the exception of those two things, there wasn't one setting I found which made a huge difference in frame rate. Turning on and off AI planes, pushing object density up and down and playing with various HDR settings would only gain, or lose, a few fps here and there. If you have a couple fast cores and a good video card from the last generation or two of GPUs I think the process will be about finding the balance of settings you like rather than the thing to avoid. I have found that I'm not getting anywhere near the frame rates I was in v9, which I can easily run at over 100 fps, but I just think that means v10 is making much better use of my hardware than was v9. If you insist on running v10 at triple digit frames per second, be prepared to turn a lot of stuff off.

Two is that v10 is definitely faster with the same settings in the same place than v9. One of my favorite things to do is to load an F-16, take off from LSZH, turn south and fly through the alps to northern Italy. In v9 I would see frame rates vacillate from over 100 to pegged at 19, and popping over the top of a tall mountain could definitely bring v9 to its knees as it had to suddenly render hundreds of miles of scenery. In v10 I didn't see the frame rate oscillation--it stayed at between 25 and 45 fps--but I flew over the alps with all the eye candy turned on near max, including HDR rendering, and 100 mile visibility, and the sim never bogged me down to 19. There's no way v9 would've been able to show me 100 miles of visibility without promptly dying. Plus, with all the candy on, v10 looks fantastic.

Three, I really do think that 19 frames per second is much smoother in v10 than v9. I v9 I always know when I hit 19, as the sim turns into a slideshow. In v10, if I didn't have the frame rate displaying on the screen, I couldn't tell you when it gets low.

The two things I found which can really kill a machine are clouds and HDR at night with a high object count. Clouds can just be nasty man. I don't understand the technology behind their rendering, but the only time I've seen a slideshow in v10 was in heavy cloud conditions. More experimenting will have to come. HDR at night--making the sim render all those thousands of reflective lights--is another killer, but not as bad as clouds. Flying over KSEA with HDR off gives me 20 fps versus HDR on.

The other thing I've found, mentioned above, isn't really about the rendering settings, at least not directly. As v10 uses more application memory than v9, there's less RAM available for OpenGL to store textures. This means I just can't run with texture res as high as v9. It's a real issue in a place like NYC, where I have a lot of custom scenery (including converted Aerosoft FS Manhattan buildings). I can't load the custom scenery and a high texture res plane like the x737: the sim pushes past the 3GB barrier and crashes. This means, for me, that until Laminar releases a 64-but version, I can't use all of the custom scenery I use with v9. I will have to experiment some--maybe the Aerosoft Manhattan buildings will have to wait for 64-bit. And I'm not sure what will happen if I try to load the fantastic Paris scenery. This is the only real limitation I've found with v10.

Ben's said he's going to release some v10 specific fps tests when he and Laminar get past the rush of bug fixes which came with the initial release. I think I will wait until then to do any more fps testing.

0

Share this post


Link to post
Share on other sites

I also found that HDR and clouds are the big frame killers. I reduced all cloud settings to 20%. I don't really quite understand, what it does different then, because I honestly don't see the difference, but it sure doesn't hit frames as bad as 30% or more. Rendering is on very high, tons of objects and roads and all the rest at default settings gives me nice and fluid flying experience at and around KSEA.

I also found that 15 frames in 10 feels more fluid than 19 in version 9. I am still on the demo, but am confident now, that 10 will improve over time to a point, where it outscores X-Plane 9 in all aspects. I will probably wait to get the aerosoft deal with the extra airports and more european looking buildings (at least that is what I understand they are trying to do), even though I have always bought at the org store and would still like to support them, but it is too tempting...

0

Share this post


Link to post
Share on other sites

OK. I tried it again <_< . This post will be an optimistic one, contrary to the previous ones I made.

I noticed a few things that I haven't seen mentioned anywhere yet on the forums. A few more observations that I hope will get to the developers:

- The sim seems to perform BETTER when NOT using the CEssna 172. For example, sitting in KSEA in a B747 gets me 19fps. In same conditions, loading up the C172 gets me 15 fps. Very strange. IN flight the different is even worse.

- The sim is not constant in the fps. Something changes as the simulation advances in time. I can takeoff at 20 fps, climb and as the sim goes and goes, and as my flight advances, the frame rate drops as if something was stucked in some kind of loop.

- Changing the 3D view to look at my seat only (no external view at all), DOES NOT IMPROVE THE FRAME RATE at all. It seems that currently, there is no link in the code to actually NOT process what the pilot does NOT see. Very strange and you probably have a point of optimization right there. Version 9 would increase the frame rate by a lot when the view changes to just inside the plane vs. external. THis is very strange because the frame rate does go from 19fps to 60fps in clouds.

- The F-sim and F-ACT is very confusing. The F-SIM is constantly sitting at 19.90 fps. However, I've seen it climb by stutters to 20 and even 23, only to drop back to 19.90 again, stable for 10 minutes or so. What causes the F-sim to go up like that??? Even with F-ACT being 24 fps, the F-sim stayed at 19.90. There is some loops that are not working properly. I have looked at the log.txt after. FULL OF ERRORS. errors all over the place. Error finding this, error finding that, etc.

- Flying faster seems to be getting more fps. Strange, completely the opposite of FSX. FSX, the faster you got, the more the computer struggled to display the same amount of things in less time. In X-plane 10, flying faster provided me with faster fps.

- I'm repeating myself here but, something is blocking the fps from going up, even if the GPU is not used to its maximum and the CPU either.

- However, I did get a grasp of realism last night. A brief 5 minutes of excitement, the first one for me in X-plane 10 after hours and hours of playing with rendering options. Clouds set to 25% , flying at night with volumetric fog, and seeing the night lights below from 12 000 feet in the B747, and the reflections in the cockpit. It felt really real. I was astonished at the new cirrus clouds. The cloud effects are amazing. The runway lights from the distance also are huge. HDR is great. Truly beautiful. Knowing that there are loops in the code that are not working properly for sure, I think the developing team will certainly be able to make us gain 100% to 200% performance that we are getting right now. (getting from 12 fps to 24 fps would be a huge step).

:0

Patrick

1

Share this post


Link to post
Share on other sites

Couple random things:

1) Your CPU usage will vary depending on what the sim is doing. Sitting on the ground at KSEA means your CPU isn't doing much, so you won't see much CPU activity; Same with your GPU;

2) Every machine is different. What makes your machine grind to a halt may not effect my machine;

3) If you have eye candy turned all the way up and are still seeing less CPU/GPU activity than you think you should, the weak spot could be the PCI bus. Ben has mentioned that v10 moves enough info around to soak the PCI bus.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.