karingka

X-PLANE 10 DEMO!!!!!!!!!!!!!!!!!

137 posts in this topic

Thanks for the advice Goran

My AA is 16X in X-plane 9 with no issues, so that is why I have set it to 16X in version 10. What does the Shadowing to 3D aircraft means ? WHat is the difference between OVERLAY, STATIC, 3D Aircrafts, and GLOBAL??? anyone knows what 3d Bump maps means ????

I have a pretty decent system I think , and I'm disappointed that I have to turn off all the new features like HDR and clouds. I will give it a try. I've sticked to my ATI drivers because everytime I tried updating them, it became a mess of reconfiguring Eyefinity!! I even had to roll back once because I could not configure the 3 monitors like I used to. SO I probably have a 2 years old ATI driver installed at the moment.

anyway, thanks for the feedback. I will start with low settings and upgrade them one by one, to see which one is the fps killer

thanks and hopefully the driver update helps a lot

Patrick

The shadowing, I'm not 100% sure what all the settings represent. I did have a play around with it today and when it was on "overlay" the aircraft had no shadows cast on it. When i had it on 3D aircraft, the different parts of the aircraft were casting shadows on the aircraft itself. As for the rest of the shadow settings, I'm only guessing that they increase quality. ("Melt the GPU" wasn't particularly appealing for me to try).

Good luck with it. Let us know how it goes.

EDIT: FYI, shaders are the biggest FPS killer. Use them carefully.

Edited by Goran_M
0

Share this post


Link to post
Share on other sites

Well my download finally finished this morning! Loaded up XP, tweaked it to my liking and I'm getting roughly the same FPS in some areas, and better FPS in other areas as xp9. I really like the new interface and the new lighting\ATC\Weather systems! The only thing that I wish would change would be the hotkeys for the views, the new ones are a bit confusing... And one more thing (directed to those working at Laminar) Are we going to get the option to set ourselves 3nm or 10nm from a certain runway? I could not find this option when I was playing around with the demo, and it's really useful for practicing ILS or just landings.

EDIT: Specs are Quad 2.67, 8GB DDR3 Ram, and a Nvidia 9500GT with 1GB of V-Ram.

Edited by Oliver
0

Share this post


Link to post
Share on other sites

Folks,

update your GPU drivers!

This is crucial! There was a HUGE improvement in openGL performance of both the ATI and the nVidia cards when they pushed the updates for Rage. So if you haven't updated your driver since 2011-10-10 you must update now.

Philipp

0

Share this post


Link to post
Share on other sites

Been a while since ive been on here, but XP10 had me having to post, first off it looks "ok" not much better than XP9 really, yes the raods are nice and the night lighting etc, but the textures are still very amateurish.

Next up is performance, on my 2500K@5.2ghz and ATi HD6970 2GB and all left on default i get no more than 22fps, im up to date with all drivers, think it needs a lot of optimizing yet.

1

Share this post


Link to post
Share on other sites

X-Plane 10 is everything and more that i expected! This Demo is sooo cooool. The World is so beautiful and though the 747 is default aircraft, it handles great. It feels heavy and don´t bounce around like a piper cessna.

When Ixeg 737 releases for X-Plane 10 i am going to wet my pants and die from heartattack while approaching for landing is this beautiful sim with ixeg system depth!

0

Share this post


Link to post
Share on other sites

I am not happy

I'm somewhere in the middle between not happy and definately happy. For one, those are some great features and design that went into this sim. But the ATI Radeon HD5870, wich I also have, does struggle. Like you say, it is not really that much dependend on the resolution. I also gain minimal when turning it down. Biggest effect against FSP is shadows (I won't use Global shadows), HDR (but only in 3D cockpit view), water effects (I'll use very low) and Clouds (lowered it to 10%).

The HD5870 seems to handle it very well to display a large amount of objects (buildungs, streets) without too much impact. I have forests now at "filled in", as buildings and streets are much more required to make up the "plausible world". With lots of buildings and the like, it is obvious that this is a beautiful sim. It is even better around smaller cities in the demo region, where the housings and bridges and smaller streets really make a perfect impression.

So here's my plan:

- stop the trial and error with the demo. I have a good impression about what to expect now and I know I will be able to find settings that I can live with, although those won't be the ones I may have dreamed of.

- will wait now for Aerosoft to finish their version, hopefully including a 10.1 or even 10.2. don't wanna go crazy with the bugs now. the release canditate/beta status is very obvious.

- get me a graphics card update, some next gen AMD/ATI, as soon as they are avaiable sometime in 2012 (and fit into the Mac Pro). I want that HDR. I want those global shadows. That's for sure and worth an upgrade.

Meanwhile I keep my fingers crossed for an early X-Plane 10 64-bit. Yes, I already had my first "Xmapped out of memomory" with version 10. Good old friend, still around ;).

But please, I am curious, because I don't exactly understand:

Do we use HDR with volumetric fog and per pixel lightning, or does it replace those, make them unnecessary, like it does with the standard anti aliasing?

1

Share this post


Link to post
Share on other sites

i just taxied slowly with the 747 at night with the cockpit lighting in deep fog. The feeling is incredible. When you light up all the other aircraft with your own landing lights...

The only bad thing about X-Plane 10 demo is the 10 minute rule. What where they thinking!?!??!?!?!?!?!?

0

Share this post


Link to post
Share on other sites

Just made a few more tests, well for an early version i'm hooked.

Performance wise i think it's good, if it can be optimised for the final release it's gonna be awesome

A test on LFMT , G2XPL orthophoto, 120'000 buildings generated from openStreetMap, 25 fps (i7 950, hd6970, 4gb ram)

lfmtthumb.jpg settingsthumb.jpg

1

Share this post


Link to post
Share on other sites

Benny. Nice shots!!! However, I also get 23 fps when in Chase view like that, just overlooking the scenery. The performance decreases dramatically in cockpit mode and when actually doing what the sim is made for : flying

I don't see how you can have those settings and simply not kill the sim like me. I will definitely update the ATI Drivers. I'm anxious to see if it makes any difference!

0

Share this post


Link to post
Share on other sites

Still downloading... 8kb/s with 42 hour to go. I want to cry. :(

I just don't feel like downloading by torrent.

0

Share this post


Link to post
Share on other sites

Still downloading... 8kb/s with 42 hour to go. I want to cry. :(

I just don't feel like downloading by torrent.

Now that I got torrenting sorted out (thanks gthomas), I'd recommend it in this case. Nearly done with the download, took about 2 hours. Hoping for no corrupt files like others have seen, so I left the X-Plane installer running at the same time.

0

Share this post


Link to post
Share on other sites

Hi Graham

this is strange cause I've downloaded the whole thing via Torrent yesterday evening in about 2h30. It was flying at almost 500-600 kb/s

you should check Utorrent settings for the number of connections you're allowing

To come back to the fps issue, I've read on CAX airline forum that if FXAA is turned on, that we should turn off regular anti-aliasing, because they counter-act and this could decrease performance. That's what I was doing (using both), so I will definitely give that a try!

0

Share this post


Link to post
Share on other sites

Benny. Nice shots!!! However, I also get 23 fps when in Chase view like that, just overlooking the scenery. The performance decreases dramatically in cockpit mode and when actually doing what the sim is made for : flying

I don't see how you can have those settings and simply not kill the sim like me. I will definitely update the ATI Drivers. I'm anxious to see if it makes any difference!

Same place, same settings, virtual cockpit on 3 different xp10 aircrafts:

lfmt3thumb.jpg lfmt2thumb.jpg lfmt1thumb.jpg

1

Share this post


Link to post
Share on other sites

1. Someone on dev blog told us we can use our modern fast GPU's like ATI5870. On this public beta it's not yet possible. Very low difference (<3fps) between HDR on/off. [keep in mind the new AMD7970 with PCI 3.0 will be only +-2x faster on paper]

2. They suggest to invest in multicore/multiCPU for best visuals. I get 45% CPU load of 800% (+6AI planes)

3. GPU is not melting either, even GPU fan is dead idle like with the XP9 (2000rpm)

4. GPU load is similar or even little less than extreme settings in XP9 (80% vs 75%)

5. Where is the "Report Bugs to Laminar Research" button?

My systems are system 1:MacPro 3GHz, 5870, 16GB RAM, Lion 10.7.2.

System 2: custom PC 4.2GHz i7, 5870 Eyefinity6 OC latest driver v11.11, 12GB RAM (I get 40-50fps on extreme settings in XP9, 5500x1920. XP10=6-7fps (with no Anti Aliasing).

Without the proper framerate it's too early to talk about the nice visual eye candy (we know, the sound is same as fantastic as before).

regards

arti

Edited by Andrzej Artymowicz
0

Share this post


Link to post
Share on other sites

lol Andrzej... yes.. the sound is fantastic.

I'm happy to see that I'm not the only one with the HD5870 having performance issues and not seeing much impact in turning HDR on or off.

If others could post what their performance is that'd be great. I'm thinking this X-plane 10 is for MAC only lOL

0

Share this post


Link to post
Share on other sites

Andrzej, I just read on the .org that upgrading the drivers to the latest catalyst, can make a difference of up to 15-20 fps MORE. I think we should do that and report back :)

0

Share this post


Link to post
Share on other sites

My drivers on the PC are super fresh Catalyst v11.11 Nov15. No change in fps between v11.10 I guess it's not the drivers fault just not optimized enough (XP9=40-50fps vs. XP10= 6-7fps), as we know on the Mac side we can't upgrade the drivers at all.

0

Share this post


Link to post
Share on other sites

Great link! Guys, AA at 4 is more than enough. I wouldn't use xp9 settings as a comparison, this is totally different.

1

Share this post


Link to post
Share on other sites
I wouldn't use xp9 settings as a comparison, this is totally different.

300% agree with you Simon. I find it unusual how anyone could compare it with settings from a simulator that was made 4 years ago. Even with the updates, XP10's architecture is still radically different from that of 9.70 and should be treated as such. This is a whole new animal. I learnt my lesson when FSX flew onto my PC, I set it to the same settings as FS2004 and my computer burst into flames...well not really...but you get the idea.

Be realistic with settings and let LR do their magic, you know they will, they're clever like that. :-)

Rhydian

0

Share this post


Link to post
Share on other sites

The thing I find funny is:

First it's a Beta Version (another word for work in progress) :), so why are SOOOO many people trying to run this full tilt.

Go with the flow... this SIM rocks!

Be realistic with settings and let LR do their magic, you know they will, they're clever like that. :-)

Rhydian

1

Share this post


Link to post
Share on other sites

Another post at the org mentioned something about reducing the weather default vis setting from its current 50 CAVOC to maybe VFR and it improved a mac`s fps rates big time.

I have not any issues, but if do, I know where to go to get some back. The X-plane learning curve is reducing. Printed off the default key commands sheets for quicker reference.

And once learned, the new View key commands will blow away the old ones.

0

Share this post


Link to post
Share on other sites

http://www.x-plane.c...-and-gpu-power/

Excerpt from the Ben's blog:

"Last week I had a chance to bring X-Plane 10 to ATI and run the sim on a few different modern GPUs (…)We ran X-Plane on a current-generation Mac Pro with a single Radeon HD 5870, driving a 2560 x 1440 display. The 5870 is a very solid card – to do better you have to spend a lot of money.

First: geometry and 3-d.

  • I could turn up almost everything that creates geometry. To keep fps smooth I had to turn down something ONE notch – either world LOD, visibility, or autogen density – but only ONE notch. This is a big step forward from X-Plane 9. (But also remember this is a current generation CPU.)
  • Shadows took a big bite out of the geometry budget – basically the sim has to draw geometry again to build the shadows, amplifying the cost of your objects and trees. Current generation hardware simply doesn’t have enough kick to max shadows out and max all of the 3-d out. Not yet.

We turned on pretty much every effect that isn’t CPU/bus based (that is, the GPU pixel effects) and found that we could run with all of them at 20-30 fps.

If you’ve been using a “medium” tier car (e.g. a GTX 560 instead of a GTX 580, or a 5650 instead of a 5870), this is going to mean less “stuff” in X-Plane 10: less eye candy, or less resolution, or less fps."

===================================================

Wiki's comparision of some GPUs: "very solid cards" and "medium tier cars"

ATI5780 fillrate 27GP/s, 68 GT/s, memory bandwith 153GB/s, bus 256bit, 2720GFLOPs

AMD6970 fillrate 28GP/s, 84GT/s, memory bandwith 176GB/s, bus 256bit, 2700GFLOPs

GTX560Ti fillrate 26GP/s, 52GT/s, memory bandwith 128GB/s, bus 256bit, 1260GFLOPs

====================================================

One of my systems is very similar: MacPro Xeon (4cores, 8HT cores), 16GB RAM, ATI5870, 2560x1600. My framerate is 10-15fps with no HDR, and 7-8 with HDR on.

IMO Someting is not right with the optimization. Popular hiend choice XP10 GPU's in Mac/PC 5870 is still one of the fastest single processor GPU card.

But it looks like Nvidia's runs smoother in this 10.01r1 beta XP10 release.

regards

arti

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.