Jump to content
Steve2457

SMP4 - no cloud shadows

Recommended Posts

Hello,

Thanks for a great product. Just having one issue. Cloud shadows have disappeared. I recall them being there originally and I haven't added any other weather addons. 

If I disable smp through the plugin menu the default cloud shadows instantly show. I have tried smp reinstall. Version is latest version 4.7.3. Xplane is latest version. I did notice the last xplane update did ask to overwrite a number of files. I reinstalled smp after that. 

I have tried turning off and on the cloud shadows option in the smp menu and using different slider values 0 thru 1, pressing "apply changes" each time.

Can someone assist? Thanks.

Steve

Share this post


Link to post
Share on other sites

There are some conditions where we don't draw cloud shadows, such as if you're inside a lot of fog or haze. Turn up the slider all the way to 1, and as a test, try flying above some broken clouds (so you're above the haze) and over  a body of water. The cloud shadows tend to show up best over water.

If you don't even see them in that situation, then there's something definitely wrong.

Share this post


Link to post
Share on other sites

Thanks for the reply. That helped. Can see them, although faint. Also discovered they are not visible if free camera is used to go to altitude with aircraft on ground. Although default cloud shadows do show when doing that. Thanks again.

Share this post


Link to post
Share on other sites
On 3/8/2019 at 6:24 AM, Steve2457 said:

Also discovered they are not visible if free camera is used to go to altitude with aircraft on ground. Although default cloud shadows do show when doing that. Thanks again.

Ah... looking at the code, we do base the AGL altitude used for the effect on the plane's position and not the camera's. Getting the camera's AGL is an expensive thing to do performance-wise (you have to convert the camera coordinates to world coordinates, do a terrain probe to figure out where the ground is, and subtract the two), so I think that's a compromise I made intentionally. I'll try and find some clever way around it though.

Share this post


Link to post
Share on other sites

@sundog In follow up of OPs question: Is there a fix for the cloudshadows in VR turning with the movement of your head? (only left eye does this, right eye is stable)

Share this post


Link to post
Share on other sites
4 hours ago, Servaasd said:

@sundog In follow up of OPs question: Is there a fix for the cloudshadows in VR turning with the movement of your head? (only left eye does this, right eye is stable)

Are you seeing that in SMP 4.7.3? I wasn't aware of that happening.

  • Upvote 1

Share this post


Link to post
Share on other sites

OK, I'll look into it. For now you can disable cloud shadows in the SMP configuration screen if it's distracting.

Share this post


Link to post
Share on other sites

Well, it seems that something changed in a recent X-Plane release that prevents us from retrieving the depth buffer from X-Plane when VR is on. This means we can't properly draw shadows on the ground in VR, since we can't tell where the ground is.

We'll have to disable effects that depend on the depth buffer (mainly cloud shadows and soft cloud / terrain blending) when VR is on, unless Laminar provides us with a new way to do this. I'll send them a note in hopes that they can help.

Edited by sundog

Share this post


Link to post
Share on other sites

Happy to report that with Laminar's help, I've tracked down the issue with cloud shadows in VR. They'll work properly in our 4.8 release.

And now that the underlying problem has been addressed, everything looks really great in VR now if I may say so :)

 

Edited by sundog
  • Like 1

Share this post


Link to post
Share on other sites

I expect it will be handed off for beta testing next week, but from there it's out of my hands...

  • Like 1

Share this post


Link to post
Share on other sites
On 4/20/2019 at 1:44 PM, sundog said:

I expect it will be handed off for beta testing next week, but from there it's out of my hands...

I can't wait :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×