Jump to content
Cameron

TBM 900 v1.1.4 Update Released!

Recommended Posts

Hello All,

This will serve as a formal forum announcement that we have released the version 1.1.4 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an e-mail by X-Aviation with complete instructions on how to obtain your update. We have made this a very simple process! For those that purchase the TBM 900 from today forward, your purchased download will already be updated to version 1.1.4 for you.

What if I didn't get the update e-mail?

If you did not receive your update e-mail don't fret! X-Aviation has updated our system to allow all customers to update with ease, regardless of whether you received an e-mail for the update! Here's what to do:

1. Login to your X-Aviation account here: https://www.x-aviation.com/catalog/account_history.php

2. Find your original TBM 900 download and re-download the file. It will download as the latest version!

The following is a list of additions/fixes included:
 
What's New / Changed:

  • Added HUD circuit breaker.
  • Deepened manipulators and fixed cabin pressure manipulator.
  • Fuel indicator lines were misrendered and showing too low to the actual tank state.
  • Fuel gauge lines should use a gradianted pattern, instead of a flat color.
  • Added GPU exhaust particle effect.
  • Added remap from X-Plane's TOGA_power to trigger our takeoff guidance and kill X-Plane's tendency to give full power as if we had A/THR.
  • Added propeller tip vortices at high power and high humidity.
  • Added FUEL SEL AUTO checklist item into the engine start checklist.
  • Removed superflous AUX BP AUTO checklist item from the after start checklist.
  • Implemented new airspeed and altitude tapes with better annunciator mode management.
  • Implemented custom VS tape.
  • Changed G1000 fuel units to gallons - should now show correct units in FPL fuel predictions.
  • Fixed broken AP/TRIMS disconnect and AP off buttons in XP11.30.
  • Switched to using tags for version IDs for more readable version strings.
  • Use XPLMNavRef to avoid airports with inconsistent ICAOs in the X-Plane nav database confusing us.
  • Implemented maximum climb torque and optimum cruise torque marks on the torque gauge.
  • Squashed more marching ants.
  • Added directly settable datarefs for all switches, so integration with external controllers and cockpits is simpler.
  • Added direct set commands for all toggle controls to simplify integration for cockpit builders.
  • Fixed broken alternate static port manipulator.
  • Implemented DIMMER light switch on the overhead.
  • Fixed missing approach pathways on ILS approaches.
  • Adjusted rear seats so armrests are touching.  Adjusted manipulators to reflect armrest changes.
  • Fixed Nav/Strobe lights to be closer to the real thing.
  • Chocks were sometimes misaligned. Added a vertical deflection dataref to align chocks to landing gear.
  • EDM should be using the GASC-computed cabin altitude, not true cabin altitude.
  • Bad fx_lin_multi field array could cause an assertion failure.
  • Obstacle database was broken because FAA had switched to HTTPs and we weren't expecting that.
  • XP11.30 reordered how the airport loading message is sent at start, leading to a double aircraft system init/deinit on aircraft reload via the Developer menu.
  • Indicated airspeed computation was affected by pitot covers, yielding broken behavior for engine driftdown in windy conditions.
  • Documented all custom switch datarefs + commands for cockpit builders. Can be found under Documentation/DataRefs+Commands.txt.
  • Cockpit manipulator on MFD keypad for digit 0 has incorrect command assigned
  • Fixed TerraMax license conflict causing TerraMax to sometimes deactivate momentarily.
  • Fixed misaligned LOC with runway centerline.
  • Added manual vertical realignment of GS transmitters with actual sim terrain elevation.

As always, thanks for being a customer with X-Aviation. We appreciate your feedback and support!


Enjoy these latest updates, and stay tuned to the forum as we continually announce the latest happenings.

  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, ManxJason said:

Other than windshield effects what VR issues are you having?

Windshield effects and icing effects and with the HUD.

Edited by Cyrex1984

Share this post


Link to post
Share on other sites
42 minutes ago, Cyrex1984 said:

Windshield effects and icing effects and with the HUD.

What HUD issues? I know the angle of attack indicator deosnt work, I don't think 

Share this post


Link to post
Share on other sites
9 minutes ago, ManxJason said:

What HUD issues? I know the angle of attack indicator deosnt work, I don't think 

Yes the angle of attack.

Share this post


Link to post
Share on other sites
5 minutes ago, Cyrex1984 said:

Yes the angle of attack.

Ok no, so only two real issues then outstanding for VR. I was concerned for a moment that i was missing something 

Share this post


Link to post
Share on other sites
5 minutes ago, ManxJason said:

Ok no, so only two real issues then outstanding for VR. I was concerned for a moment that i was missing something 

The rain effect and ice is most important for me, better imersion and more realistic when flying in bad weather.

Share this post


Link to post
Share on other sites
1 hour ago, Cyrex1984 said:

The rain effect and ice is most important for me, better imersion and more realistic when flying in bad weather.

Yeah likewise. Laminar also need to fix the rain in VR bug (when rain moves with your head movement)

Share this post


Link to post
Share on other sites

When I log into my account on the X Aviation website I cannot download update.  It says "update in progress" and cannot be clicked.   Is 1.1.5 already being released???

Share this post


Link to post
Share on other sites

Hi, sorry for the "stupid" question.... 

I can´t find the new download...

I signed in to my account, went to "View the orders I have made."
But I don´t find a download link....just:

Take Command!: Hot Start TBM 900  Update in Progress

Any advice?

 

BR and THX

 

Ups: Just read the new post :)

 

 

Edited by BBBE826

Share this post


Link to post
Share on other sites

I'm on 1.1.4b and Terra Max conflict hasn't been solved . It keep reloading every 5 texture every minutes.

Question to developers: Do you want to get access to my PC and remotely try to identify problem with licensing plugin? It's been going on for a long time and very frustrating! 

TBM900_28.png

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, ManxJason said:

Yeah likewise. Laminar also need to fix the rain in VR bug (when rain moves with your head movement)

I dont think LR is focusing adressing this issue, the bug was reported back in 11.20 and still not fixed.

Share this post


Link to post
Share on other sites
52 minutes ago, sd_flyer said:

Question to developers: Do you want to get access to my PC and remotely try to identify problem with licensing plugin? It's been going on for a long time and very frustrating! 

No, we don't. That's pretty much useless in all honesty.

As of now we don't have further answers to this. Thus far it was tested on multiple machines who had the issue and could concur that it did fix the problem. Until we get more people claiming the same as you that it has not we can't do much to diagnose.

Share this post


Link to post
Share on other sites
56 minutes ago, sd_flyer said:

I'm on 1.1.4b and Terra Max conflict hasn't been solved . It keep reloading every 5 texture every minutes.

Although I could resolve the issue on my test machine (where the issue was reproducible) and we've had beta users reporting it fixed as well, there is some chance we might have missed some corner cases, or some other factor that might apply specifically to your setup. We'll keep at it and try to figure out what the matter is.

Share this post


Link to post
Share on other sites
1 hour ago, Cameron said:

No, we don't. That's pretty much useless in all honesty.

As of now we don't have further answers to this. Thus far it was tested on multiple machines who had the issue and could concur that it did fix the problem. Until we get more people claiming the same as you that it has not we can't do much to diagnose.

Diagnose my XP11 setup. I had Dream Foil Creation developer in the past did just that. I gave them remote access to my computer and they fixed the problem.

Also pleas explain why more people need to claim the same problem? Am I not your customer?

 

Share this post


Link to post
Share on other sites
1 hour ago, skiselkov said:

Although I could resolve the issue on my test machine (where the issue was reproducible) and we've had beta users reporting it fixed as well, there is some chance we might have missed some corner cases, or some other factor that might apply specifically to your setup. We'll keep at it and try to figure out what the matter is.

I can offer my cooperation/help. I've been in software engineer business for 20 years.

Share this post


Link to post
Share on other sites
6 minutes ago, sdflyer said:

Also pleas explain why more people need to claim the same problem? Am I not your customer?

Because a single case does not solve this type of problem. We need a greater pool to leverage chasing down the rabbit hole and finding the common denominator.

I'm glad DreamFoil was able to help you do whatever it was you needed help with remotely. That won't solve this problem, unfortunately.

Share this post


Link to post
Share on other sites

Thank you for all the updates. I will thoroughly test 1.14b and see there is still a conflict with terramax. So far by selecting Deep Winter as opposed to Auto I have not had any issues while on th ground with engines off. I will report back later this week and do a flight test by selecting auto.

Cheers!

Share this post


Link to post
Share on other sites

Hey guy's I just did a new flight with the update I downloaded last night, and noticed the CRS is not turning so I waxs not able to do the ILS approach I was trying to do into KTVL, CRS was stuck at 165 would not turn to the 171 I needed.

Share this post


Link to post
Share on other sites
5 minutes ago, kevinm1 said:

Hey guy's I just did a new flight with the update I downloaded last night, and noticed the CRS is not turning so I waxs not able to do the ILS approach I was trying to do into KTVL, CRS was stuck at 165 would not turn to the 171 I needed.

Just to clarify, you're saying the course needle was not turning?  Because the course needle doesn't turn by itself.  You need to set the course yourself, and then the deviation bar will move according to where you are.  For the deviation bar to move towards the centre, you will need to be on an intercept heading.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×