Jump to content
Sign in to follow this  
Fropa

IXEG 737 In game main menu unusable... HELP!!!

Recommended Posts

Apologies if I'm posting in the wrong place, but I need help...

 

Just installed the IXEG 737 today. I'm running X-plane 11.30rc2. Whenever I try to change the aircraft configuration from engines running to turnaround in the preferences menu, the menu freezes and I have to reboot the aircraft from the console. I also notice some red text in the console on startup after I load the aircraft, but I'm a computer noob so it's all gibberish to me. I also get a weird message when exiting X-plane. I think they are both referencing some missing files, which doesn't make any sense since I followed the installer's instructions exactly. I'll attach my log file below, as I'm sure that will paint a much better technical picture than I am able to. Would appreciate any help I can get, as not being able to use the in game menu/set presets makes the aircraft unusable, a concept I don't want to think about having just dropped $75.

 

Thanks for your prompt response,

-Fropa

Log.txt

Share this post


Link to post
Share on other sites

Good morning, Fropa...

when glancing over your Log.txt while I munch my breakfast I noticed that X-Plane is complaining about not being able to save (write to) the B733_prefs.txt file. It says:

The file could not be saved. Check that the directory still exists and is not flagged read-only.
0:06:32.464 E/SYS: | C:\Program Files/X-Plane 11/Aircraft/X-Aviation/IXEG 737 Classic/B733_prefs.txt
0:06:32.464 E/SYS: | The file may be flagged as read-only.
0:06:32.464 E/SYS: | Change the permission on the file so it's not read-only, or create the folder listed in the file path.

This strikes me as odd - but COULD be the reason that there is trouble when you are trying to change the aircraft configuration.

I will try myself now in rc2, there is always the chance that something got messed up with these betas...

I will report back.

Cheers, Jan

 

Share this post


Link to post
Share on other sites

Ok, checked on my side and everything works as expected in 11.30rc2.

Keep in mind that changing the aircraft state is only possible with the IXEG side-screen pop out menu "preflight" - not the X-Plane 11 airplane screen option "start flight with engines running".

There is always a chance of some weird interaction when running with other plugins - so another troubleshooting step would be to disable those (XRaas, etc.)

Let me know how it goes!

Jan

 

Share this post


Link to post
Share on other sites

Good afternoon Litjan, and thank you for your prompt response. 

On your advice, I first tried in-game disabling all plugins except the Gizmo64 plugin, which I know IXEG needs in order to run. It did not fix the issue. There were a couple of other things I noticed as well. One from the log.txt file (in addition to what you referenced, which is a message I get when exiting X-Plane 11), and another from the IXEG console in game. 

From the IXEG console in game, I get a red text when the aircraft loads which says the following:

          356.456: Run(xp): OnBeforeReboot: [string "ixeg.733.config.lua.ral"]: 11

          9: attempt to index local "configfile" (a nil value)

I don't know what the above message means, but I'm guessing it has something to do with what's going on. I should mention I understand that only the popup IXEG 737 main menu can be used to configure the aircraft. Whenever I use that menu to configure the aircraft, eg. adding winglets, it'll sometimes work, but then the buttons on that menu will become unclickable after making any change. Something else I noticed, this time from the log.txt file:

0:04:24.229 I/OVR: Reading VR conf file: Aircraft/X-Aviation/IXEG 737 Classic/B733_vrconfig.txt
0:04:24.229 W/VRCONFIG: Could not find vr config file: Aircraft/X-Aviation/IXEG 737 Classic/B733_vrconfig.txt
0:04:24.229 W/VRCONFIG: VR Config data file for Aircraft/X-Aviation/IXEG 737 Classic/B733_vrconfig.txt is not valid!
0:04:24.229 W/MANIPS: Could not find vr config file: Aircraft/X-Aviation/IXEG 737 Classic/B733_vrconfig.txt
0:04:24.229 W/MANIPS: VR Manips file for Aircraft/X-Aviation/IXEG 737 Classic/B733_vrconfig.txt is not valid!

Does the above have anything to do with what's going on? I'll attach my latest log.txt file as well. I'm really hoping you're able to fix this, because not being able to use the popup IXEG 737 in game menu makes the aircraft unusable. 

 

Thank you, 

Fropa

Log.txt

Share this post


Link to post
Share on other sites

UPDATE:

If I move the IXEG 737 Classic folder into the Laminar Research aircraft folder, the normal location for addon aircraft in X-plane 11, everything works perfectly! The only problem is the warning message that appears in the middle of the screen saying the file path is incorrect and to restart X-plane, and I can't close out of it. What's even sillier is that if I could just close the warning, I could fly without any problems! So what gives?

Thanks, 

Fropa

Share this post


Link to post
Share on other sites

What gives is that you have improper permission settings on the folder it's supposed to be installed in. Make it writable.

Share this post


Link to post
Share on other sites

I'm assuming you're on windows. That would be OS settings from Microsoft on that folder. This is not an IXEG or even X-Plane issue, but a personal computer permission issue.

Share this post


Link to post
Share on other sites

Yes I'm on Windows 10. Just to make sure I'm on the correct folder, it's the X-Aviation folder inside the Aircraft folder under X-Plane 11's main directory. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×