Jump to content
Cameron

TBM 900 v1.1.1 Update Released!

Recommended Posts

Hello All,

This will serve as a formal forum announcement that we have released the version 1.1.1 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an e-mail by X-Aviation with complete instructions on how to obtain your update. We have made this a very simple process! For those that purchase the TBM 900 from today forward, your purchased download will already be updated to version 1.1.1 for you.

What if I didn't get the update e-mail?

If you did not receive your update e-mail don't fret! X-Aviation has updated our system to allow all customers to update with ease, regardless of whether you received an e-mail for the update! Here's what to do:

1. Login to your X-Aviation account here: https://www.x-aviation.com/catalog/account_history.php

2. Find your original TBM 900 download and re-download the file. It will download as the latest version!

The following is a list of additions/fixes included:
 
What's New / Changed:

  • Deleted prop stripes from 1 side of blades
  • Re-added pens on glareshield
  • Fixed multi-monitor issues with sidebar drawer positioning and screen flicker
  • Flightlog was storing altitude as meters instead of feet
  • Flight recovery with engine running was broken
  • Implemented X-IvAp COM2 workaround.
  • Added disabling of COM1/2 on initial load
  • Landing lights were on with no power
  • Reflection light source for standby instrument on the glareshield needs to be animated
  • GASC cabin rate should be higher, seen up to 890 ft/min IRL
  • Small VRAM memory leak fixes
  • Implemented custom logging facility to capture crash dumps without overwriting them
  • Flightlog units were incorrect for GPS alt and waypoint distance
  • Position restore would incorrectly place aircraft into the air when ground lowered due to terrain flattening settings change or change in scenery
  • Bad unit conversion would produce spurious terrain alerts on landing at high-altitude airports
  • Increased RTC/ITI runway distance inhibit threshold to allow for approaches into runways with close-by terrain.
  • Airportdb could leak open file descriptors
  • Possible use-after-free of runway data in runway data update

As always, thanks for being a customer with X-Aviation. We appreciate your feedback and support!


Enjoy these latest updates, and stay tuned to the forum as we continually announce the latest happenings.

Share this post


Link to post
Share on other sites

thank you for fixing multi monitor issue.

bug report here

1. side bar is gone, any alternative I can change payload?

1. autorouter.aero user name & password is gone

Edited by cpuwolf

Share this post


Link to post
Share on other sites

Sidebar appears on my 3 monitor setup. I'm not using windowed mode, just the normal defaults within XP for 3 screens. I'm also using 11.26r2 with Windows 10 (Nvidia 1080)

Edited by mfd529

Share this post


Link to post
Share on other sites
1 minute ago, mfd529 said:

Sidebar appears on my 3 monitor setup. I'm not using windowed mode, just the normal defaults withing XP for 3 screens. I'm also using 11.26r2 with Windows 10 (Nvidia 1080)

wow...what if I only have 2 monitors, no "left side bar"...hhaha

Share this post


Link to post
Share on other sites
14 minutes ago, mfd529 said:

ok just reset to 2 screens and reloaded the aircraft. Sidebar appears for me.

thanks for your info. but reload doesnt work for me

Share this post


Link to post
Share on other sites

Side bar disappears for me in full screen mode.  But, if I switch to windowed mode, the side bar re-appears.  Only happens in XP11.30b5 version.  In XP11.26r2 the side bar is OK.

Edited by cwjohan

Share this post


Link to post
Share on other sites
58 minutes ago, cwjohan said:

Side bar disappears for me in full screen mode.  But, if I switch to windowed mode, the side bar re-appears.

yes, same here with "left payload sidebar", not "right gizmo sidebar"

Edited by cpuwolf

Share this post


Link to post
Share on other sites
6 hours ago, cpuwolf said:

thank you for fixing multi monitor issue.

bug report here

1. side bar is gone, any alternative I can change payload?

1. autorouter.aero user name & password is gone

My dual monitor setup, with TBM tool bar visible.  I'm suspecting the problem you're having has to do with your set up somehow.
 

Screenshot_1.jpg

Share this post


Link to post
Share on other sites
31 minutes ago, Goran_M said:

My dual monitor setup, with TBM tool bar visible.  I'm suspecting the problem you're having has to do with your set up somehow.
 

Screenshot_1.jpg

I really dont have special setting in graphics. you can see above, not only me. and I am software engineer, I know how to report bug.

firstly I would suspect myself:P. I do have 1130b5 beta, but...seems it is not beta related

193181246_zbmate_com_obs_addon022018-11-21.thumb.jpg.a93e45d12d3f175dde5fe6cc71b9ed12.jpg

Edited by cpuwolf

Share this post


Link to post
Share on other sites

@Goran_M

bug title can be simplified as:

title: Left side bar disappears in full screen mode, but windowed mode works

description: it has nothing to do with multple-monitor setup

priority: midium (current windowed mode works)

solution: if Left side bar sub-function: payload, chorks, maintainance,etc, these sub-function can be call out from plugin menu, then this bug is not important at all

Edited by cpuwolf
  • Like 1

Share this post


Link to post
Share on other sites

seems like go to windowed mode until they sort it, I always use window mode so didn't see any difference...

Share this post


Link to post
Share on other sites

Thank you very much for the aircraft and updates!

I have found a small issue with the G1000's timer on the pilots PFD. The timer will only count to 59min 59sec before zeroing out. The hours will remain at 00.

 

Share this post


Link to post
Share on other sites

Single monitor here and can't access left side bar (when simulator is running in "Full Screen Simulator" mode under XP11 Graphics setting. 

image.png.5c7be0dc478f82c76ab22fdd9fd79ef8.png

 

Workaround is to switch to Windowed Simulator mode under XP11 graphic setting and left bar appears. Like mentioned above it will be ideal if each of these items can be called from TBM 900 Plugin menu. 

Share this post


Link to post
Share on other sites

Unable to download Hotstart TBM 900 on MAC. When attempting to run osx installer.dmg I get an error saying "no mountable file systems". Does anyone have a solution? 

Edited by DannyB

Share this post


Link to post
Share on other sites
45 minutes ago, DannyB said:

Unable to download Hotstart TBM 900 on MAC. When attempting to run osx installer.dmg I get an error saying "no mountable file systems". Does anyone have a solution?

This is an issue with your Mac. You'll need to google the error for ways around fixing it.

Share this post


Link to post
Share on other sites

Dual Oxygen Mask Issue Solved!

I was using Interface Size at 150%, now changed to 100% and the issue is gone.

I'm running the sim in a 1440p 24" monitor so a bigger interface size is desirable but the side bar got too big (looks more then a 50% increase IMO) so I decided to get back to 100% and then found that the issue with the masks were gone as well.

Cheers

 

Share this post


Link to post
Share on other sites
22 hours ago, Sims Smith said:

Single monitor here and can't access left side bar (when simulator is running in "Full Screen Simulator" mode under XP11 Graphics setting.

If you are running on XP11.30b5, then that's an issue that got introduced in beta 5. They changed the way monitor coordinates are represented, which confuses the sidebar window positioning code. Waiting on their response to see if they'll revert it back to the old behavior, or we'll simply have to re-implement that piece for XP11.30 and later.

  • Like 4

Share this post


Link to post
Share on other sites
On 11/21/2018 at 12:22 PM, SirJohn62 said:

Same here. Side bar disappears in x.plane 11 full screen mode with 1 monitor.  But, if I switch to windowed mode, the side bar re-appears.

+1.. works with 2 monitors ore more :)

Freddy

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×